Jump to content

Warning to all buying the RGB K70/95 in the UK/EU

Dicehunter
 Share

Corsair in their infinite wisdom have not released the correct firmware for their new RGB K70's/K95's in the UK/EU meaning some keys are not lighting up due to having a different layout.

 

Mostly everyone can only select North America, China or Taiwan for "Current Layout" but not German, UK, Nordic etc... resulting in some keys lights being turned off, Corsair have said they are working on it.

 

Just a headsup for those buying :)

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

Doesn't everyone just use US international?

 

Nope because US is useful just for US, US and UK layouts are completely different i.e the placement of quite a few keys and the Nordic, German etc... have a lot of different letters and accents.

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

Doesn't everyone just use US international?

 

Because it's tedious to switch IMEs and a pain in the backside to memorize the layout of the IME keyboard...

Link to comment
Share on other sites

Link to post
Share on other sites

What would you expect from Corsair...

 

To be honest their standards are starting to slip, I've gone through 4 x H100i's each with a different problem i.e 1 had sheared screw holes when it arrived, 1 came with the pump top loose, The third 1 sounded like it was being tortured and the 4th thankfully is pristine.

 

I've also been through 3 x standard K95's all with different dead LED's and dead switches within 4 months and now this firmware fiasco.

 

Oh and not forgetting to mention my 780T's side window arrived looking like someone had a knife fight with it.

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

To be honest their standards are starting to slip, I've gone through 4 x H100i's each with a different problem i.e 1 had sheared screw holes when it arrived, 1 came with the pump top loose, The third 1 sounded like it was being tortured and the 4th thankfully is pristine.

 

I've also been through 3 x standard K95's all with different dead LED's and dead switches within 4 months and now this firmware fiasco.

 

Oh and not forgetting to mention my 780T's side window arrived looking like someone had a knife fight with it.

I've also noticed the decline in Corsairs quality, although the situation with your case, that sounds to be more of a damaged in transit.

I understand "BUT KNIVES DONT GO NEAR THERE" Trust me, I work in I.T and we deal with this shit often, trust me, it's damaged in transit, not Corsairs fault.

CPU i5 6600K | Mobo Gigabyte Z170X Gaming 7 | Cooling H80i | MSI GTX970 Gaming 4GB in SLi | Geil Super Luce 16GB 3000MHz DDR4 | Intel 330 120GB | 2 x 1TB WD Black | Corsair Air 540 | XFX ProSeries 1250W. | Corsair K70 Anodised Black Cherry Reds | Logitech G502 | Dell U2713HM | Red LED Lighting.

Portable Gamer - Metabox Alpha W370SS - CPU i7 4710MQ | RAM 8GB 1600MHz | Nvidia GTX 860M 2GB GDDR5 | Samsung 840 EVO 250GB SSD | 17.3" Matte Display 72% Gamut
Back-up - HP Pavilion dv6 - Ancient Stuff - P7550 @ 2.26gHz  | DDR2 4GB | Kingston HyperX 120Gb SSD | ATi 4550m (fried)

Link to comment
Share on other sites

Link to post
Share on other sites

I've also noticed the decline in Corsairs quality, although the situation with your case, that sounds to be more of a damaged in transit.

I understand "BUT KNIVES DONT GO NEAR THERE" Trust me, I work in I.T and we deal with this shit often, trust me, it's damaged in transit, not Corsairs fault.

 

I'm thinking it's more along the lines of bad handling at the factory with the side panels.

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

I'm thinking it's more along the lines of bad handling at the factory with the side panels.

I think you've missed the part where I've said "Damaged in Transit"

Nothing leaves Corsairs' factories without a QA, This NEVER happens, if this is the case, then i'd hate to be you on a regular basis.

CPU i5 6600K | Mobo Gigabyte Z170X Gaming 7 | Cooling H80i | MSI GTX970 Gaming 4GB in SLi | Geil Super Luce 16GB 3000MHz DDR4 | Intel 330 120GB | 2 x 1TB WD Black | Corsair Air 540 | XFX ProSeries 1250W. | Corsair K70 Anodised Black Cherry Reds | Logitech G502 | Dell U2713HM | Red LED Lighting.

Portable Gamer - Metabox Alpha W370SS - CPU i7 4710MQ | RAM 8GB 1600MHz | Nvidia GTX 860M 2GB GDDR5 | Samsung 840 EVO 250GB SSD | 17.3" Matte Display 72% Gamut
Back-up - HP Pavilion dv6 - Ancient Stuff - P7550 @ 2.26gHz  | DDR2 4GB | Kingston HyperX 120Gb SSD | ATi 4550m (fried)

Link to comment
Share on other sites

Link to post
Share on other sites

Sad...

"Strength does not come from winning. Your struggles develop your strengths. When you go through hardships and decide not to surrender, that is strength" Arnold

Link to comment
Share on other sites

Link to post
Share on other sites

I think you've missed the part where I've said "Damaged in Transit"

Nothing leaves Corsairs' factories without a QA, This NEVER happens, if this is the case, then i'd hate to be you on a regular basis.

 

I didn't miss that part I'm going from experience is all, I've never had problems with any other brand as much as I have with Corsair apart from 1 time with Razer and that got sorted out winthin a few days.

 

Corsairs QA sucks, Simple as really and I'm not the only one by a long shot :(

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

Damn... Thankfully I'll be getting a non-RGB K70.

 

If it's the new K70 with the updated LED's it might have the same firmware problem.

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

If it's the new K70 with the updated LED's it might have the same firmware problem.

I will get it a few months later though, probably in January.

LTT's unofficial Windows activation expert.
 

Link to comment
Share on other sites

Link to post
Share on other sites

I will get it a few months later though, probably in January.

 

The firmware issues will hopefully be sorted by then, I hope.

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

Hi Guys,

 

I wanted to give you an update. 

 

We spotted an issue with the latest DE(German) layout FW/SW.  Out of the box all the LED's are working.  After the FW update, one LED will stop working.  We have a update in the works that will hopefully be released by the end of the week.   I want to let everyone know this is not a hardware issue.  We are working as fast as possible to provide the FW/SW update.

Link to comment
Share on other sites

Link to post
Share on other sites

Hi Guys,

 

I wanted to give you an update. 

 

We spotted an issue with the latest DE(German) layout FW/SW.  Out of the box all the LED's are working.  After the FW update, one LED will stop working.  We have a update in the works that will hopefully be released by the end of the week.   I want to let everyone know this is not a hardware issue.  We are working as fast as possible to provide the FW/SW update.

 

It's not just the German layout, It's also the UK layout, You might want to check your forums a bit more often plus it's not just 1 key that gets bugged after the FW update - http://forum.corsair.com/v3/showthread.php?t=132632

 

Maybe a little bit more communcation on your part on the Corsair forums and facebook to let people know about the UK and DE firmware issue would be good, Otherwise people are simply going to take their keyboards back and go with another brand.

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

Corsair in their infinite wisdom have not released the correct firmware for their new RGB K70's/K95's in the UK/EU meaning some keys are not lighting up due to having a different layout.

 

Mostly everyone can only select North America, China or Taiwan for "Current Layout" but not German, UK, Nordic etc... resulting in some keys lights being turned off, Corsair have said they are working on it.

 

Just a headsup for those buying :)

 

What a relief! I thought my k70 was a duff one, my " \ or | " key to the right of the left shift will not change colour to anything. It remains dead, but if I update or reload the latest firmware it lights up as normal/works during the update then goes blank again after it has updated.

 

I was dreading returning it, it is my first mechanical and I am loving the experience.

Link to comment
Share on other sites

Link to post
Share on other sites

It's not just the German layout, It's also the UK layout, You might want to check your forums a bit more often plus it's not just 1 key that gets bugged after the FW update - http://forum.corsair.com/v3/showthread.php?t=132632

 

Maybe a little bit more communcation on your part on the Corsair forums and facebook to let people know about the UK and DE firmware issue would be good, Otherwise people are simply going to take their keyboards back and go with another brand.

 

I was just informed that our team is validating a update for the fix.  I will keep posting on when the update with be available for wide release. 

 

UK and DE versions.

Link to comment
Share on other sites

Link to post
Share on other sites

To be honest their standards are starting to slip, I've gone through 4 x H100i's each with a different problem i.e 1 had sheared screw holes when it arrived, 1 came with the pump top loose, The third 1 sounded like it was being tortured and the 4th thankfully is pristine.

 

I've also been through 3 x standard K95's all with different dead LED's and dead switches within 4 months and now this firmware fiasco.

 

Oh and not forgetting to mention my 780T's side window arrived looking like someone had a knife fight with it.

 

That's one of the problems that I am facing, I'm thinking of getting an RGB keyboard from Corsair but is there still a problem with dead LED's? 

Link to comment
Share on other sites

Link to post
Share on other sites

I was just informed that our team is validating a update for the fix.  I will keep posting on when the update with be available for wide release. 

 

UK and DE versions.

 

Good to know thank you :)

 

That's one of the problems that I am facing, I'm thinking of getting an RGB keyboard from Corsair but is there still a problem with dead LED's? 

 

Well so far there has only been the firmware issue which turns some lights off, Other than that Corsair said the dead LED issue was fixed due to better LED placement.

Battle.Net - Dicehunter#2746

Origin - Dicehunter

Steam - Dicehunter

Uplay - Dicehunter

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×