Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Wifi6 5GHz much slower than 2.4GHz

shiin3
 Share

Hello guys. I'm already exhausted at this point, not sure what went wrong with my network. My laptop is Acer Aspire 3 A315-41 and upgraded the wireless card to AX200. At first, I thought my old router (AC-87U) wasn't compatible with the original card (Atheros Wifi 5 if I remember correctly) since I can't get it work faster than Wifi 4 2.4GHz mode even from close proximity. Upgraded to AX200, turns out to be exactly the same. I then upgraded the router to Redmi AX5, I got maximum possible speed on 2.4GHz but again, it's much slower on 5GHz.

Is there anyone experienced the same thing here?. I need faster wifi for local stream and backups on my laptop. I currently have no other Wifi 6 device to test but I dont think there's anything wrong with my router.

Wifi analyzer on two spot (close proximity and my bed) attached

 

 

 

Spoiler

2.4GHz_close.png

2.4GHz, right in front of the router

 

 

Spoiler

5GHz_bed.png

5GHz, 3M from the router with a concrete wall in between

 

 

Spoiler

5GHz_close.png

5GHz, right in front of the router


 

Link to comment
Share on other sites

Link to post
Share on other sites

21 minutes ago, shiin3 said:

(Sorry, I dont get how to spoiler the attachments)

Edit the post, click on the attachments to select them, then click on the "eye" icon in the toolbar, that should put them inside a spoiler.

 

I can only speculate, but how far are you from the router, are there any walls in between? 5 GHz is much more susceptible to this and typically has a lower range than 2.4 GHz.

 

-46 dBm and -60 dBm isn't great, it means quality of the signal is quite bad. You'll normally want something around -70 dBm (the lower, the better). Have you checked how many other people around you are crowding the 5 GHz band? Maybe a different channel might work better, if it is less crowded.

 

If possible, you probably also want to have wider channels. You have 20 MHz right now, Wifi 6 should also allow for 40 MHz and 80 MHz, which should increase available bandwidth, provided both devices support this.

Remember to quote or @mention others, so they are notified of your reply

Link to comment
Share on other sites

Link to post
Share on other sites

@Eigenvektor Thanks, I'll edit it later. Both -46 and -60dBm was on my room, around 3m from router with a wall in between while the other is me standing directly in front of the router. I had checked for interference but there's no one else using 5GHz band. Tried every single band without luck too. The bandwidth seems wrong since there's no change when i changed the bandwidth Auto, 20, 40, and 80

Link to comment
Share on other sites

Link to post
Share on other sites

Are there any pipes or electrical conduits in the wall? That could be a huge factor.

 

Check if the same thing happens in other walls, even if the router is further away.

Link to comment
Share on other sites

Link to post
Share on other sites

@mtz_federicoThere's one plastic conduit on the wall. I took another ss on both 2.4GHz and 5GHz while im on the kitchen. Two concrete walls in between my laptop and router (straight line) even though there's big opening a couple meter besides my laptop. What bothers me is even with -22dBm strength, why the 5GHz link speed is worse than 2.4GHz with -46dBm?

Spoiler


2.4GHz_Kitchen.png

5GHz_Kitchen.png

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, shiin3 said:

@mtz_federicoThere's one plastic conduit on the wall. I took another ss on both 2.4GHz and 5GHz while im on the kitchen. Two concrete walls in between my laptop and router (straight line) even though there's big opening a couple meter besides my laptop. What bothers me is even with -22dBm strength, why the 5GHz link speed is worse than 2.4GHz with -46dBm?

  Hide contents

 

2.4GHz_Kitchen.png

5GHz_Kitchen.png

 

 

Why channel 157?  I'd honestly start by trying channel 36 and work from there.

 

That could also be why you're stuck on 20Mhz as some WiFi equipment can be very specific on which channels you need to set to get 40Mhz, 80Mhz or 160Mhz to work.

Router: i5-7200U appliance running pfSense WiFi: Zyxel NWA210AX (~940Mbit peak) + Ubiquiti nanoHD (OpenWRT)
ISPs: Zen VDSL (66Mbit) + Lebara 4G [Vodafone] (~120Mbit) + Three 5G (~700Mbit during quiet hours, ~500Mbit peak hours)

Link to comment
Share on other sites

Link to post
Share on other sites

@Alex Atkin UK My laptop can only detect from 149 and up for unknown reason. Kinda weird knowing no country restricted channel 36~48

---

After digging a bit deeper, this might be caused by LAR (Location Aware Regulatory) misdetection. No useful info how to change nor check the assigned location

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, shiin3 said:

wo concrete walls in between my laptop and router

ummmmm. Thats going to have a major impact. Lower bands have better penetration than higher bands. So 2.4 Ghz is going to penetrate the concrete a hell of a lot easier than the 5 Ghz signal. Generally your WiFi will slow down if the signal has to penetrate too many objects are dense objects and with distance. 

 

Have you taken and put the computer right next to the router? Just to rule out the issues with the building materials. 

I just want to sit back and watch the world burn. 

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, shiin3 said:

@Alex Atkin UK My laptop can only detect from 149 and up for unknown reason. Kinda weird knowing no country restricted channel 36~48

---

After digging a bit deeper, this might be caused by LAR (Location Aware Regulatory) misdetection. No useful info how to change nor check the assigned location

 

It does indeed, lots of reports of exactly the problem you describe.  Not a great result but at least we know what is going on now.

Router: i5-7200U appliance running pfSense WiFi: Zyxel NWA210AX (~940Mbit peak) + Ubiquiti nanoHD (OpenWRT)
ISPs: Zen VDSL (66Mbit) + Lebara 4G [Vodafone] (~120Mbit) + Three 5G (~700Mbit during quiet hours, ~500Mbit peak hours)

Link to comment
Share on other sites

Link to post
Share on other sites

@Donut417 Have you read my posts carefully?. Placing my laptop close to the router is the first thing i did and even with -22dBm strength, it's still slower than 2.4GHz at -46dBm
@Alex Atkin UK Yeah, this is sucks. I hope fix is available soon. Changing windows region doesnt do anything

Link to comment
Share on other sites

Link to post
Share on other sites

@shiin3

  1. Force Windows to forget the SSIDs of your current network. Reconnect with password.
  2. Did you completely uninstall the old WiFi adapter's drivers before installing the AX200?
  3. Remove and reinsert the AX200. Make sure both antenna cables are securely attached to the card.
  4. Uninstall then reinstall the latest Intel AX200 drivers (WiFi and Bluetooth).
  5. I've moved away from using WiFi Analyzer for wireless survey because it seems to have a problem interpreting wide channel widths. Try WiFiMan instead for mobile. Also, post the screenshots of the graphical channel analysis.
  6. Also, take screenshots of the RedMi's wireless settings. Redact any passwords.
Link to comment
Share on other sites

Link to post
Share on other sites

@Falcon1986
1. Tried, no luck
2. I dont think so(?)
3. Tried, no luck
4. Tried just a few minutes ago, no luck again
5 and 6.:

Spoiler

 


 

Screenshot from 2021-10-22 22-06-15.png

Screenshot_20211022-215358.png

Screenshot_20211022-215343.png

 

my phone did the same thing but there's workaround by enabling airplane mode first

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, shiin3 said:

2. I dont think so(?)

Please check Device Manager for hidden devices and uninstall if you see it.

 

2 hours ago, shiin3 said:

5 and 6.:

...

Do you have an English translation for those settings?

 

As you might observe from WiFiMan, the broadcast is at 80MHz channel width. Can you force channel 42? What about not setting channel width to auto but force 80MHz?

Link to comment
Share on other sites

Link to post
Share on other sites

@Falcon1986Sure. from top to down:

SSID

Security (WPA3)
Pass
Channel (Manual, 36)
Bandwidth (Manual, 80M)
Signal strength (max power)

Wifi 5 backward compatibility (disables OFDMA and BSS Coloring)

MU-MIMO

Something about easy connect through apps

---

The only available channels are 36, 40, 44, 48, 149, 153, 157, 161, and 165

-add-
Just to update, I changed my router region to both Europe and Taiwan, no luck at all. My laptop simply won't detect anything but high channels and I confirmed the router does works at 80MHz with my phone using WiFiMan. My bad for not looking this up before but hey, nothing changed on my laptop so I guess they did work just like now before change(?)

 

Spoiler

IMG_20211023_044247.jpg

 

Link to comment
Share on other sites

Link to post
Share on other sites

@Falcon1986 I tried 149 80MHz and turns out my phone can't detect it. My laptop does but it looks like it runs at 20MHz. I ran iperf3 on both laptop (2.4GHz ch11 and 5GHz ch149) and phone (2.4GHz ch11 and 5GHz ch52):
laptop:
2.4GHz AX 178Mbps avg with 315Mbps transmit link speed
5GHz AX 94Mbps avg with 129Mbps transmit link speed
phone:

2.4GHz N 112Mbps avg with 173Mbps transmit link speed
5GHz AC 420Mbps avg with 866Mbps transmit link speed

Im planning to try ubuntu live disc and disable LAR if still possible later
Nah. Ubuntu 21.10 uses the latest kernel and i cant disable LAR. Im either waiting for a driver update (who knows when they gonna fix it) or ditch the AX200 for another brand chip. Either Mediatek, Realtek, or Qualcomm
*SIGH*

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×