Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Hacking Nvidia's Drivers!

i tried cod warzone, well modern war not sure if is right one on ubuntu, blizzard launcher works out of box through wine staging, anf game will download but since i need to often swap drivers for steam, i forgot to swap to lstest so didnt get to test. all i can can say is doesnt work on 384 nvdia driver. i have 5 diffrent drivers i can swap from on boot, so i will try again when i can its a hige download. and i deleted by mistake. what windows nvdia driver adds dx12 support? mosr recent driver i have/ can dwap to is 430.

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

@dartraiden what ppa are you using?  is your driver over 430? i use graphics team one and highest driver is 430. i see everyone on photon using 440, which i think is a beta one. 

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

17 hours ago, dartraiden said:

DOOM Eternal ūü§ģ

 

image.png.d290fbbb9e08d7a44cfdc9bf56db70a4.png

what happens when you click play ? 

Link to comment
Share on other sites

Link to post
Share on other sites

17 hours ago, Snowarch said:

i tried cod warzone, well modern war not sure if is right one on ubuntu, blizzard launcher works out of box through wine staging, anf game will download but since i need to often swap drivers for steam, i forgot to swap to lstest so didnt get to test. all i can can say is doesnt work on 384 nvdia driver. i have 5 diffrent drivers i can swap from on boot, so i will try again when i can its a hige download. and i deleted by mistake. what windows nvdia driver adds dx12 support? mosr recent driver i have/ can dwap to is 430.

Try pop_os, and no you cant run the damn warzone by default in linux. Activission had gone and done it in DX 12 only. The only lead I have is that you need VKD3D to translate DX 12 to vulkan and this is not included by default in wine. Add VKD3D then try with  wine. There are ways to do this but I already messed enough with the card as I am running this with intel 2600k.

@Mirror Reaper Try setting the game on borderless window, remove any cpu OC. In my case the game was not running even in gtx950 and giving errors. Most errors and crashes went away after I took back OC on cpu and made the game borderless window using Gforce experience.

@Orion98 Can I get your system config? I need to know if i can manage to run warzone with this card with 2nd gen intel.

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, Mirror Reaper said:

what happens when you click play ? 

Nothing. Too old driver (or broken crack)

Also if driver is older than 442.19, you get ingame crash at chapter 3.

 

Well,  I will install Linux and use Valve Proton...

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, Shibly said:

Try pop_os, and no you cant run the damn warzone by default in linux. Activission had gone and done it in DX 12 only. The only lead I have is that you need VKD3D to translate DX 12 to vulkan and this is not included by default in wine. Add VKD3D then try with  wine. There are ways to do this but I already messed enough with the card as I am running this with intel 2600k.

@Mirror Reaper Try setting the game on borderless window, remove any cpu OC. In my case the game was not running even in gtx950 and giving errors. Most errors and crashes went away after I took back OC on cpu and made the game borderless window using Gforce experience.

@Orion98 Can I get your system config? I need to know if i can manage to run warzone with this card with 2nd gen intel.

I have an i5-4690 with 8gb ddr3 1600Mhz

Link to comment
Share on other sites

Link to post
Share on other sites

@Orion98 I dont like call of duty was just testing for this. bl3 is what i wanted to play but its broken on steam through photon, and or wine.

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

I got Warzone to work pretty fine. for some reason it crashes on the intro on my main windows 10, however works just fine (after increasing my paging files size)  on another Windows 10.
The game will crash a lot if you have 8 gb ram or less. after adding 2 gb ram (I had 8 ) and closing everything also changing the game process priority to normal as it's automatically set itself to high the game worked and I was able to play several games without crashes. I also changed some settings though that may or may not helped (check the link, though I ignored the last tip).  
possible_fix_for_pc_crash_to_desktop_wit

Link to comment
Share on other sites

Link to post
Share on other sites

has anyone managed to play Doom Eternal?

Looks like Vulkan API only works with top tier of intel cpus and their older graphic chips, won't support it.

the game won't even start for me.

it's funny some people say it might work in linux, but i could not get it to work properly.

damn windows.

Link to comment
Share on other sites

Link to post
Share on other sites

@zereshk you can use wines version of dxgl instead of vulcan maybe 

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

7 hours ago, Snowarch said:

@zereshk you can use wines version of dxgl instead of vulcan maybe 

maybe i didn't understand what ure saying, but the game only uses Vulkan API, So dx is out of the question, in linux and windows.

funny isn't it?

Link to comment
Share on other sites

Link to post
Share on other sites

what intel cpu do you have? i saw 7000-ish or lower intel cpus running bl3 steam/dx12 version and a regular 1060. when i was looking for benchmarks. 

 

and about the "top tier only cpus" thing. not true. steam steam bl3 uses dxvk12/dxvk11 selectors. my cpu is an 8086k(stock) with p106-100 on prime. could never run it sadly.  what driver do you have on the p106? I use mainly 384, but swap to 418 for cirtain games in "additional drivers" tab. using ubuntu distro with the "graphics team" ppa so i can swap, since that .run file was bad. always shutdown your pc after driver swap bar loads. it will say logout, but this will give issue if not. also i read proton 5.0 needs driver 390+ when i needed help on steam forum. 

 

linux supports vulkan normally so not sure here. is doom eternal a steam game? if not you may be able to get away with 430 driver. its on additional drivers list but steam complains about a missing libreary and crashs. good luck. if youre on a distro higher than 16.04, what linux are you using tho?

 

@zereshk

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Snowarch said:

what intel cpu do you have? i saw 7000-ish or lower intel cpus running bl3 steam/dx12 version and a regular 1060. when i was looking for benchmarks. 

 

and about the "top tier only cpus" thing. not true. steam steam bl3 uses dxvk12/dxvk11 selectors. my cpu is an 8086k(stock) with p106-100 on prime. could never run it sadly.  what driver do you have on the p106? I use mainly 384, but swap to 418 for cirtain games in "additional drivers" tab. using ubuntu distro with the "graphics team" ppa so i can swap, since that .run file was bad. always shutdown your pc after driver swap bar loads. it will say logout, but this will give issue if not. also i read proton 5.0 needs driver 390+ when i needed help on steam forum. 

 

linux supports vulkan normally so not sure here. is doom eternal a steam game? if not you may be able to get away with 430 driver. its on additional drivers list but steam complains about a missing libreary and crashs. good luck. if youre on a distro higher than 16.04, what linux are you using tho?

 

@zereshk

Why are you even bothering to switch drivers? I am on POP_OS and all games that run Run perfectly with the latest drivers(442..) in my case. I am not getting the point why are you switching drivers.

Link to comment
Share on other sites

Link to post
Share on other sites

Spoiler

 

@Shibly mk9, and starwars do not work on the high drivers. i play these games a lot so mskes no sense to stay on high driver while theyre unplayable. 418's only purpose is dxvk12.

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

has anyone tried linux p106 sli?

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

 

@Snowarchthx for the rply. for starters i have to say my knowledge of linux is none existed! tried installing it for playing some games(i think the last time i used the linux was ubuntu version 16? and i didn't enjoy the expriment!!!) but this time i get a liking to it.

haven't had the chance to play borderland 3(maybe i should use my gtx 970 and windows for it) but i have 3570k on this system and i dont have a p106!! i'm using a rx 470 mining edition.

sorry for misleading u.

i'm using pop os 19.10, it has the latest drivers pre installed, ubuntu ruined every feeling i had for linux with driver installation problems. but i tested different version like fedora, solus with different base and kernels and decided POP OS was the best of them all for gaming.

 

as for doom i have to say, the game only uses vulkan and if i remember correctly, DXVK, means DirectX to Vulkan and it doesn't mean anything if the game won't use DX.

when we are using the intel integrated graphic card as the display output, it seems it should have the minimal ability to run the DX12 or Vulkan so we can run the games. but this is for windows, it's funny how linux doesn't have this problem!!!(damn windows) and i said it before, i use the card for playing resident evil 2 DX12 version without any problems!!!

then why Call of duty warzone won't work? or maybe metro exodus?

 

there has been a proton version 5.4 GE and people say it could run it with low frame rate, someone said their 1080ti give about 40 frame at best!!!

they said AMD Cards give better frame rate but i couldn't run it at all!! the game won't even start.

some people said the DRM Free version works, but it didn't!!

tried to even update to the latest kernel i could find(i think it was 5.5.11), but it didn't do anything.

next i'm going to try and use ubuntu 20.04, cuz they are saying the game needs the latest vulkan driver and i couldn't get it whatever i did.

Link to comment
Share on other sites

Link to post
Share on other sites

25 minutes ago, zereshk said:

 

@Snowarchthx for the rply. for starters i have to say my knowledge of linux is none existed! tried installing it for playing some games(i think the last time i used the linux was ubuntu version 16? and i didn't enjoy the expriment!!!) but this time i get a liking to it.

haven't had the chance to play borderland 3(maybe i should use my gtx 970 and windows for it) but i have 3570k on this system and i dont have a p106!! i'm using a rx 470 mining edition.

sorry for misleading u.

i'm using pop os 19.10, it has the latest drivers pre installed, ubuntu ruined every feeling i had for linux with driver installation problems. but i tested different version like fedora, solus with different base and kernels and decided POP OS was the best of them all for gaming.

 

as for doom i have to say, the game only uses vulkan and if i remember correctly, DXVK, means DirectX to Vulkan and it doesn't mean anything if the game won't use DX.

when we are using the intel integrated graphic card as the display output, it seems it should have the minimal ability to run the DX12 or Vulkan so we can run the games. but this is for windows, it's funny how linux doesn't have this problem!!!(damn windows) and i said it before, i use the card for playing resident evil 2 DX12 version without any problems!!!

then why Call of duty warzone won't work? or maybe metro exodus?

 

there has been a proton version 5.4 GE and people say it could run it with low frame rate, someone said their 1080ti give about 40 frame at best!!!

they said AMD Cards give better frame rate but i couldn't run it at all!! the game won't even start.

some people said the DRM Free version works, but it didn't!!

tried to even update to the latest kernel i could find(i think it was 5.5.11), but it didn't do anything.

next i'm going to try and use ubuntu 20.04, cuz they are saying the game needs the latest vulkan driver and i couldn't get it whatever i did.

Warzone works fine for me, read below 

 

On 3/24/2020 at 3:08 AM, Mirror Reaper said:

I got Warzone to work pretty fine. for some reason it crashes on the intro on my main windows 10, however works just fine (after increasing my paging files size)  on another Windows 10.
The game will crash a lot if you have 8 gb ram or less. after adding 2 gb ram (I had 8 ) and closing everything also changing the game process priority to normal as it's automatically set itself to high the game worked and I was able to play several games without crashes. I also changed some settings through that may or may not helped (check the link, though I ignored the last tip).  
possible_fix_for_pc_crash_to_desktop_wit

 

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, Mirror Reaper said:

Warzone works fine for me, read below 

 

 

Have fun.

it doesn't work for me, at least not with good frame rate. it's about not switching to the right graphic card from the start, it's intel's fault for not developing the drivers for the DX12 and even Vulkan for their older hardware. they don't even have vulkan support for their 6th generation and older...

Link to comment
Share on other sites

Link to post
Share on other sites

11 minutes ago, zereshk said:

Have fun.

it doesn't work for me, at least not with good frame rate. it's about not switching to the right graphic card from the start, it's intel's fault for not developing the drivers for the DX12 and even Vulkan for their older hardware. they don't even have vulkan support for their 6th generation and older...

Oh you are talking about igpu

Link to comment
Share on other sites

Link to post
Share on other sites

Guys,

 

there is this P104-100 card, with an 8GB mod bios. GPU-z reports that the card is on PCI-E 1.1 x4.

Is there any way to make it use PCI-E x16?

Link to comment
Share on other sites

Link to post
Share on other sites

@AnusSexTips the card is fixed this way, locked by nvdia. im not sure if linux will help on it. 

main rig:

CPU: 8086k @ 4.00ghz-4.3 boost

PSU: 750 watt psu gold (Corsair rm750)

gpu:axle p106-100 6gbz msi p104-100 @ 1887+150mhz oc gpu clock, 10,012 memory clock*2(sli?) on prime w coffee lake igpu

Mobo: Z390 taichi ultimate

Ram: 2x8gb corsair vengence lpx @3000mhz speed

case: focus G black

OS: ubuntu 16.04.6, and umix 20.04

Cooler: mugen 5 rev b,

Storage: 860 evo 1tb/ 120 gb corsair force nvme 500

 

backup

8gb ram celeron laptop/860 evo 500gb

Link to comment
Share on other sites

Link to post
Share on other sites

And what about this card? TPU says that it has PCI-e 3.0 but GPU-z tells me its running on 1.0 :/

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, AnusSexTips said:

And what about this card? TPU says that it has PCI-e 3.0 but GPU-z tells me its running on 1.0 :/

All p106 are the same PCIE 1.1. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



√ó