Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Screen tearing on CSGO

Petar_99
 Share

Hi, 

I have got a new GPU,  I went from a 1080 to a ti and I'm getting some stutter and tearing on CS but none in GTA V or Tomb Raider. 

I understand that I get it in cs as the fps is about 250, I've turned Vsync off (way too much input lag if on) Gsync is On for windowed and full screen.  

Ive attached SC of my CS settings and nvidia control panel settings. Anyone know if any of the setting i currently have are causing this or is there something else i can do to fix this. 

 

Thanks. 

 

Multisampling Anit-Aliasing Mode - x4

FXAA - Enabled 

20181101210417_1.thumb.jpg.c8138c84c5f14e78111b389f9bbd0271.jpgCapture1.PNG.137c79854151da3bd4c7503b223aa5d5.PNGCapture2.PNG.02135ed939b755027391345cc9b179e8.PNG 

Link to comment
Share on other sites

Link to post
Share on other sites

13 minutes ago, Petar_99 said:

Hi, 

I have got a new GPU,  I went from a 1080 to a ti and I'm getting some stutter and tearing on CS but none in GTA V or Tomb Raider. 

I understand that I get it in cs as the fps is about 250, I've turned Vsync off (way too much input lag if on) Gsync is On for windowed and full screen.  

Ive attached SC of my CS settings and nvidia control panel settings. Anyone know if any of the setting i currently have are causing this or is there something else i can do to fix this. 

 

Thanks. 

 

Multisampling Anit-Aliasing Mode - x4

FXAA - Enabled 

20181101210417_1.thumb.jpg.c8138c84c5f14e78111b389f9bbd0271.jpgCapture1.PNG.137c79854151da3bd4c7503b223aa5d5.PNGCapture2.PNG.02135ed939b755027391345cc9b179e8.PNG 

Simply enable v-sync

I may be wrong.

Link to comment
Share on other sites

Link to post
Share on other sites

22 minutes ago, Petar_99 said:

 

I really hope that 1080ti was really cheap

Just turn on fast sync

 

 

9 minutes ago, Altruist said:

Simply enable v-sync


Never.

 

I edit my posts a lot, Twitter is @LordStreetguru just don't ask PC questions there mostly...
 

Spoiler

 

What is your budget/country for your new PC?

 

what monitor resolution/refresh rate?

 

What games or other software do you need to run?

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

14 minutes ago, Altruist said:

Always works for me.

it limits your fps and adds latency.

I edit my posts a lot, Twitter is @LordStreetguru just don't ask PC questions there mostly...
 

Spoiler

 

What is your budget/country for your new PC?

 

what monitor resolution/refresh rate?

 

What games or other software do you need to run?

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Petar_99 said:

Anyone know if any of the setting i currently have are causing this or is there something else i can do to fix this.

First of all, what is the brand and model number of your monitor? Acer ??????

 

You can also try changing the following settings in your NVidia control panel for CS:GO to these:

  • Antialiasing - Mode: Use global setting (Application-controlled) Change the global setting to Application-controlled.
  • Antialiasing - Setting: Use global setting (Application-controlled) Set this one to what you want it to be in the in-game settings.
  • Antialiasing - Transparency: Use global setting (Off) Change the global setting to Off.
  • Maximum pre-rendered frames: Use global setting (Use the 3D application setting) Change the global setting to Use the 3D application setting.
  • Multi-Frame Sampled AA (MFAA): Use global setting (Off) Change the global setting to Off.
  • OpenGL rendering GPU: Use global setting (Auto-select) Change the global setting to Auto-select.
  • Power management mode: Use global setting (Prefer maximum performance). Change the global setting to Prefer maximum performance.
  • Preferred refresh rate (Acer X34): Use global setting (Application-controlled) Change the global setting to Application-controlled.
  • Threaded optimization: Use global setting (Auto) Change the global setting to Auto.
  • Triple buffering: Use global setting (Off) Change the global setting to Off.
  • Vertical sync: Use global setting (Off) Change the global setting to Off.

These are the settings I use and I have zero issues. The Power management mode should always be on Prefer maximum performance in your global settings. This is one of the most important settings in all the games you play to achieve the best performance possible. As for everything else, I don't know why you messed with all that stuff in the first place. 

 

And if your monitor is 60 Hz, no clue why you don't just cap your frames to 60 in any game you play because your monitor won't go above 60 fps. You can cap your frames very easily with MSI AB. I have found this to be better than vsync because vsync can introduce input lag(using K&M anyway). I've never noticed input lag using a controller on PC. Only on console.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×