Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My ryzen 72700x goes up to 4.050ghz with stock settings in bios and I’ve done research and the clock speed is supposed to be 3.7ghz I’ve made sure there was no oc on the cpu and everything is stick I also removed the cmos battery to see if that would work but it doesn’t reset to normal speed. When I’m in idle my cpu tends to get hot and I think it’s because of the 4.050ghz. Also I’ve change the cpu ration from auto to 37 which helped but when I game it tends to heat up not as before. I had also turned on msi game mode but turned it off because my cpu was going up to 65 degrees idle. could my cpu may have been damaged?

ryzen 7 2700x

mpg msi x570 wireless WiFi motherboard 

cooler master master liquid ml240l v2

 

Link to post
Share on other sites

It's a Zen+ flagship and it does tend to run hot with PBO on "auto" which you can set to "disable" instead of using a fixed multiplier. 

 

At stock you should see at idle higher temps because the Cpu will be boosting single core to 4350mhz and roughly 1.5v

 

All this a normal function of the processor.

 

The thermal throttle limit is 95c. If the cpu doesn't ever throttle, just let it do it's thing and enjoy the performance.

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
9 minutes ago, ShrimpBrime said:

It's a Zen+ flagship and it does tend to run hot with PBO on "auto" which you can set to "disable" instead of using a fixed multiplier. 

 

At stock you should see at idle higher temps because the Cpu will be boosting single core to 4350mhz and roughly 1.5v

 

All this a normal function of the processor.

 

The thermal throttle limit is 95c. If the cpu doesn't ever throttle, just let it do it's thing and enjoy the performance.

Thank you👌🏽

Link to post
Share on other sites
Posted (edited)
1 hour ago, ShrimpBrime said:

It's a Zen+ flagship and it does tend to run hot with PBO on "auto" which you can set to "disable" instead of using a fixed multiplier. 

 

At stock you should see at idle higher temps because the Cpu will be boosting single core to 4350mhz and roughly 1.5v

 

All this a normal function of the processor.

 

The thermal throttle limit is 95c. If the cpu doesn't ever throttle, just let it do it's thing and enjoy the performance.

Also my cpu isn’t oc so I can’t disable pbo. This also never happened u til I used the game boost and turned it off

560DE386-DBC3-4A26-A3D7-D08BAC007284.thumb.jpeg.91d67bab90a590565012450d73706cd2.jpegBED45DCC-BD3F-450C-A2BB-9B3E1DB27798.thumb.jpeg.c5f64851688c1e33f7558a28e69d13d9.jpeg6D158ED2-093C-49E8-A9D6-CCDBABF5243A.thumb.jpeg.682832259fb270109e0edaecf9c9cbc2.jpeg

Edited by Epicgam3r
Link to post
Share on other sites
10 hours ago, Epicgam3r said:

Also my cpu isn’t oc so I can’t disable pbo. This also never happened u til I used the game boost and turned it off

 

Can disable PBO is bios, where you should be changing settings opposed to the software....

 

The cpu is automatically factory overclocked with PBO on auto. Setting PBO to enabled only just extends the factor overclock slightly 100 to 200 mhz. Disabled (in bios) will run the cpu at default 3.7ghz frequency. 

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
1 hour ago, ShrimpBrime said:

Can disable PBO is bios, where you should be changing settings opposed to the software....

 

The cpu is automatically factory overclocked with PBO on auto. Setting PBO to enabled only just extends the factor overclock slightly 100 to 200 mhz. Disabled (in bios) will run the cpu at default 3.7ghz frequency. 

I had found it

Link to post
Share on other sites
2 hours ago, ShrimpBrime said:

Can disable PBO is bios, where you should be changing settings opposed to the software....

 

The cpu is automatically factory overclocked with PBO on auto. Setting PBO to enabled only just extends the factor overclock slightly 100 to 200 mhz. Disabled (in bios) will run the cpu at default 3.7ghz frequency. 

I did and it was still running at 4.2ghz

Link to post
Share on other sites
1 hour ago, Epicgam3r said:

I did and it was still running at 4.2ghz

Disable the OC software from starting with windows.  Set all defaults to bios and try again.

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
3 hours ago, Epicgam3r said:

I did and it was still running at 4.2ghz

 

5 hours ago, ShrimpBrime said:

Disabled (in bios) will run the cpu at default 3.7ghz frequency. 

eh, ryzen will still boost with pbo off, just slightly less agressive.

 

OP: 3.7 is your "base" clock, 4.2 is "boost" clock, but it'll go there only.shortly and thats what its supposed to do.  Its really best to run Ryzen at default settings, pbo on, automatic or off doesnt matter much, just let it do its thing.

 

Also u may uninstall Ryzen Master, its not needed for the chip to work properly, its only meant for temporary overclocking, and it doesnt  sound like you actually  want that.  

✪Ryzen 3600✪RTX3070✪B350✪

✪Trident Z 3600 16-16-16-36✪

✪Noctua U12S Chromax✪

 

 

Link to post
Share on other sites
5 hours ago, Mark Kaine said:

 

eh, ryzen will still boost with pbo off, just slightly less agressive.

 

OP: 3.7 is your "base" clock, 4.2 is "boost" clock, but it'll go there only.shortly and thats what its supposed to do.  Its really best to run Ryzen at default settings, pbo on, automatic or off doesnt matter much, just let it do its thing.

 

Also u may uninstall Ryzen Master, its not needed for the chip to work properly, its only meant for temporary overclocking, and it doesnt  sound like you actually  want that.  

So it’s normal for my

cpu to go at that speed?

Link to post
Share on other sites
15 hours ago, Mark Kaine said:

 

eh, ryzen will still boost with pbo off, just slightly less agressive.

 

 

I do not receive this experience with Strix B450-I and 2700x. PBO disabled it ran defaults. 

 

Also, a 2700x doesn't boost all core to 4.2ghz while default, it should be closer to 3.8 - 3.9ghz.

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
2 minutes ago, ShrimpBrime said:

I do not receive this experience with Strix B450-I and 2700x. PBO disabled it ran defaults. 

hmm, i see, i definitely do with my 3600/b350… in fact there isnt a discernable difference in boost on or off, however any "offsets" do seem to do something, still barely boosts over 4.2...

 

 

 

4 minutes ago, ShrimpBrime said:

Also, a 2700x doesn't boost all core to 4.2ghz while default, it should be closer to 3.8 - 3.9ghz

Ah yeah, i thought something wrong about these numbers, was just going with what OP said. 

✪Ryzen 3600✪RTX3070✪B350✪

✪Trident Z 3600 16-16-16-36✪

✪Noctua U12S Chromax✪

 

 

Link to post
Share on other sites
6 minutes ago, Mark Kaine said:

hmm, i see, i definitely do with my 3600/b350… in fact there isnt a discernable difference in boost on or off, however any "offsets" do seem to do something, still barely boosts over 4.2...

 

 

 

Ah yeah, i thought something wrong about these numbers, was just going with what OP said. 

I think originally it was 4050mhz OP was talking about which the cpu will boost to with either enabled PBO or increase power limits or under certain thermal conditions while on automatic.

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
5 hours ago, ShrimpBrime said:

I think originally it was 4050mhz OP was talking about which the cpu will boost to with either enabled PBO or increase power limits or under certain thermal conditions while on automatic.

So is there anyway to fix it?

Link to post
Share on other sites
21 hours ago, Mark Kaine said:

 

eh, ryzen will still boost with pbo off, just slightly less agressive.

 

OP: 3.7 is your "base" clock, 4.2 is "boost" clock, but it'll go there only.shortly and thats what its supposed to do.  Its really best to run Ryzen at default settings, pbo on, automatic or off doesnt matter much, just let it do its thing.

 

Also u may uninstall Ryzen Master, its not needed for the chip to work properly, its only meant for temporary overclocking, and it doesnt  sound like you actually  want that.  

So is it able to be fixed because my cpu would never had gone higher than 3.7ghz

Link to post
Share on other sites
1 hour ago, Epicgam3r said:

So is there anyway to fix it?

It's actually a good thing the cpu boosts 4050mhz. You must have the cooling head room and not in need to run a default speed.

 

The only course of action has already been explained.

 

Either disable PBO and stop the OC software from starting with windows

 

Or manually set a 37.25x multi.

It has to be one quarter multiplier higher or PBO will still work as intended while set to auto or enabled.

 

That is all. Good luck!

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
1 hour ago, ShrimpBrime said:

It's actually a good thing the cpu boosts 4050mhz. You must have the cooling head room and not in need to run a default speed.

 

The only course of action has already been explained.

 

Either disable PBO and stop the OC software from starting with windows

 

Or manually set a 37.25x multi.

It has to be one quarter multiplier higher or PBO will still work as intended while set to auto or enabled.

 

That is all. Good luck!

 

1 hour ago, ShrimpBrime said:

It's actually a good thing the cpu boosts 4050mhz. You must have the cooling head room and not in need to run a default speed.

 

The only course of action has already been explained.

 

Either disable PBO and stop the OC software from starting with windows

 

Or manually set a 37.25x multi.

It has to be one quarter multiplier higher or PBO will still work as intended while set to auto or enabled.

 

That is all. Good luck!

I don’t have any oc software and pbo doesn’t seem to help I also changed the cpu ratio but that also doesn’t help

Link to post
Share on other sites
Just now, Epicgam3r said:

 

I don’t have any oc software and pbo doesn’t seem to help I also changed the cpu ratio but that also doesn’t help

Did you change the ratio to 37.25? Or just 37. Try the extra .25.

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
2 hours ago, ShrimpBrime said:

Did you change the ratio to 37.25? Or just 37. Try the extra .25.

I will try that rn. Do you think the msi game mode is what causes this because this had never happened to me until I turned it on

Link to post
Share on other sites
12 minutes ago, Epicgam3r said:

I will try that rn. Do you think the msi game mode is what causes this because this had never happened to me until I turned it on

Yes. Game mode is essentially turning PBO to enabled. 

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
36 minutes ago, ShrimpBrime said:

Yes. Game mode is essentially turning PBO to enabled. 

How though if I had turned off game mode?

Link to post
Share on other sites
57 minutes ago, Epicgam3r said:

How though if I had turned off game mode?

At a loss this point. Not sure. 

 

So uninstall MSI OC software, uninstall ryzen master software. Restart and shut down.  Then clear the cmos.

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites

In Ryzen Master - at the top it shows your current set limits. Stock is: PPT 142watts, TDC 95A, EDC 140A - Something has increased the power limits

When you fix the problem, Ryzen Master will shows those default values. If you still see numbers above those, something is still enabled.

 

You have an overclocking setting turned on somewhere, like PBO turned on.

Your CPU is set to use maximum power with no limits essentially.

 

Your CPU has a voltage/frequency curve, it will throttle itself to stay within the stock power limits of the CPU. Something has increased those limits allowing it to no longer throttle itself once it hits the default 142watt limit. Even though its not "overclocked" in the traditional sense, it is capable of reaching higher frequencies on the voltage/frequency curve because it is no longer limited by a PPT of 142watts. It can run higher up the curve fully loaded, giving higher frequencies/voltage increasing temperature and power consumption.

 

This is considered safe because the default AMD frequency/voltage curve is controlling the voltage. However, it will cause a temperature issue if your cooler isn't up for the task.(any OC is technically not safe)

 

IMO never touch the voltage unless you know what your doing. (even then at your own risk)

 

A.Try resetting your BIOS to default - or

 

B. In your BIOS click the OC option on the left,

 -Advanced CPU Configuration

 -AMD Overclocking

     Precision Boost Overdrive - change that to disabled

     PBO Limits - Default

 

If either of those don't work, you have overclocking enabled in Ryzen Master or third party software somewhere

 

 

Link to post
Share on other sites
25 minutes ago, ShrimpBrime said:

At a loss this point. Not sure. 

 

So uninstall MSI OC software, uninstall ryzen master software. Restart and shut down.  Then clear the cmos.

My cpu now stays at 4ghz or lower but my power plan switches to and balanced and power saver which the amd plan makes my cpu go up to 4ghz. I just removed the power plan tho I read that it’s no good

Link to post
Share on other sites
37 minutes ago, ShrimpBrime said:

At a loss this point. Not sure. 

 

So uninstall MSI OC software, uninstall ryzen master software. Restart and shut down.  Then clear the cmos.

Bro I think it’s fixed now. I just wanna thank you so much I thought I messed up really bad thank you man😭😭😭

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×