Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
S w a t s o n

Site sending empty audio signal

Recommended Posts

Posted · Original PosterOP

Browser, version and OS: 

Firefox 78.0.1 on Windows 10 2004

 

Steps to reproduce/what were you doing before it happened?

Log into LinusTechTips.com

 

What happened?

Background:

I have a set of Steelseries Arctis Pro Wireless headphones. One quirk of this headset is that it has a somewhat high noise floor. Basically if the headset is being sent an audio signal at all the non passive audio equipment has to be powered, which can create a bit of a hiss. This is a byproduct of the headphone design yes.

 

The "Problem": Browsing the forum while logged in opens an audio channel which causes the drivers and electronics to power on giving me an audible hiss. Because there's no actual audio playing it's very annoying and noticeable. This doesn't occur if I load the site while not logged in. I'm guessing this has to do with notification pings or something but is there a way to not have the channel open constantly? I am fully aware this is technically a problem with the headset but lots of wireless headphones have high noise floors so I can't be the only one that it bothers. Other sites with push notifications do not have the same problem generally but I will admit some other sites/applications do cause this as it's just a problem with how audio is being dealt with. Aka not sending a signal but having the channel "open" or however it's described.

 

What did you expect to happen?

Silence.

 

Link to a page where it happened, if applicable: 

Any part of linustechtips while logged in.

Link to post
Share on other sites
Posted · Original PosterOP

On a page load the hiss will actually pause until the page load is complete, closing the LTT tab brings about joyous silence to my ears. I should clearly point out that not all pages with audio cause the headphones to stay permanently powered causing the hiss. I can load twitch or youtube and if the audio is muted, no signal at all is sent and no hiss is heard. I can't mute the LTT tab because firefox knows that no audio is being sent.

Link to post
Share on other sites

I use Firefox 80.0a1 and I've never experienced such an issue. If Firefox is not indicating that audio is being played from a linustechtips.com tab, the site itself is unlikely to be the source of the issue.

 

Have you tried running Firefox in safe mode? Does the issue occur in other browsers?


Make sure to quote me or use @PorkishPig to notify me that you replied!

 

 

Desktop

CPU - Ryzen 9 3900X | Cooler - Noctua NH-U12S | Motherboard - Asus TUF X570-PLUS (WiFi) RAM - Corsair Vengeance LPX (2x8GB) DDR4-3200

GPU - MSI GTX 1070 Ti PSU - EVGA B3 650W Case - Meshify C Storage - 960 EVO 500GB, MX500 500GB

 

Media Server

CPU - Core i5-4570 | RAM - Samsung 16GB (4x4GB) DDR3-1600 | Case - OptiPlex 9020 SFF

Storage - 850 EVO 128GB (Boot), BX500 240GB (Software), WD Red 4TB (Storage) | OS - FreeNAS 11.3

Link to post
Share on other sites
Posted · Original PosterOP
Just now, PorkishPig said:

I use Firefox 80.0a1 and I've never experienced such an issue. If Firefox is not indicating that audio is being played from a linustechtips.com tab, the site itself is unlikely to be the source of the issue.

 

Have you tried running Firefox in safe mode? Does the issue occur in other browsers?

It's 100% the site. Are you using headphones that even have an audible noise floor? Firefox is aware there is no audio playing so it's not indicating anything. On a youtube tab, if you mute the video player, the firefox tab will still indicate that the tab has audio active.

Link to post
Share on other sites
Posted · Original PosterOP

Using the new version of Edge I am unable to replicate, but I also dont know how edge handles audio. Could be firefox specific.

I had edge muted, it replicated exactly the same, but seems to end after 30 seconds (each page load) which is nice.

Link to post
Share on other sites
2 minutes ago, S w a t s o n said:

It's 100% the site. Are you using headphones that even have an audible noise floor? Firefox is aware there is no audio playing so it's not indicating anything. On a youtube tab, if you mute the video player, the firefox tab will still indicate that the tab has audio active.

I do not, though what you are reporting would likely be difficult to replicate. I suggested you run in Firefox safe mode in case the issue is originating from an extension, otherwise try a beta version of Firefox to ensure that this isn't an issue in 78.0.1.


Make sure to quote me or use @PorkishPig to notify me that you replied!

 

 

Desktop

CPU - Ryzen 9 3900X | Cooler - Noctua NH-U12S | Motherboard - Asus TUF X570-PLUS (WiFi) RAM - Corsair Vengeance LPX (2x8GB) DDR4-3200

GPU - MSI GTX 1070 Ti PSU - EVGA B3 650W Case - Meshify C Storage - 960 EVO 500GB, MX500 500GB

 

Media Server

CPU - Core i5-4570 | RAM - Samsung 16GB (4x4GB) DDR3-1600 | Case - OptiPlex 9020 SFF

Storage - 850 EVO 128GB (Boot), BX500 240GB (Software), WD Red 4TB (Storage) | OS - FreeNAS 11.3

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, PorkishPig said:

I do not, though what you are reporting would likely be difficult to replicate. I suggested you run in Firefox safe mode in case the issue is originating from an extension, otherwise try a beta version of Firefox to ensure that this isn't an issue in 78.0.1.

I just confirmed the issue replicates in Edge, so I think we're past it being a 78.0.1 issue. It's not a new issue either. As I mentioned, while typically this does not occur on websites that have audio, it does on some select websites or applications (guessing it's based on how the particular site handles audio).

Link to post
Share on other sites

The forum does open an audio context when you open the page, and tries to keep it around while it's open so that it can play notification sounds. You can turn off notification sounds in your notification settings - https://linustechtips.com/main/notifications/options/


HTTP/2 203

Link to post
Share on other sites
Posted · Original PosterOP
Just now, colonel_mortis said:

The forum does open an audio context when you open the page, and tries to keep it around while it's open so that it can play notification sounds. You can turn off notification sounds in your notification settings - https://linustechtips.com/main/notifications/options/

So you're basically saying it's not a bug it's a feature? In Edge it does at least close the context after about 30 seconds per page load, maybe that could at least be implemented for Firefox? Why are other sites able to serve me audio without having the context open 100% of the time? Twitch, twitter, youtube, other forums?

Link to post
Share on other sites
1 minute ago, S w a t s o n said:

So you're basically saying it's not a bug it's a feature? In Edge it does at least close the context after about 30 seconds per page load, maybe that could at least be implemented for Firefox? Why are other sites able to serve me audio without having the context open 100% of the time? Twitch, twitter, youtube, other forums?

As I understand it, although I've not found docs for it in my quick look today, there are some limitations about when a tab can play audio which relates to user interactions, so my guess is that is why it tries to hold onto the context without suspending it. The default behaviour of the library that we use is to auto suspend when the context is idle, and it has been changed deliberately, so I presume there was some reason behind doing so. I will submit a ticket to find out why it was set like that and see if it is possible to change, but even if it does get changed it will likely take a while.


HTTP/2 203

Link to post
Share on other sites

I've spoken to the forum software devs and it seems that the current approach is needed to work around issues that prevent the sound from working otherwise, so the only option if it's causing problems is to turn it off I'm afraid.


HTTP/2 203

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×