Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Jehfg17

no sound for Linux on iMac 2017 Retina 5K, 27-inch

Recommended Posts

Posted · Original PosterOP

Hey guys.

I am using an iMac 2017 Retina 5K, 27-inch and I would like to fully switch to Linux for my private use of the machine. So far so good, almost everything works like a charm but...

The sound is not working. The machine is using a weird soundcard (one of those cirruslogic ones). I tested so far different sound settings and also if there is sound on the headphone jack (No sound from internal speakers or headphone jack). On MacOS both work just fine so its not a hardware issue. I dont really know how to proceed from here. 
If any of you has an idea how to fix it or a full on solution, you're welcome to share.
Right now I am running Manjaro with the lates non-experimental kernel but I'm willing to switch if necessary. 

Greetings from Ireland,
Jehfg17

 

PS: Anthony rocks!

Link to post
Share on other sites
Posted · Original PosterOP

If you dont have any constructive answer, why even bother to answer?

Link to post
Share on other sites

use either "alsamixer" or "amixer" to change sound settings.

 

You may have to install them first as Manjaro is based on arch.

Link to post
Share on other sites
Posted · Original PosterOP

As you can see Alsamixer shows me those 3 sound cards. The Intel PCH is the internal soundcard. I chose this one and set it to 100 but it doesnt seem to be working.
 

AlsaMixer setting.png

 

According to the ifixit teardown it is a Cirruslogic 4206BCNZ Audio Controller, maybe this helps.

 

Link to post
Share on other sites

You said you are willing to switch have you tried Elementary? In my experience it runs smooth after you get past the installation (which can be a bit slow for some reason).

You can also run Tails if what you are concerned about is privacy… It is much harder to get it going and you will have to set it up every time you reboot but it can be done (don't know of any issues but haven't used for too long though).

Link to post
Share on other sites

check the audio settings in the control center and make sure the default card is that one

 

try every update you can, if not successful, try the most updated Ubuntu distro or manjaro

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×