Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Stringtheory

LSI 9207-8i with Windows 10?

Recommended Posts

Posted · Original PosterOP

I'm looking for reliable 8-port SATA 6gb cards, pref PCIe v3, x8.  Don't need RAID, so the 9207-8i seems like it would be a logical choice.  But I haven't been able to verify whether it will run under Windows 10 or not.  Do the appropriate drivers exist?

 

Link to post
Share on other sites

you will need to cross flash the card to IT-mode so you don't have to setup RAID arrays to see any drives on it at all in Windows.


PC Specs - AMD Ryzen 7 2700X MSI X370 Gaming Plus 16GB Corsair Vengeance LPX DDR4-3000 - GTX1070Ti FE 600p 256GB & M550 512GB & 860 Evo 500GB Fractal Define R5 CM V550 W8.1 Pro

Link to post
Share on other sites
8 hours ago, Stringtheory said:

I'm looking for reliable 8-port SATA 6gb cards, pref PCIe v3, x8.  Don't need RAID, so the 9207-8i seems like it would be a logical choice.  But I haven't been able to verify whether it will run under Windows 10 or not.  Do the appropriate drivers exist?

I can confirm a 9207-8i will work in Win10.

 

In fact, it will "just work" as Microsoft has drivers (though not the latest, I don't think) that Windows will pull automatically. I was actually pretty surprised when I was testing mine. Hot-swap works, too.

 

I believe I used the Win8.1 drivers from here without issue.


Main System (Byarlant): Ryzen 5 1600X | Asus B350-F Strix | Corsair H80i V2 | 16GB G.Skill DDR4 3200MHz CAS-14 | Reference Nvidia GTX 770 2GB | Samsung 960 PRO 512GB/Samsung 970 EVO 500GB/HGST 7200RPM 1TB | Corsair CX650M | Mellanox ConnectX-2 10G NIC | Anidees AI-07BW Case | Dell U3415W Monitor | Microsoft Modern Keyboard

 

FreeNAS Server (Veda): Core i3-4170 | Supermicro X10SLL-F | Corsair H60 | 32GB Micron DDR3L ECC 1600MHz | 4x 10TB WD Whites/1x Samsung PM961 128GB/1x Kingston SSD 16GB | Corsair CX430M | Mellanox ConnectX-2 10G NIC | LSI 9207-8i LBA | Fractal Design Node 804 Case (side panels swapped to show off drives)

 

Media Center (Jesta): Core i7-2600 | Asus H77M-PRO | Stock Cooler | 8GB No-name DDR3 | EVGA GTX 750Ti SC | Sandisk UltraII SSD 64GB/Samsung 850 EVO 250GB | Corsair CX450M | Hauppauge ImpactVCB-PCIe | Asus Xonar Sound | LG UH12NS30 BD-ROM | Silverstone Sugo SG-11 Case

 

Laptop (Rozen-Zulu): Sony VAIO VPCF13WFX | Core i7-740QM | 8GB Patriot DDR3 | GT 425M | Kingston 120GB SSD | Blu-ray Drive | (Still my favorite typing keyboard)


Tablet (ReGZ): Asus T102HA | Samsung EVO+ microSD 128GB

 

Testbed/Old Desktop (Kshatriya): Xeon X5470 @ 4.0GHz | ZALMAN CNPS9500 | Gigabyte EP45-UD3L | 8GB Nanya DDR2 400MHz | XFX HD6870 DD | OCZ Vertex 3 Max-IOPS 120GB | Corsair CX430M (?) | HooToo USB 3.0 PCIe Card | NZXT H230 Case

 

Camera: Sony A7II (w/ Meike Grip) | Sony SEL24240 | Sony SEL2870 | Sony SEL55F18F | PNY Elite Perfomance SDXC cards

Link to post
Share on other sites

I have a 9211-8i on my windows 10 server, flashed to IT mode and runs fine. Didn't try it when not flashed to IT though, so can't comment on that aspect.


Please quote my post, or put @paddy-stone if you want me to respond to you, I may not see your post otherwise.

 

Spoiler
  • PCs:-
  • AM4 1700 build https://uk.pcpartpicker.com/user/paddy.stone/saved/XyXyXL
  • ASUS x53e  - i7 2670QM / Sony BD writer x8 / Win 10, Elemetary OS, Ubuntu/ Samsung 830 SSD
  • Lenovo G50 - 8Gb RAM - Samsung 860 Evo 250GB SSD - DVD writer
  •  
  • Displays:-
  • Panasonic 55" 4k TV
  • LG 29" Ultrawide
  •  
  • Storage/NAS/Servers:-
  • Main Server - ASrock AB350M Pro 4 - AMD Athlon 200GE - 16GB DDR4 2133Mhz RAM - 240GB Crucial M500 SSD Boot Drive, running Windows 10, plex server - 4x 4TB Seagate Ironwolf HDDs.
  • Backup server - HP Proliant Gen 8 4 bay NAS running FreeNAS ZFS striped 3x3TiB WD reds
  • HP ProLiant G6 Server SE316M1 Twin Hex Core Intel Xeon E5645 2.40GHz 48GB RAM
  •  
  • Gaming/Tablets etc:-
  • Xbox One S 500GB + 2TB HDD
  • PS4
  • Nvidia Shield TV
  • Xiaomi/Pocaphone F1 128GB 6GB RAM
  • Xiaomi Redmi Note 4
  • Lenovo k3 note
  • Windows tablet
  •  
  • Unused Hardware currently :-
  •  
  • i7 6700K  b250 mobo - Thermaltake Core V21-  EVGA Supernova G2 650W Gold PSU
  • AMD phenom II 1055t / 8GB RAM / DVD writer
  • Zotac GTX 1060 6GB Amp! edition x2
  • Zotac GTX 1050 mini
  • Nvidia Shield K1 tablet

 

 

Link to post
Share on other sites
On 4/2/2019 at 6:27 AM, NelizMastr said:

you will need to cross flash the card to IT-mode so you don't have to setup RAID arrays to see any drives on it at all in Windows.

Actually he won't. The 9207-8i is a proper HBA, so unless someone messed with the firmware on the Card, it should be good to go out of the box.


For Sale (lots of stuff):

Spoiler

[FS] [CAD] Various things

 

 

* Intel i7-4770K * ASRock Z97 Anniversary * 16GB RAM * 750w Seasonic Modular PSU *

* Crucial M4 128GB SSD (Primary) * Hitachi 500GB HDD (Secondary) *

* Gigabyte HD 7950 WF3 * SATA Blu-Ray Writer * Logitech g710+ * Windows 10 Pro x64 *

 

Link to post
Share on other sites
Posted · Original PosterOP

Thought I'd check back with the results:  I bought two LSI 9207-8i boards.  Installed under Windows 7 for now (which I prefer for development machines).  I didn't reflash to IT-mode.  In fact, I don't know much about that, so I just went with the stock firmware.  Win7 did need the drivers to be installed.  Win10 may not...I don't know yet.

 

In any case, it seems to be running very well!  On one of the systems, I trust the LSI controller more than the built-in motherboard SATA controller.

 

I was originally considering one of the newer Syba cards when I spotted the LSI.  I'm glad I went this path.

 

Thanks to those who took the time to advise!

 

 

Link to post
Share on other sites
9 hours ago, Stringtheory said:

Thought I'd check back with the results:  I bought two LSI 9207-8i boards.  Installed under Windows 7 for now (which I prefer for development machines).  I didn't reflash to IT-mode.  In fact, I don't know much about that, so I just went with the stock firmware.  Win7 did need the drivers to be installed.  Win10 may not...I don't know yet.

The 9207-8i is an HBA (Host Bus Adapter). It doesn't need to be flashed to IT firmware. They're exactly what you need, if you want direct drive pass through (instead of hardware RAID).

9 hours ago, Stringtheory said:

In any case, it seems to be running very well!  On one of the systems, I trust the LSI controller more than the built-in motherboard SATA controller.

 

I was originally considering one of the newer Syba cards when I spotted the LSI.  I'm glad I went this path.

 

Thanks to those who took the time to advise!

No problem!


For Sale (lots of stuff):

Spoiler

[FS] [CAD] Various things

 

 

* Intel i7-4770K * ASRock Z97 Anniversary * 16GB RAM * 750w Seasonic Modular PSU *

* Crucial M4 128GB SSD (Primary) * Hitachi 500GB HDD (Secondary) *

* Gigabyte HD 7950 WF3 * SATA Blu-Ray Writer * Logitech g710+ * Windows 10 Pro x64 *

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×