Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Looking for Sapphire Nitro+ RX 570 8GB Stock BIOS

My friend got to buy an RX 570 on the secondhand market and it turns out to have no working vBIOS on it on both the vBIOSes it has since it has dual vBIOS.

AAA.thumb.jpg.650d1d66529a2b98bb051696444d853f.jpg

The card reports 0 core clock and memory clock on GPUz on one, and wouldn't reach OS on the other. We found out that the vBIOS flashed is wrong since software reported it has Micron memory but upon inspection at the chips itself, it clearly shows SKhynix (HCGC8H24MJR - R0C).

179451182_312888240206001_6645617835953555613_n.thumb.jpg.cd688fdb7747cc5128647a90ca7ed5c3.jpgAAAA.thumb.jpg.19c3c4c669c9796fb6ef729b3fdead45.jpg

 

We thought it to be not a problem because we do know how to reflash a vBIOS but then after checking every single Sapphire RX570 vBIOS that supports Hynix memory, we noticed that almost every vBIOS available at TechPowerUp for Sapphire RX 570 or RX 580 has memory chip support for only "H5GQ8H24MJR" which when looked at the specs, runs at a very slightly different voltage and all. The only available vBIOS supporting "HCGC" memory chips are 4GB cards also from Sapphire. I should note that I only tried browsing the "verified vbioses" section of TechPowerUp and not much on the unverified side.

 

Regardless, we tried flashing the HCGQ variant of the vBIOS anyways and we we're greeted with a proper readout page for GPUz, although the OS crashes when doing anything slightly gpu demanding.

180169053_1765607156944875_5875283402806733964_n.thumb.jpg.b18c0252bebd8eae93a20e222fa42a36.jpg

After reading a bit about losing stock vBIOS, we found that you can contact Sapphire for it and ask for a vBIOS. We've tried that and they only sent HCGQH24MJ one again and to no one's suprise it didn't work and it also reported 0 clock on both core and memory once again.

 

 

So now we've caught up and we're here. Does anyone somehow know any place deep in the internet (another vBIOS collection perhaps), or maybe you have the very exact vBIOS we need, or is able to do things like Anthony can that would be willing to help? We think we only need the correct vBIOS, but maybe someone can tell it is something else.

 

Any help is greatly appreciated, thanks.

*Attached vBIOSes sent by Sapphire.

AAAAAAA.jpg

123.png

366L06HU.x56 366L06HU.s4u

[H.A.N.D.] <^_^> - Have A Nice Day

 

Budget PC, my specs:
CPU: Ryzen 7 1700

GPU: Asus ROG Strix RX 580 8GB

RAM: 2x8GB DDR4 2666MHz @3000MHz

HDD: 1TB Seagate Barracuda

SSD: Kingston A4000 NVMe 256GB

Link to post
Share on other sites
13 minutes ago, Yosuru said:

After reading a bit about losing stock vBIOS, we found that you can contact Sapphire for it and ask for a vBIOS. We've tried that and they only sent HCGQH24MJ one again

Then tell Sapphire that they gave you a wrong BIOS,and ask them to give you a HCGC BIOS.

A PC Enthusiast since 2011
AMD Ryzen 5 2600@3.9GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2085MHz Memory 5000MHz
Cinebench R15: 1382cb | Unigine Superposition 1080p Extreme: 3439
Link to post
Share on other sites

Edit: There is no RX570 with that VRAM chip. Your cards VRAMs have been replaced.

mY s YsTeM iS Not pErfoRmInG aS gOOd As I sAW oN yOuTuBe. WhA t IS a GoOd FaN CuRVe??!!? wHat aRe tEh GoOd OvERclok SeTTinGS FoR My CaRd?? HoW CaN I foRcE my GpU to uSe 1o0%? BuT WiLL i HaVE Bo0tllEnEcKs? RyZEN dOeS NoT peRfORm BetTer wItH HiGhER sPEED RaM!!dId i WiN teH SiLiCON LotTerrYyOu ShoUlD dEsHrOuD uR GPUmy SYstEm iS UNDerPerforMiNg iN WarzONE.
 
 
Link to post
Share on other sites
23 minutes ago, Yosuru said:

we noticed that almost every vBIOS available at TechPowerUp for Sapphire RX 570 or RX 580 has memory chip support for only "H5GQ8H24MJR" which when looked at the specs

Found a RX 580 VBIOS with support for the same VRAM chip:

https://www.techpowerup.com/vgabios/208710/sapphire-rx580-8192-180719

A PC Enthusiast since 2011
AMD Ryzen 5 2600@3.9GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2085MHz Memory 5000MHz
Cinebench R15: 1382cb | Unigine Superposition 1080p Extreme: 3439
Link to post
Share on other sites
45 minutes ago, mahyar said:

first: have you tried to benchmark it

No, it's only either the driver wouldn't install, or the PC would crash before being able to do anything.

 

52 minutes ago, mahyar said:

second: take a look here you might find something

https://www.techpowerup.com/vgabios/192281/sapphire-rx570-8192-170322

Yeah that's for micron memory, thanks anyway

 

45 minutes ago, Vishera said:

Then tell Sapphire that they gave you a wrong BIOS,and ask them to give you a HCGC BIOS.

We did, still waiting for response :<

 

[H.A.N.D.] <^_^> - Have A Nice Day

 

Budget PC, my specs:
CPU: Ryzen 7 1700

GPU: Asus ROG Strix RX 580 8GB

RAM: 2x8GB DDR4 2666MHz @3000MHz

HDD: 1TB Seagate Barracuda

SSD: Kingston A4000 NVMe 256GB

Link to post
Share on other sites
42 minutes ago, Levent said:

Edit: There is no RX570 with that VRAM chip. Your cards VRAMs have been replaced.

There are, Gigabyte has, so does MSI, Sapphire also has but only 4GB density variant cards have records of vBIOS supporting that memory in TechPowerUp.

 

36 minutes ago, Vishera said:

Found a RX 580 VBIOS with support for the same VRAM chip:

https://www.techpowerup.com/vgabios/208710/sapphire-rx580-8192-180719

Wow, must've missed that. Although the end is a little different (AJR) instead of (MJR), still worth a shot, I'll ask him to try it. 😄

 

[H.A.N.D.] <^_^> - Have A Nice Day

 

Budget PC, my specs:
CPU: Ryzen 7 1700

GPU: Asus ROG Strix RX 580 8GB

RAM: 2x8GB DDR4 2666MHz @3000MHz

HDD: 1TB Seagate Barracuda

SSD: Kingston A4000 NVMe 256GB

Link to post
Share on other sites

Hello, i've decided to manually reflash the bios with an EEPROM usb programmer I have. But I need to know if there exists a second chip for dual bios GPUs like this Nitro+ Sapphire. Based on what i've researched, I am quite certain that this one is a bios chip. But I am quite uncertain if dual BIOS gpus uses a single chip or there lies a second chip somewhere else.

182956418_800347484020038_479941929581774201_n.thumb.jpg.29e54f620921b73d4b7081b814fc0a79.jpg

 

The bioses i tried flashing onto the card didn't work, but i have not tried everything. (I've seen some other forum with someone having the exact problem, all they had to do was try many different BIOSes after unbricking the chip with the 1+8pin method). I think i'd like to try the 1+8pin method but I thought I already had this eeprom programmer anyways so...

I've also tried the atikmdag-patcher (ATI PIXEL CLOCK PATCHER) but with no luck. We've actually found a BIOS that resulted into the GPUz not reporting 0 clocks but that was days ago (april 30) and we kinda lost the bios somewhere in the history of searches (It was on his side). I thought that was the closest we got to getting it in working state.

So here I am, about to try flashing the vBIOS with this usb programmer, brb.

[H.A.N.D.] <^_^> - Have A Nice Day

 

Budget PC, my specs:
CPU: Ryzen 7 1700

GPU: Asus ROG Strix RX 580 8GB

RAM: 2x8GB DDR4 2666MHz @3000MHz

HDD: 1TB Seagate Barracuda

SSD: Kingston A4000 NVMe 256GB

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×