Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Unknown Firewall Blocking People on Minecraft Server

Forleb
 Share

Go to solution Solved by mtz_federico,
20 hours ago, Forleb said:

Update:

• Server port has returned to 25565

• Forwarding still has 25565 both ways
• They still can't connect

 

Are there any firewalls that come to mind that would immediately prevent this from working? I have Windows Defender fully disabled & I haven't changed anything in the above screenshots. I tried turning on dynamic IP in the past but it crashed my router and forced a hard reset.

With the server running, try using a port forward testing website to see if it is open.

 

Just to clarify, you changed the routers inbound and local ports to be 25565-25565, changed the server port to 25565, you are sure that the windows firewall is disabled or is allowing port 25565 on tcp and your friends are trying to connect to [your public ip]:25565?

 

If all of that is true and they still can't connect, you might be behind Carrier grade NAT (CGNAT). To verify this, check if your routers public ip (WAN ip) is the same as the ip that you get when you google what's my ip. If they are different, then you are behind CGNAT.

I'm trying to start a minecraft server with some friends using the default software provided on minecraft.net, but for some reason nothing is allowing other people to join it. I've been able to confirm that one specific IP works vs just my IPv4, but even after port forwarding it, no dice. Are there any general firewalls I should have disabled other than Windows Defender?

If you or a loved one has been condemned to using a Dell or hp product, you are automatically entitled to compensation.

Link to comment
Share on other sites

Link to post
Share on other sites

Your ISP might be blocking these ports.

 

Could you explain a bit more what exactly you've configured, e.g. what are the port forwarding settings on the router etc.?

Remember to quote or @mention others, so they are notified of your reply

Link to comment
Share on other sites

Link to post
Share on other sites

14 minutes ago, Eigenvektor said:

Your ISP might be blocking these ports.

 

Could you explain a bit more what exactly you've configured, e.g. what are the port forwarding settings on the router etc.?

image.thumb.png.6b073d8c51ad045f042c71b14ace4766.png

image.thumb.png.6fce8c76d13cacc6bd42cac9162bf82d.png

I am able to connect specifically with port 11169, but nobody else can - they get "No route to host"

If you or a loved one has been condemned to using a Dell or hp product, you are automatically entitled to compensation.

Link to comment
Share on other sites

Link to post
Share on other sites

Are you giving them your 192.168.0.x address? Or your actual public IP address?

Current Network Layout:

Current Build Log/PC:

Prior Build Log/PC:

Link to comment
Share on other sites

Link to post
Share on other sites

12 hours ago, Forleb said:

I am able to connect specifically with port 11169, but nobody else can - they get "No route to host"

You are forwarding port 25565 to port 11169, so people coming from outside your network need to connect to port 25565, not port 11169. And, as @Lurick said, people need to connect to your public IP, not your internal IP (192.168.x.x).

 

As an aside, there's no real need to censor the 192.168.x.x IP, since it's an internal IP. No one outside your network can connect to that, since it isn't guaranteed to be unique and ISPs (and routers) never transmit connections to such an IP over the internet.

Remember to quote or @mention others, so they are notified of your reply

Link to comment
Share on other sites

Link to post
Share on other sites

56 minutes ago, Eigenvektor said:

You are forwarding port 25565 to port 11169, so people coming from outside your network need to connect to port 25565, not port 11169. And, as @Lurick said, people need to connect to your public IP, not your internal IP (192.168.x.x).

 

As an aside, there's no real need to censor the 192.168.x.x IP, since it's an internal IP. No one outside your network can connect to that, since it isn't guaranteed to be unique and ISPs (and routers) never transmit connections to such an IP over the internet.

I manually set the server's port to 11169. I just changed the forward to 25565 both ways, but having them connect with {publicIP}:11169 doesn't work. Now they're getting a timed out error.

If you or a loved one has been condemned to using a Dell or hp product, you are automatically entitled to compensation.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, Forleb said:

I manually set the server's port to 11169. I just changed the forward to 25565 both ways, but having them connect with {publicIP}:11169 doesn't work. Now they're getting a timed out error.

Your screenshots shows you forwarding port 25565 to port 11169. That means people must connect to port 25565, not 11169. The server on the other hand must listen on port 11169.

 

[public-ip]:25565 —> [internal-ip]:11169

 

13 hours ago, Forleb said:

image.thumb.png.6b073d8c51ad045f042c71b14ace4766.png

 

Remember to quote or @mention others, so they are notified of your reply

Link to comment
Share on other sites

Link to post
Share on other sites

7 minutes ago, Eigenvektor said:

Your screenshots shows you forwarding port 25565 to port 11169. That means people must connect to port 25565, not 11169. The server on the other hand must listen on port 11169.

 

 

So they should just change their port to 25565 even though I can only use 11169 from my IPv4?

If you or a loved one has been condemned to using a Dell or hp product, you are automatically entitled to compensation.

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Forleb said:

So they should just change their port to 25565 even though I can only use 11169 from my IPv4?

Yes. Since you're forwarding from 25565 to 11169, the port that is open to the outside world is 25565, not 11169. It doesn't really matter what port the server is listening to, the port forwarding takes care of "translating" from the port open to the outside and the internal port.

Remember to quote or @mention others, so they are notified of your reply

Link to comment
Share on other sites

Link to post
Share on other sites

Update:

• Server port has returned to 25565

• Forwarding still has 25565 both ways
• They still can't connect

 

Are there any firewalls that come to mind that would immediately prevent this from working? I have Windows Defender fully disabled & I haven't changed anything in the above screenshots. I tried turning on dynamic IP in the past but it crashed my router and forced a hard reset.

If you or a loved one has been condemned to using a Dell or hp product, you are automatically entitled to compensation.

Link to comment
Share on other sites

Link to post
Share on other sites

20 hours ago, Forleb said:

Update:

• Server port has returned to 25565

• Forwarding still has 25565 both ways
• They still can't connect

 

Are there any firewalls that come to mind that would immediately prevent this from working? I have Windows Defender fully disabled & I haven't changed anything in the above screenshots. I tried turning on dynamic IP in the past but it crashed my router and forced a hard reset.

With the server running, try using a port forward testing website to see if it is open.

 

Just to clarify, you changed the routers inbound and local ports to be 25565-25565, changed the server port to 25565, you are sure that the windows firewall is disabled or is allowing port 25565 on tcp and your friends are trying to connect to [your public ip]:25565?

 

If all of that is true and they still can't connect, you might be behind Carrier grade NAT (CGNAT). To verify this, check if your routers public ip (WAN ip) is the same as the ip that you get when you google what's my ip. If they are different, then you are behind CGNAT.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×