Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Hey all,

first of all, i want to apologize for my bad english. Its not my main language but ill try to do my best.

 

Recently i bought a Lenovo Legion 5-15 laptop.

Specs:

CPU:Ryzen 5 4600H

16GB RAM (i think, the retailer added 1 stick of ram)

 512 GB SSD

GPU 2060RTX.

When i got it, i've installed Windows10 Home, a game (Horizon Zero Dawn) and that's it. I used it for i think 2-3hours. After a week of not using it (emergency work related stuff) i turned it on and after ~15min the keyboard stopped working. All the keys were not respoding aside of the FN+F1-F6 keys. I tried to turn it on and off. It worked for couple of minutes and the issue came back. Tried it again and it completly stopped working. Even it stopped working trying to get into bios.

Ive reinstalled all of the drivers, reinstalled Windows and turned the reset button to the fabric state and reseted the battery (in couple of steps). Again, it worked for a couple of minutes. Ive discoverd that the keyboard works when in Device Menager, under the Keyboard tab 2 icons apear :standard keyboard PS/2 and Keyboard HID Device. It does'nt work when there is only standard keyboard PS/2.

I was wondering, do you guys know what can be the issue? Is it a broken keyboard that get overloaded after some time of its a driver issue. (Pluging a usb keyboard works fine).

I could only open the back cover of the laptop, the rest is secured and opening further can cause losing my guarantee. Im sending the laptop to the retailer on monday, but i would like to know what can be the issue.

 

 

Thank you for your help and im sorry if its not readable

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×