Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My motherboard display port doesn't work

So my motherboard display port is broken so will a graphics card display port work (i don't have a graphics card )

Link to post
Share on other sites

Is this a new build or is it a computer that has worked previously? What CPU do you have?

I mostly speak from my own past experience from similar problems. My solution may not work for you, but I'll always try my best to help as much as I can. If you want me to see your reply, make sure to quote my comment or mention me @WaggishOhio383, and I'll get back to you as soon as possible.

 

-- My PC Build --

Ryzen 7 2700x

AsRock B450 Steel Legend

XFX RX 590 Fatboy

Crucial Ballistix Tactical Tracer RGB 16GB 3200MHz
120GB Crucial BX500 SSD + 2TB Seagate Barracuda HDD

Corsair CX650M

Phanteks Eclipse P350x

Link to post
Share on other sites

CPU matters - some CPUs do not have an iGPU (integrated GPU) and require a dGPU (dedicated graphics card) in order to produce a visual display.

Workstation Laptop: Dell Precision 7540, Xeon E-2276M, 32gb DDR4, Quadro T2000 GPU, 4k display

Ryzen Rig 2: ASrock B450 Pro4 ATX, Ryzen 7 1700 @ 4.2ghz all core 1.4vCore, AMD R9 Fury X w/ Swiftech KOMODO waterblock, Custom Loop 2x240mm + 1x120mm radiators in push/pull 16gb (2x8) 3600mhz V-Color Skywalker (or 4x8gb DDR4 2666mhz for large tasks), Corsair HX850 PSU, 128gb Patriot Scorch NVMe Win 10 boot drive, 500gb Samsung 840 EVO SSD, 512GB TeamGroup MS30 M.2 SATA III, CoolerMaster HAF XM Case.  Zalman K600S keyboard, Zalman ZM-GM1 mouse, Viotek GN24C 24" 1080p 144hz curved and Hannspree HF207 as 2nd monitor

https://www.3dmark.com/3dm/37004594?

Ryzen Rig 1: ASUS B350-PRIME ATX, Ryzen 7 1700, Sapphire R9 Fury Tri-X Nitro 4gb HBM, 16gb (2x8) 3200mhz V-Color Skywalker, ANTEC Earthwatts 750w PSU, MasterLiquid Lite 120 AIO cooler in Push/Pull config as rear exhaust, 250gb Samsung 850 Evo SSD, Patriot Burst 240gb SSD, Cougar MX330-X Case.  Zalman K600S keyboard, Zalman ZM-GM1 mouse, Acer XF270HU 2560x1440 144hz IPS monitor

https://www.3dmark.com/3dm/37628874?

Dwight: The Mixed Metals Loop Media Center.  Ask me about it.  Currently decommissioned to move to an mATX setup on a new MOBO once I pick one out (getting its facelift as of June 2020 have new air cooler, drives etc.  About 60% finished.  Will no longer be a closed loop system.  Slight update, upgraded to larger SSD, and air cooling installed Arctic Alpine cooler.

Schrute: ASUS M5A99FX Pro R2.0, FX 8350, Sapphire R9 Fury Tri-X Nitro 4gb HBM, 16gb (4x4) Corsair Vengeance DDR3 1600mhz, Sparkle/FSP 650w PSU, Corsair H100i GTX 240mm AIO w/ 12mm thick fans to fit in top exhaust, 256gb TIMETEC SSD, 1tb WDBlack HDD, Rosewill Nautilus 1.0 case.  DSI 90-Key Mechanical Keyboard w/ Cherry Red switches, Zalman gaming mouse

Micro Form Factor Dell OptiPlex 3040: Dell 0MGK50 A02, i3-6100T, 2x4gb DDR3 1600, Team Group 120gb SSD, 500gb Seagate 7mm HDD attached storage, Windows 10 Pro, Logitech K400+, USB Wifi adapter all vesa mounted to the back of a 37" 1080p TV 

Linux Box: Toshiba Laptop, i7 620M, NVS graphics, 4gb ram tinker toy at the moment.  Running Manjaro XFCE at the moment.

Home Security: ZOSI 8 channel CCTV (4 used at this time, 1080p) DVR H.265+, 3tb HGST Enterprise HDD, ASUS monitor for display

Link to post
Share on other sites

We will need to know what motherboard and CPU you have. Not all CPUs have graphics processors integrated in to the CPU.

CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x16GB 3000MHz Corsair Vengeance LPX | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB + Crucial MX500 2TB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites

so my motherboard is a Asus H110m-K and the cpu is the intel pentium g4560 (the diplay port in the motherboard stopped working after i forgot to unscrew the cable and pull it out) i have used this pc before

 

 

Link to post
Share on other sites
On 10/19/2020 at 4:27 PM, WaggishOhio383 said:

Is this a new build or is it a computer that has worked previously? What CPU do you have?

so my motherboard is a Asus H110m-K and the cpu is the intel pentium g4560 (the diplay port in the motherboard stopped working after i forgot to unscrew the cable and pull it out) i have used this pc before

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×