Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Overwatch using igpu, not discrete

Hello all, first time using this new laptop and overwatch is refusing to use the discrete graphics, every other game uses the discrete card, just not overwatch,

I have tried:

Setting the physx to use the gpu for my external monitor (issue still happens when not using an external monitor.

setting global settings to only use the rtx 2080mq

set individual settings to only use the rtx 2080mq

updated nvidia drivers

disabling the igpu in device manager (this just uses the windows renderer)

uninstalling gpu drivers and reinstalling

 

specs:

rb15

i7-9750h

rtx2080mx

16gb ram

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, schwellmo92 said:

What makes you think it is using the iGPU?

task manager reporting almost no usage from gpu 1 (rtx 2080mq) and then 100% from the igpu

image.png.1d3074d0d2f32da5551232261527d8d3.png

Link to comment
Share on other sites

Link to post
Share on other sites

11 minutes ago, ImNotThere said:

task manager reporting almost no usage from gpu 1 (rtx 2080mq) and then 100% from the igpu

image.png.1d3074d0d2f32da5551232261527d8d3.png

If you go to the 'Processes' tab does it show Overwatch using 100% of the iGPU? Do you get bad FPS in Overwatch?

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, schwellmo92 said:

If you go to the 'Processes' tab does it show Overwatch using 100% of the iGPU? Do you get bad FPS in Overwatch?

yes, 100% of gpu-0, terrible frames, 30 fps on menu screen

 

Link to comment
Share on other sites

Link to post
Share on other sites

22 minutes ago, ImNotThere said:

yes, 100% of gpu-0, terrible frames, 30 fps on menu screen

 

Sometimes people set the OW Launcher to dGPU but not the actual game itself, did you set the application at this location to your dGPU? "#:\Program Files (x86)\Overwatch\_retail_\Overwatch.exe"

 

You can also try right clicking on the .exe and opening it in the high performance mode (or whatever it's called).

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, schwellmo92 said:

Sometimes people set the OW Launcher to dGPU but not the actual game itself, did you set the application at this location to your dGPU? "#:\Program Files (x86)\Overwatch\_retail_\Overwatch.exe"

yes, I found half of a fix, when the monitor is unplugged, setting the graphics settings in windows for overwatch (the game exe) to high and to use the dgpu will work find and overwatch uses the gpu, when the monitor is plugged in however, it goes back to using the igpu

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, ImNotThere said:

yes, I found half of a fix, when the monitor is unplugged, setting the graphics settings in windows for overwatch (the game exe) to high and to use the dgpu will work find and overwatch uses the gpu, when the monitor is plugged in however, it goes back to using the igpu

Seems to be a problem many have reported actually, as an example https://us.forums.blizzard.com/en/overwatch/t/100-cpu-and-gpu-when-launched-on-extended-display/339792

 

You can do Windows + P and set the primary display to laptop only, launch Overwatch then swap back to extended mode.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, schwellmo92 said:

Seems to be a problem many have reported actually, as an example https://us.forums.blizzard.com/en/overwatch/t/100-cpu-and-gpu-when-launched-on-extended-display/339792

 

You can do Windows + P and set the primary display to laptop only, launch Overwatch then swap back to extended mode.

okay, this has alleviated the problem but it is obviously still not ideal, do you know of any other solution

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×