Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Iovl123

Bad performance

Recommended Posts

Posted · Original PosterOP

Hello guys, i have a really weird problem i hope you could help me solve.. 

For some reason im getting really bad performance in jedi fallen order, thats the only game im having problems with.. 

My specs: 

I7 6700

2070 super

2133 mhz 2x8 ram

3440x1440 res

Im getting 55 fps, that fluctates between 45 to 60, with drops to 42. I would use freesync but i get insane brightness flickering in the game, to the point its not playable. Im getting same fps across all graphics settings, with epic dropping it about 3 fps more on average. 

Im getting around 80-100 fps on metro exodus with a mix of high-ultra, around 90 fps on witcher 3 on ultra, just this one game is unplayable.. 

Things ive tried: 

Reinstalling drivers. 

Overclocking gpu. 

Reinstalling game. 

Trying older drivers. 

Deleting the official game and downloading older versions from pirated sites. 

Reinstalling Windows. 

 

Im open to any suggestions..  Thanks in advance! 

Link to post
Share on other sites

Your cpu is bottlenecking your gpu. It is a 4 core 8 thread cpu, not much better than the 4770k/3770k. You might want to upgrade it, or perhaps the game just isnt optimized well.

Link to post
Share on other sites
3 minutes ago, Iovl123 said:

Hello guys, i have a really weird problem i hope you could help me solve.. 

For some reason im getting really bad performance in jedi fallen order, thats the only game im having problems with.. 

My specs: 

I7 6700

2070 super

2133 mhz 2x8 ram

3440x1440 res

Im getting 55 fps, that fluctates between 45 to 60, with drops to 42. I would use freesync but i get insane brightness flickering in the game, to the point its not playable. Im getting same fps across all graphics settings, with epic dropping it about 3 fps more on average. 

Im getting around 80-100 fps on metro exodus with a mix of high-ultra, around 90 fps on witcher 3 on ultra, just this one game is unplayable.. 

Things ive tried: 

Reinstalling drivers. 

Overclocking gpu. 

Reinstalling game. 

Trying older drivers. 

Deleting the official game and downloading older versions from pirated sites. 

Reinstalling Windows. 

 

Im open to any suggestions..  Thanks in advance! 

You could try lowering the game's graphics to low... 

Link to post
Share on other sites
Posted · Original PosterOP
54 minutes ago, Noeyedye said:

You could try lowering the game's graphics to low... 

Ive tried low also, doesnt seem to change anything. 

 

47 minutes ago, boggy77 said:

i mean, that's the performance of that gpu in that game. not much you can do about it.

Im pretty sure i used to get better performance with my 1070, cant remember clear enough though.. Beside, i would assume lowering the graphics would impact, at least to get stable 60?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×