Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
PorumbFlorin

DEAD RTX 2080Ti ?

Recommended Posts

Posted · Original PosterOP

Hello guys. 

Specs : 

ASUS Rampage VI Extreme

i9 7960X

ASUS RTX 2080 Ti

64 GB DDR 4

 

Problem

I was in gaming, and system shut down. At restart, on the MB display, i get this error : B2 Load VGA BIOS

 

What i've tryed : Only one stick or RAM, moved the GPU on different slots, BIOS update (on MB), CMOS clean... nothing, I cant even get into BIOS. Is anythig to be done or shoud i call for a replacement ? 

 

Thanks allot 

20190222_150344.jpg

Link to post
Share on other sites

If you've tried different slots and such then I would maybe try a second graphics card first, something cheap like a 610 or 210 or whatever.  If that works then it's defective and the retailer should be able to do a replacement.

 

(This is why I have a bunch of obsolete hardware on my shelf as "spares" in case I need to do component troubleshooting like replacing a PSU, gpu, memory, etc)


Workstation: 8600k @ 4.6Ghz || ASRock Z390 Taichi Ultimate || Gigabyte 1080Ti || G.Skill DDR4-3800 @ 2666 4x8GB || Corsair AX1500i || 25 gallon whole-house loop.

HTPC/GuestGamingBox: Optoma HD142X 1080p Projector || 7600K@ 4.6 || Gigabyte Z270 Gaming 9  || EVGA Titan X (Maxwell) || Corsair RM650x || CPU+GPU watercooled 280 rad pull only.

Server Router (Untangle): 8350K @ 4.5Ghz || ASRock Z370 ITX || 2x8GB || EVGA G3 750W || CPU watercooled, 25 gallon whole-house loop.

Server VM/Plex/HTTPS: E5-2699v4 (22 core!) || Asus X99m WS || GT 630 || Corsair RM650x || CPU watercooled, 25 gallon whole-house loop.

Server Storage: Pent. G3220 || Z87 Gryphon mATX || || LSI 9280i + Adaptec + Intel Expander || 4x10TB Seagate Enterprise Raid 6, 3x8TB Seagate Archive Backup, Corsair AX1200i (drives) Corsair RM450 (machine) || CPU watercooled, 25 gallon whole-house loop.

On the Shelf: EVGA X99 micro2, 780, 740 GT, 210 w/ DVI port unsoldered (Hint: it can be done but it ain't easy). 

Laptop: HP Elitebook 840 G3 (Intel 8350U).

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, AnonymousGuy said:

If you've tried different slots and such then I would maybe try a second graphics card first, something cheap like a 610 or 210 or whatever.  If that works then it's defective and the retailer should be able to do a replacement.

 

(This is why I have a bunch of obsolete hardware on my shelf as "spares" in case I need to do component troubleshooting like replacing a PSU, gpu, memory, etc)

Thanks for the reply. 

The thing is ( i just want to make sure ), is that a hardware issue or a software one ? Based on that error. It might sound stupid, but i'm not really into these things. And, any ideas WHAT was the cause ?

Thank you 

Link to post
Share on other sites
Just now, PorumbFlorin said:

Thanks for the reply. 

The thing is ( i just want to make sure ), is that a hardware issue or a software one ? Based on that error. It might sound stupid, but i'm not really into these things. And, any ideas WHAT was the cause ?

Thank you 

Hardware.  The BIOS isn't able to initialize the card.  ^ raised a good point to to make sure the PSU cables are seated and not bad.

 

My first Titan X (maxwell) popped when I plugged it in and powered it on for the first time.  These things happen periodically.


Workstation: 8600k @ 4.6Ghz || ASRock Z390 Taichi Ultimate || Gigabyte 1080Ti || G.Skill DDR4-3800 @ 2666 4x8GB || Corsair AX1500i || 25 gallon whole-house loop.

HTPC/GuestGamingBox: Optoma HD142X 1080p Projector || 7600K@ 4.6 || Gigabyte Z270 Gaming 9  || EVGA Titan X (Maxwell) || Corsair RM650x || CPU+GPU watercooled 280 rad pull only.

Server Router (Untangle): 8350K @ 4.5Ghz || ASRock Z370 ITX || 2x8GB || EVGA G3 750W || CPU watercooled, 25 gallon whole-house loop.

Server VM/Plex/HTTPS: E5-2699v4 (22 core!) || Asus X99m WS || GT 630 || Corsair RM650x || CPU watercooled, 25 gallon whole-house loop.

Server Storage: Pent. G3220 || Z87 Gryphon mATX || || LSI 9280i + Adaptec + Intel Expander || 4x10TB Seagate Enterprise Raid 6, 3x8TB Seagate Archive Backup, Corsair AX1200i (drives) Corsair RM450 (machine) || CPU watercooled, 25 gallon whole-house loop.

On the Shelf: EVGA X99 micro2, 780, 740 GT, 210 w/ DVI port unsoldered (Hint: it can be done but it ain't easy). 

Laptop: HP Elitebook 840 G3 (Intel 8350U).

Link to post
Share on other sites

This is scarin me, keep us posted OP

 

Also that's a sicc motherboard


Current Build

Spoiler

System

  • CPU
    Ryzen 2700x
  • Motherboard
    ASrock x470 Fatal1ty k4
  • RAM
    16GB
  • GPU
    EVGA RTX 2080 Ti Black
  • Case
    Corsair 570x
  • Storage
    480gb SSD
  • PSU
    Thermaltake Smart M 650W 80+ Bronze
  • Display(s)
    27 inch Dell S2716DG
  • Cooling
    Wraith Prism
  • Keyboard
    Razer Huntsman
  • Mouse
    Corsair M65 pro
  • Sound
    Beyerdynamic dt770
  • Operating System
    Windows 10

 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, ELSknutson said:

re check to see if all your power cables are seated properly 

I will do that, i will change the cables and i will give a reply asap

Link to post
Share on other sites
Posted · Original PosterOP
33 minutes ago, AnonymousGuy said:

Hardware.  The BIOS isn't able to initialize the card.  ^ raised a good point to to make sure the PSU cables are seated and not bad.

 

My first Titan X (maxwell) popped when I plugged it in and powered it on for the first time.  These things happen periodically.

Just changed the cables, still the same err.. I guess i will submit a replace form .  I cant believe i have to replace a 2080 ti so soon. Funny thing  (or not), it happen while i was playing Resident Evil 2. And when you press START GAME, the name of the game cranks on the screen. I pressed that, and it f...up  my VGA :((((

 

Thanks for the help guys. 

Link to post
Share on other sites
4 minutes ago, PorumbFlorin said:

Just changed the cables, still the same err.. I guess i will submit a replace form .  I cant believe i have to replace a 2080 ti so soon. Funny thing  (or not), it happen while i was playing Resident Evil 2. And when you press START GAME, the name of the game cranks on the screen. I pressed that, and it f...up  my VGA :((((

Thanks for the help guys. 

RIP, good luck with the RMA process, at least you still got the Titan, if mine dies i have my backup 1080 lol


Current Build

Spoiler

System

  • CPU
    Ryzen 2700x
  • Motherboard
    ASrock x470 Fatal1ty k4
  • RAM
    16GB
  • GPU
    EVGA RTX 2080 Ti Black
  • Case
    Corsair 570x
  • Storage
    480gb SSD
  • PSU
    Thermaltake Smart M 650W 80+ Bronze
  • Display(s)
    27 inch Dell S2716DG
  • Cooling
    Wraith Prism
  • Keyboard
    Razer Huntsman
  • Mouse
    Corsair M65 pro
  • Sound
    Beyerdynamic dt770
  • Operating System
    Windows 10

 

Link to post
Share on other sites
15 minutes ago, Emanbaird said:

RIP, good luck with the RMA process, at least you still got the Titan, if mine dies i have my backup 1080 lol

And i was told the "die early" batch was already gone. Like my ass it is.


Gorishi Hive King

 

ゴリシ蜂の巣の王

Link to post
Share on other sites
2 minutes ago, ReggieGRS said:

And i was told the "die early" batch was already gone. Like my ass it is.

This is what influenced my purchase of an EVGA card, i'd gone through a lot of RMA's in the past.

Corsair/EVGA take the cake. 


Current Build

Spoiler

System

  • CPU
    Ryzen 2700x
  • Motherboard
    ASrock x470 Fatal1ty k4
  • RAM
    16GB
  • GPU
    EVGA RTX 2080 Ti Black
  • Case
    Corsair 570x
  • Storage
    480gb SSD
  • PSU
    Thermaltake Smart M 650W 80+ Bronze
  • Display(s)
    27 inch Dell S2716DG
  • Cooling
    Wraith Prism
  • Keyboard
    Razer Huntsman
  • Mouse
    Corsair M65 pro
  • Sound
    Beyerdynamic dt770
  • Operating System
    Windows 10

 

Link to post
Share on other sites
4 minutes ago, Emanbaird said:

This is what influenced my purchase of an EVGA card, i'd gone through a lot of RMA's in the past.

Corsair/EVGA take the cake. 

Asus belongs on that list too. First impressions last a lifetime, and after experiencing their customer service I don't think I will ever branch away from them (unless they dont make a component I need.)


Main PC: i5-8600K (6C/6T), MSI Z370M, T-Force Delta II RGB 16GB, Samsung 128GB NVME, Crutial MX300, ROG STRIX RX-580 8GB, Corsair CX 750, Fractal Define Mini C TG, Windows 10 Enterprise

School Laptop: Late 2008 Macbook Aluminum Unibody. C2D P7350, nVidia 9800M, 8GB RAM, 1 TB HDD, macOS Mojave. Also my editing laptop (FCP > Adobe Premier)

Phone: Galaxy Note 8, Android 8.0

Random devices in various stages of working: Gateway Solo W2000 Laptop (For writing floppies, needs a battery), iBook G3 Clamshell (for a custom build, just a case), iBook G4 (For Sale.), Surface 3 (Touch screen is borked, perfect otherwise.), Lenovo G580 (For Sale)

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, ReggieGRS said:

And i was told the "die early" batch was already gone. Like my ass it is.

I herd  of those cases as well, and you never think is gonna' happen to you until it does. And it sucks ! I was getting ready for Metro Exodus... now i'm left with mobile legends ...wtf  

Link to post
Share on other sites
1 minute ago, SenpaiKaplan said:

Asus belongs on that list too. First impressions last a lifetime, and after experiencing their customer service I don't think I will ever branch away from them (unless they dont make a component I need.)

I've owned a ton of things from Asus, and nothing I've owned from them has died (Yet)


This includes my original P6t from ~2009 which is still in use in a friends build somewhere (I'm actually getting it back this year to do a retro build) a couple of strix cards, and an old lga 775 board, 


Current Build

Spoiler

System

  • CPU
    Ryzen 2700x
  • Motherboard
    ASrock x470 Fatal1ty k4
  • RAM
    16GB
  • GPU
    EVGA RTX 2080 Ti Black
  • Case
    Corsair 570x
  • Storage
    480gb SSD
  • PSU
    Thermaltake Smart M 650W 80+ Bronze
  • Display(s)
    27 inch Dell S2716DG
  • Cooling
    Wraith Prism
  • Keyboard
    Razer Huntsman
  • Mouse
    Corsair M65 pro
  • Sound
    Beyerdynamic dt770
  • Operating System
    Windows 10

 

Link to post
Share on other sites
Just now, Emanbaird said:

I've owned a ton of things from Asus, and nothing I've owned from them has died (Yet)


This includes my original P6t from ~2009 which is still in use in a friends build somewhere (I'm actually getting it back this year to do a retro build) a couple of strix cards, and an old lga 775 board, 

I nearly RMA'd a ROG STRIX RX580, which was purchased 2nd hand, used, and was a mining card. Asus was happy to RMA it even knowing these conditions (Previous owner purchased extended warrenty). I ended up fixing the issue, and cancelled the RMA. But that some damned good service.


Main PC: i5-8600K (6C/6T), MSI Z370M, T-Force Delta II RGB 16GB, Samsung 128GB NVME, Crutial MX300, ROG STRIX RX-580 8GB, Corsair CX 750, Fractal Define Mini C TG, Windows 10 Enterprise

School Laptop: Late 2008 Macbook Aluminum Unibody. C2D P7350, nVidia 9800M, 8GB RAM, 1 TB HDD, macOS Mojave. Also my editing laptop (FCP > Adobe Premier)

Phone: Galaxy Note 8, Android 8.0

Random devices in various stages of working: Gateway Solo W2000 Laptop (For writing floppies, needs a battery), iBook G3 Clamshell (for a custom build, just a case), iBook G4 (For Sale.), Surface 3 (Touch screen is borked, perfect otherwise.), Lenovo G580 (For Sale)

Link to post
Share on other sites
21 minutes ago, Emanbaird said:

This is what influenced my purchase of an EVGA card, i'd gone through a lot of RMA's in the past.

Corsair/EVGA take the cake. 

I got my hands on a hof from galax. If that shit dies on me i will be monumentally furious and probably never get an rtx card ever again.


Gorishi Hive King

 

ゴリシ蜂の巣の王

Link to post
Share on other sites

I love the GALAX cards, it's almost impossible to find them in the states, i tried for a 1070 Katana, but my local retailer didn't have them in stock, and when they did there were 1080's NIB for the same price $450


Current Build

Spoiler

System

  • CPU
    Ryzen 2700x
  • Motherboard
    ASrock x470 Fatal1ty k4
  • RAM
    16GB
  • GPU
    EVGA RTX 2080 Ti Black
  • Case
    Corsair 570x
  • Storage
    480gb SSD
  • PSU
    Thermaltake Smart M 650W 80+ Bronze
  • Display(s)
    27 inch Dell S2716DG
  • Cooling
    Wraith Prism
  • Keyboard
    Razer Huntsman
  • Mouse
    Corsair M65 pro
  • Sound
    Beyerdynamic dt770
  • Operating System
    Windows 10

 

Link to post
Share on other sites

They supposedly have pretty good costumer service in my country but still. RMA a card of this level feels wrong. Shouldn't ever be needed. Guess time will tell if i'll be making the first RMA of my life or not.


Gorishi Hive King

 

ゴリシ蜂の巣の王

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×