Jump to content

Crashing whenever I alt tab from games

Hi, I've been having issues with my PC where when I alt tab from games, my system will crash to a black screen and reboot. The only critical event in event viewer at the time of the crash is Kernel-Power 41.

The most consistent way to reproduce the crash for me is to load into a community server in Counterstrike 2, alt tab and watch a YouTube video in Firefox. However the crash has also happened where I've been in the CS2 menu and alt tabbed to change someone's volume in discord, when playing xDefiant and alt tabbing to change my music in Spotify, playing Helldivers 2 and alt tabbing to change volume in discord (even with dx11 enabled, etc).

Build Components:

  • CPU: AMD 5800x3d

  • GPU: AMD XFX 310 Merc 7900xt

  • MOBO: MSI MAG X570S Tomahawk Max WiFi

  • RAM: 32GB Gskill Ripjaw 3600mhz cl18

  • PSU: CORSAIR RM850X (2021)

  • Storage: Samsung 970 EVO Plus NVME

  • CPU Cooler: EKWB EK-AIO Elite 360 D-RGB CPU Cooler

Fixes I've tried:

  • DDU/Amd cleanup utility and reinstall drivers

  • Checked Crystaldisk info, no drive errors

  • Ran memtest86 with XMP both off and on, no issues

  • Disabled fast startup in windows, made the crashes happen faster when alt tabbing, couldn't even open firefox when in the main menu of cs2

  • Different PSU (Corsair RM750), still crashed

  • Different GPU (GTX 1070), no crash

  • Tried the GPU (7900xt) in a different system, (with the RM750) no crash

  • Monitored thermals while running Furmark CPU and GPU, no throttling

  • Fresh install to Windows 10, was on Windows 11 previously (currently on W10 22H2)

  • Updated the bios to the latest version, still happens (BIOS version 7D54v18)

  • Latest AMD chipset drivers are installed from the motherboard's webpage (

  • Tried different GPU drivers, nothing helped, currently on the latest version (24.5.1)

Kinda running out of ideas tbh, either it's a CPU issue or Motherboard issue and I can't test either of those as I don't have other parts as my old system which I used parts to test with has an Intel CPU/MOBO. Any help would be appreciated.

Link to comment
Share on other sites

Link to post
Share on other sites

Have you tried removing a stick of ram to see if that helps?

sup dawg


Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now