Jump to content

My PC suddenly shut down and the it won't turn on anymore. Will it also bring the other components with it to the grave?

 Share

I was playing and it suddenly shut down and it won't turn on again. Did it also killed the rest of my PC components? I can't test most of it since I don't have another PC that uses the same chipset  and only low profile graphics cards could be fit in those. 

Link to comment
Share on other sites

Link to post
Share on other sites

Does the system receive power?

Does it light up, beep or have the debug LED on?

A PC Enthusiast since 2011
AMD Ryzen 5 2600@4.1GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2085MHz Memory 5000MHz
Cinebench R15: 1349cb | Unigine Superposition 1080p Extreme: 3566
Link to comment
Share on other sites

Link to post
Share on other sites

What are the full system specs includes brand and model of the PSU?

Link to comment
Share on other sites

Link to post
Share on other sites

31 minutes ago, Vishera said:

Does the system receive power?

Does it light up, beep or have the debug LED on?

No and No. 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, --SID-- said:

What are the full system specs includes brand and model of the PSU?

GTX 1050 Ti

i5 6400

16 GB RAM Ripjaws V

Corsair CV450

Asus H110M-K

Samsung 860 EVO 500GB

500GB WD Blue HDD

Some cheap PC case

Link to comment
Share on other sites

Link to post
Share on other sites

Take out the HDD, SSD, graphics card and one of the RAMs. See if it boots

 

Most likely, the PSU or motherboard went to jack, but the otehr components are fine.

If you are an electronics nerd and have a multimeter, you can see if the PSU gives the correct power on the ATX pins.

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Newblesse Obblige said:

No and No. 

The PSU or the motherboard are the most likely components to cause such symptoms.

 

Try assembling the computer outside the case then try to power it on.

A PC Enthusiast since 2011
AMD Ryzen 5 2600@4.1GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2085MHz Memory 5000MHz
Cinebench R15: 1349cb | Unigine Superposition 1080p Extreme: 3566
Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Vishera said:

The PSU or the motherboard are the most likely components to cause such symptoms.

 

Try assembling the computer outside the case then try to power it on.

that is a bit risky, mounted tests should be enough.

Link to comment
Share on other sites

Link to post
Share on other sites

32 minutes ago, sharkaroid said:

Take out the HDD, SSD, graphics card and one of the RAMs. See if it boots

 

Most likely, the PSU or motherboard went to jack, but the otehr components are fine.

If you are an electronics nerd and have a multimeter, you can see if the PSU gives the correct power on the ATX pins.

I did the paperclip test on the PSU and the fan did not spin. Does that mean the PSU is dead? I don't have any extra PSU to test the motherboard tho

Link to comment
Share on other sites

Link to post
Share on other sites

It really depends. Case-by-case basis, mainly what failed. It's probably not that common, but I've seen a PSU fail and nuke the entire system. So you would really need to individually test the components.

1 minute ago, Newblesse Obblige said:

I did the paperclip test on the PSU and the fan did not spin. Does that mean the PSU is dead? I don't have any extra PSU to test the motherboard tho

As I said, the only way to know is, as others have said, a multimeter test of output voltage, and testing individual components (usually requires swapping components in another setup).

Edited by An0maly_76
Revised, more info

I don't badmouth others' input, I'd appreciate others not badmouthing mine. *** More below ***

 

MODERATE TO SEVERE AUTISTIC, COMPLICATED WITH COVID FOG

 

Due to the above, I've likely revised posts <30 min old, and do not think as you do.

THINK BEFORE YOU REPLY!

Link to comment
Share on other sites

Link to post
Share on other sites

35 minutes ago, An0maly_76 said:

It really depends. Case-by-case basis, mainly what failed. It's probably not that common, but I've seen a PSU fail and nuke the entire system. So you would really need to individually test the components.

As I said, the only way to know is, as others have said, a multimeter test of output voltage, and testing individual components (usually requires swapping components in another setup).

Like I said, I can't test most of it since I don't have a the equipment to do so and I don't have another PC that uses the same chipset and only low profile graphics cards could be fit in those PCs as they have Slim form factor(SFF?). I guess I'm really have go to a PC technician.

Link to comment
Share on other sites

Link to post
Share on other sites

34 minutes ago, Newblesse Obblige said:

Like I said, I can't test most of it since I don't have a the equipment to do so... I guess I'm really have go to a PC technician.

In this day and age not having a multimeter is surprising. I even have my mother's one that she bought 60 years ago. They cost under $10 these days.

 

I could give you a link to a website to show what to look for in the PSU but the Moderators won't allow it because it has more useful information than their website. I suspect a capacitor or two are faulty. However as you probably don't have a soldering iron or know how to use one it doesn't really matter.

 

It would seen you will have to take the entire system to a PC technician.  Yes, I can do it on Monday but you probably don't want to travel half way round the world.

Link to comment
Share on other sites

Link to post
Share on other sites

Yeah get a multimeter or buy some cheapo PSU and mobo at Amazon, if it still doesn't work you can send them back...

System : AMD R9 5900X / X570 AORUS PRO/ 2x16GB Corsair Vengeance 3600CL18 / RTX3080 Gigabyte EAGLE GPU/ Phanteks P600S case / Customized Watercooling Eisbaer 280mm + Eiswolf2 360mm + VPP755 pump  and 150mm reservoir0.5TB Sabrent Rocket + 2TB WD SN850 NVme Gen4 + 4TB Toshiba X300 HDD drives/ Corsair RM850x PSU/ 34" 120Hz 3440x1440p Alienware AW3420DW monitor / Logitech G915TKL keyboard (wireless) / Logitech G PRO X Superlight mouse

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, RollyShed said:

In this day and age not having a multimeter is surprising. I even have my mother's one that she bought 60 years ago. They cost under $10 these days.

 

I could give you a link to a website to show what to look for in the PSU but the Moderators won't allow it because it has more useful information than their website. I suspect a capacitor or two are faulty. However as you probably don't have a soldering iron or know how to use one it doesn't really matter.

 

It would seen you will have to take the entire system to a PC technician.  Yes, I can do it on Monday but you probably don't want to travel half way round the world.

I think know the problem now but Ill make another thread since it isn't really related to the PSU anymore as the PSU and the motherboard is working. The GPU seems the one that makes it not boot at all

Link to comment
Share on other sites

Link to post
Share on other sites

7 hours ago, Newblesse Obblige said:

I think know the problem now but Ill make another thread since it isn't really related to the PSU anymore as the PSU and the motherboard is working. The GPU seems the one that makes it not boot at all

PSU failed the paper clip test but you think it's the GPU? - Very unlikely.

Try powering the system with a different power supply and using the iGPU - There is no need to connect the graphics card.

A PC Enthusiast since 2011
AMD Ryzen 5 2600@4.1GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2085MHz Memory 5000MHz
Cinebench R15: 1349cb | Unigine Superposition 1080p Extreme: 3566
Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×