Jump to content

Can't See Network Computers to Share Files!

malawar
 Share

Go to solution Solved by malawar,

Ok so I did some more research based on why I can't ping 2 devices on the same network and here's what worked for me. Thanks @OddOod

 

1) Firewall > Advanced Settings > Inbound Rules > enable all File and Printer Sharing rules

 

2) Type services in windows search > restart Function Discovery services (try them one at a time, while having the network page open to check)

Hello Friends,

 

I'm unable to see computers on my network. I hope someone can help.

 

In case there are different solutions; the reason I need to set this up is: I need to transfer the files from an intel-laptop with a 10TB ext drive, to my AMD PC; but obviously the PC can't access a thunderbolt drive.

 

Here's what I've done so far on both PC and laptop:

 

Made sure network is set to private

Turned on network discovery AND file/printer sharing for private profile and guest

Turned on sharing under all networks and turned off password protected sharing

Made sure relevant services are on and set to "auto" (UPNP, Function discovery, etc, etc)

Tried sharing a folder on my desktop and the drive itself (for the drive, the share button is greyed out under the share tab, advanced sharing is ok. folder on dekstop, share button is not greyed out.)

Made sure SMB feature is on

Updated to latest windows 10

Restarted multiple times

 

I've gone through multiple videos/articles, and I can't figure out why the computers won't show up under the network. Other devices that I haven't done anything with show up without any problem. Although I can't access them because they need to be set up.

 

PS - I can only see the device and shared folder on the network when I click the button in the picture below. But then the computer is listed under "unspecified". Still not visible to other devices though, and it just disappears when I close the folder.

 

image.png.7fc0b1f9d62990e103bb1bcd30f34261.png

Link to comment
Share on other sites

Link to post
Share on other sites

To do so, open a cmd shell, type:
 ipconfig /all
find the Physical Address and use that in a cmd shell on the desktop with 

 ping [ip address]


 

Link to comment
Share on other sites

Link to post
Share on other sites

This will double check that the computers are on the same network and visible to each other. 

 

Link to comment
Share on other sites

Link to post
Share on other sites

On 8/8/2022 at 7:48 PM, OddOod said:

This will double check that the computers are on the same network and visible to each other. 

 

Thank you so much, I've found both physical addresses as you suggested. Then, I pinged the laptop from the desktop, but I got the error message you can see on the screenshot below.

 

I don't understand why though? They are both on the same network?

 

Internet is setup kind of like this: Modem > main router > network switch > other routers

 

There is one place where it goes from the main network switch to another switch. I don't know if any of that is relevant?

 

image.png.6a5d8f45205ae93ba5a33824cab71aca.png

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Ok so I did some more research based on why I can't ping 2 devices on the same network and here's what worked for me. Thanks @OddOod

 

1) Firewall > Advanced Settings > Inbound Rules > enable all File and Printer Sharing rules

 

2) Type services in windows search > restart Function Discovery services (try them one at a time, while having the network page open to check)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×