Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

I need help with my Dyson Vacuum (very off topic)

Meowster
 Share

Go to solution Solved by Curious Pineapple,

Yeh, the power switch has worn out.

 

If you know what you're doing: https://www.amazon.co.uk/Switch-Dyson-Cleaner-Equivalent-91097101/dp/B005M4ANGA

I own a Dyson DC19 Animal and it has worked perfectly for a long time but recently it started acting strange. It turns on but stops working literally 2 seconds after I push the power button. I noticed this morning if I wiggle the power button a bit, I hear some electrical buzzing and the machine works until I stop wiggling the power button. Can someone please help me resolve the issue? I know this vacuum is outdated but it is still very good. I contacted Dyson but they didn't know what was causing this. Maybe someone here can help.

 

Once again, this is very off topic

Make sure to quote me @Meowster  so that I see your reply

I love my job, being a sysadmin. It's very fun 

 

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, GenericFanboy said:

Sounds like its... broken? RMA it lol. 

As far as I know, I think you need warranty to RMA something, this vacuum is 7 years out of warranty and I don't have the receipt. Looks like I can't RMA it sadly

Make sure to quote me @Meowster  so that I see your reply

I love my job, being a sysadmin. It's very fun 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, Curious Pineapple said:

Yeh, the power switch has worn out.

 

If you know what you're doing: https://www.amazon.co.uk/Switch-Dyson-Cleaner-Equivalent-91097101/dp/B005M4ANGA

This looks like a good idea, will buy and try and repair it. My grandad has better knowledge about these things than I do, can ask him.

Thanks for the help

Make sure to quote me @Meowster  so that I see your reply

I love my job, being a sysadmin. It's very fun 

 

Link to comment
Share on other sites

Link to post
Share on other sites

@Curious Pineapple Thanks so much for the help! The switch came and I installed it, took a bit of time and patience (which I don't have :)) but eventually I got it to work again. Thanks so much!

Make sure to quote me @Meowster  so that I see your reply

I love my job, being a sysadmin. It's very fun 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Meowster said:

@Curious Pineapple Thanks so much for the help! The switch came and I installed it, took a bit of time and patience (which I don't have :)) but eventually I got it to work again. Thanks so much!

 No problem :)

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×