Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

USB-C Webcam not detected over Thunderbolt 3 port

Dredgy
 Share

In early days of trying to troubleshoot, but not sure so much what to try.

 

  • Have an Asrock X570 ITX TB3 motherboard, which has a thunderbolt port on the back. 
  • Initially tried plugging in a Logitech Streamcam (USB-C) to that TB3 port. It did not show up.
  • Camera worked just fine if I plugged it into the USB-C port on the front panel. 
  • Last week I had a teleconference and just plugged the camera into the TB port on the back and restarted the computer. Didn't expect it to work, but it did.
  • Have restarted at some point this week and now the camera is simply not showing up again. I have restarted a few more times, reoriented the plug, reinstalled chipset drivers, installed Logitech's capture software. No dice.
  • I have at the moment no other Thunderbolt devices (backorder due to Covid), but my SanDisk Extreme SSD USB-C drive works fine over the Thunderbolt port so the port is not dead. Likewise the camera works fine in the front panel USB-C port (but has worked in the thunderbolt port in the past), just that port is poorly located relative to the camera.

Any ideas?

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×