Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
xelu

AC-9560 doesn't want to do Wifi 6

Recommended Posts

Posted · Original PosterOP

So I just bought a fresh new Asus RT-AX88U, I've set the 5Ghz to 802.11ax only and that resulted in my PC not being able to connect to it at all.

 

I'm using an ROG Strix Z390-I with a i9-9900K and the network adapter is the built in AC-9560.

I've updated its drivers to version 21.90.3.2 (it even says 160Mhz in the network adapter description) and yet, no option to select 802.11.ax anywhere in advanced settings nor can I connect to the network.

 

I'm not sure what to do next...

Link to post
Share on other sites
2 hours ago, xelu said:

So I just bought a fresh new Asus RT-AX88U, I've set the 5Ghz to 802.11ax only and that resulted in my PC not being able to connect to it at all.

 

I'm using an ROG Strix Z390-I with a i9-9900K and the network adapter is the built in AC-9560.

I've updated its drivers to version 21.90.3.2 (it even says 160Mhz in the network adapter description) and yet, no option to select 802.11.ax anywhere in advanced settings nor can I connect to the network.

 

I'm not sure what to do next...

That adaptor is 802.11ac, why do you expect it to connect to a Wifi 6 only network? Supporting 160MHz was available with AC, it was just a dumb choice that noone should use. Even with Wifi 6, it shouldn’t be used. Wifi 6E with 6GHz will make 160MHz worthwhile.


Looking to buy GTX690, other multi-GPU cards, or single-slot graphics cards: 

 

Link to post
Share on other sites
8 hours ago, xelu said:

So I just bought a fresh new Asus RT-AX88U, I've set the 5Ghz to 802.11ax only and that resulted in my PC not being able to connect to it at all.

 

I'm using an ROG Strix Z390-I with a i9-9900K and the network adapter is the built in AC-9560.

I've updated its drivers to version 21.90.3.2 (it even says 160Mhz in the network adapter description) and yet, no option to select 802.11.ax anywhere in advanced settings nor can I connect to the network.

 

I'm not sure what to do next...

Either get a proper WiFi 6 supported adapter or set the 5GHz radio for AC/AX. You’re not going to get the full benefits of WiFi 6 with the latter option unless you do the former.

 

Additionally, please don’t use a 160MHz channel width unless you have a clear 5GHz spectrum. 80MHz should be fine. If you don’t check for neighborhood WiFi, you’re just being a spectrum hog, which is quite impolite to your neighbors.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×