Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Affnx

No sound output device with GPU plugged in

Recommended Posts

Posted · Original PosterOP

I'm using a Radeon RX 580 8GB from xfx and when I use my pc there is no audio output from my monitor but if I plug headphones in, they work how they should. I've attached screenshots of when headphones are unplugged and plugged.

If you have any tips or fixes I could try please message my discord @affnx#4381.

Thank you.

Capture.PNG

Capture.PNG

Capture.PNG

Capture.PNG

Link to post
Share on other sites
15 minutes ago, Affnx said:

I'm using a Radeon RX 580 8GB from xfx and when I use my pc there is no audio output from my monitor but if I plug headphones in, they work how they should. I've attached screenshots of when headphones are unplugged and plugged.

So to be clear, your monitor has onboard speakers and you wish to use them? I believe your GPU has nothing to do with audio output, only video. Audio goes through the I/O ports on your motherboard.

 

Could it be that the onboard audio for your monitor is not working?


When the son of the deposed king of Nigeria emails you directly, asking for help, you help! His father ran the freaking country! Ok?

Link to post
Share on other sites

2 questions does your monitor have speakers? and are you using hdmi or display port?


***FEEL FREE TO DM ME QUESTIONS ABOUT MY GEAR IF YOU HAVE ANY QUESTIONS OR JUST CURIOUS***

CPU : ryzen 3600x  Motherboard: b350 PC mate RAM:16 GB ddr4 corsair lpx GPU: gtx 1070 6gb Case:phanteks p400 

Storage:x1 280 gb kingston ssd x1 1tb WD blue hdd x1 2tb seagate barraccuda 

 PSU:650 GQ Cooling:be quite! BK009 Keyboard:ducky one 2 rgb full sized Mouse:G502, Model o Operating System:win 10

Desktop audio gear: topping d10 --->  monolith Cavelli Liquid Spark---> Beyerdynamic dt 990 , Sennheiser Hd 58x, Hifiman HE4xx, AKG k240, AKG k52

Speaker Setup: Topping PA3--->Micca RB42

My portable setup: fiio Q1 mk2, fiio ubtr, fiio btr1k,fiio btr5---> Tin T2,Tin t3,Tin t4, QKZ VK4, Koss ksc 75,Blon 03 , Vido

 AKG y50bt,Sennheiser HD 4.40

Link to post
Share on other sites
16 minutes ago, Quackwich said:

So to be clear, your monitor has onboard speakers and you wish to use them? I believe your GPU has nothing to do with audio output, only video. Audio goes through the I/O ports on your motherboard.

thats not entirely true as audio can be sent by the gpu through HDMI or display port 


***FEEL FREE TO DM ME QUESTIONS ABOUT MY GEAR IF YOU HAVE ANY QUESTIONS OR JUST CURIOUS***

CPU : ryzen 3600x  Motherboard: b350 PC mate RAM:16 GB ddr4 corsair lpx GPU: gtx 1070 6gb Case:phanteks p400 

Storage:x1 280 gb kingston ssd x1 1tb WD blue hdd x1 2tb seagate barraccuda 

 PSU:650 GQ Cooling:be quite! BK009 Keyboard:ducky one 2 rgb full sized Mouse:G502, Model o Operating System:win 10

Desktop audio gear: topping d10 --->  monolith Cavelli Liquid Spark---> Beyerdynamic dt 990 , Sennheiser Hd 58x, Hifiman HE4xx, AKG k240, AKG k52

Speaker Setup: Topping PA3--->Micca RB42

My portable setup: fiio Q1 mk2, fiio ubtr, fiio btr1k,fiio btr5---> Tin T2,Tin t3,Tin t4, QKZ VK4, Koss ksc 75,Blon 03 , Vido

 AKG y50bt,Sennheiser HD 4.40

Link to post
Share on other sites
Posted · Original PosterOP

the monitors onboard audio is fine, I have a ryzen 3200G so when I was troubleshooting it I took the GPU out and audio would work

Link to post
Share on other sites
Posted · Original PosterOP

I am using HDMI and when I use integrated graphics, audio works fine

Link to post
Share on other sites

Can you post a screenshot of Device Manager with the "Sound, Video and Game Controllers" tree expanded when the GPU is installed?


PC: Ryzen 5-3600 / MSI MPG X570 Gaming Plus / 16GB (2x8GB) Corsair Vengeance LPX 3600 / MSI GTX 1070 TI Gaming / Phanteks P400S / LG 34" Ultrawide IPS

Laptop: Lenovo X230 / OS X 10.15 Hackintosh (OpenCore)

F@H ID: Paroxy777

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Paroxy said:

Can you post a screenshot of Device Manager with the "Sound, Video and Game Controllers" tree expanded when the GPU is installed?

there you go

Capture.PNG

Link to post
Share on other sites

Does your GPU have the latest drivers installed? Could we also know the make/model of your monitor?


When the son of the deposed king of Nigeria emails you directly, asking for help, you help! His father ran the freaking country! Ok?

Link to post
Share on other sites

If you want audio through HDMI to your monitor then you need to install or reinstall the drivers for the graphics card. Clearly HD audio does not appear to be installed.

 

Enter the link below to find the drivers for your graphics card and choose the operating system you are using (Windows 10 or whatever it may be), download the file to your hard drive and then run the installer.

 

When installer runs choose CUSTOM INSTALL or similar if it asks and when presented with a list of things to install make sure all audio related items are checked, other than that just install to default location, you should now have audio through HDMI after installation finished. 


?TuringMachine?

Ryzen 5 3600x - Asus Strix B450-F - Asus ROG RTX 2060S Strix AD - HyperX Predator 3200 2x8 GB DDR4 - Phanteks P400S - Corsair RM 650x - BeQuiet! Dark Rock 4 - Kingston A2000 NVMe 1TB SSD - 2x Samsung QVO 1TB SSD (RAID 0) - Seagate Barracuda 3TB

 

Quote

"If the genius of invention were to reveal tomorrow the secret of immortality, of eternal beauty and youth, for which all humanity is aching, the same inexorable agents which prevent a mass from changing suddenly its velocity would likewise resist the force of the new knowledge until time gradually modifies human thought."

  -Nikola Tesla, New York, May 16, 1907
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×