Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
AzrealNoctis

Losing my mind building my computer

Recommended Posts

Posted · Original PosterOP

I'm low key tearing my hair out trying to get this thing to work, I'm using a Corsair crystal 570x rgb mated to an Asus x470-f gaming motherboard with an athelon proceser for bios updating and the lights on the Mobo turn on and the gpu gets power but the power button does nothing and there is no display, tried resetting and making sure I plugged everything in

Link to post
Share on other sites

Maybe post a pic of MB showing everything?

 


If you're interested in a product please download and read the manual first.

Don't forget to tag or quote in your reply if you want me to know you've answered or have another question.

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, keskparane said:

Maybe post a pic of MB showing everything?

 

Ram was in on last attempt, just took it out minutes ago

IMG_20200221_215327.jpg

Link to post
Share on other sites

IDK but why would all the lights turn on if the power button isn't doing anything?

I'm thinking unplug all the front panel switches except the start button.


If you're interested in a product please download and read the manual first.

Don't forget to tag or quote in your reply if you want me to know you've answered or have another question.

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, keskparane said:

IDK but why would all the lights turn on if the power button isn't doing anything?

I'm thinking unplug all the front panel switches except the start button.

NANI!!??? HOW DID THAT FIX IT???

Link to post
Share on other sites
7 minutes ago, AzrealNoctis said:

NANI!!??? HOW DID THAT FIX IT???

I simply can't understand what you're saying here. It's easily taken a couple of ways.


If you're interested in a product please download and read the manual first.

Don't forget to tag or quote in your reply if you want me to know you've answered or have another question.

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, keskparane said:

I simply can't understand what you're saying here. It's easily taken a couple of ways.

Nah, I was just screaming why and how, since after trying what you suggested everything worked and I got to post, just got to figure out the CPU fan error now, thanks!!!??

Link to post
Share on other sites

NP. I suspected that you may have accidentally shorted the reset or power switch with an led or similar. Another possibility could be power or reset button on case getting stuck on. 


If you're interested in a product please download and read the manual first.

Don't forget to tag or quote in your reply if you want me to know you've answered or have another question.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×