Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SkieHacker

Weird PC Problem

Recommended Posts

Posted · Original PosterOP

Hey guys, so i having problem on my AMD Desktop. well when i turn on my PC, it boot up, then a minute later, the display just went No SIgnal & both of my Mouse & Keyboard ( of course they are RGB ) they went off either, but the CPU still running. i tried to move mouse or press any key on keyboard, still no respond & when i forced to reboot, it won't display.

 

CPU & GPU: AMD A8-7650k APU ( i used Integrated GPU )

RAM: Unknown 4Gb 1600Mhz

SSD: Samsong EVO 260Gb & Seagate HDD 1Tb

PSU: Power Choice 580W PSU

 

Link to post
Share on other sites

maybe its overheating? just my initial thought.


Im with the mentaility of "IF IM NOT SURE IF ITS ENOUGH COOLING, GO OVERKILL"

 

PS: i cooled a Ryzen 5 3600(65W) with ID cooling SE207 (200W-250W tdp lol)

Link to post
Share on other sites
Posted · Original PosterOP
19 minutes ago, Martin2132 said:

maybe its overheating? just my initial thought.

Well if its overheat, why my CPU still running?

Link to post
Share on other sites

cause that symptom ever only happens to me when the graphics driver crashes.


Im with the mentaility of "IF IM NOT SURE IF ITS ENOUGH COOLING, GO OVERKILL"

 

PS: i cooled a Ryzen 5 3600(65W) with ID cooling SE207 (200W-250W tdp lol)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×