Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Vsync, monitor refresh rate and FPS

JBIZZL3Y
 Share

Go to solution Solved by corrado33,
9 minutes ago, Jurrunio said:

check your monitor's refresh rate settings first, maybe you've left it at 49Hz for some reason

If this doesn't work, just go into your Nvidia display panel (assuming nvidia card) and "Manage 3d settings" and turn vsync on there, but keep it off in game. I've had good luck with this and sometimes it seems to work better than the in game vsync. 

I’m somewhat confused as to what’s happening to my Frame rate in game when I apply vsync.. 

 

when enabled, the games graphics menu states that with vsync on, the FPS will be capped to my monitors refresh rate. (Which is 59hz)

 

However no matter what graphical setting I select the game caps out at 49 FPS with vsync enabled. It is smooth though..

 

With it disabled it runs at around 60-70 frames but the tearing is pretty bad.. 

 

there is is an option in the in-game graphics menu to cap the frame rate to a custom number, so I’ve set that to 60 but it still isn’t very smooth..

 

just wondereding what is happening and why vsync seems to cap my frame rate lower than that of my monitor.. I guess 49 FPS is so bad but it’d be nice to figure out why it does this?

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

check your monitor's refresh rate settings first, maybe you've left it at 49Hz for some reason

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, Jurrunio said:

check your monitor's refresh rate settings first, maybe you've left it at 49Hz for some reason

If this doesn't work, just go into your Nvidia display panel (assuming nvidia card) and "Manage 3d settings" and turn vsync on there, but keep it off in game. I've had good luck with this and sometimes it seems to work better than the in game vsync. 

Link to comment
Share on other sites

Link to post
Share on other sites

You think that it's around 60-70, but even small FPS drops under 60 makes you refresh rate constant lower than 60.

I agree with @corrado33 - I prefer to set vsync in nvidia control panel too and disable it in game. It can help sometimes. But also try to lowering your ingame settings a little.

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks for the advice, i've checked the monitor settings and it is set to 60hz. i'll try setting vsync in the control panel as i didn't realise you could do that.

Link to comment
Share on other sites

Link to post
Share on other sites

37 minutes ago, corrado33 said:

If this doesn't work, just go into your Nvidia display panel (assuming nvidia card) and "Manage 3d settings" and turn vsync on there, but keep it off in game. I've had good luck with this and sometimes it seems to work better than the in game vsync. 

Thanks for this, seems to have fixed the issue.. although the in-game menu is definitely playing up, it offers me 2 refresh rates in game: 49 or 59 and even if i select 59 and apply when I re-open the menu it has changed back to 49. 

 

also with in-game vsync turned off I still have some tearing happening at 55-60fps. (this is whilst having global vsync on in the control panel)

 

however if I then also apply the in-game vsync the fps now stays at 60 and is tear free.

 

Whatever works lol

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×