Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Metro 2033 FREE for the next 24 hours ONLY!

Paul Rudd
 Share

thanks man

i7-8700k @ 4.8Ghz | EVGA CLC 280mm | Aorus Z370 Gaming 5 | 16GB G-Skill DDR4-3000 C15 | EVGA RTX 2080 | Corsair RM650x | NZXT S340 Elite | Zowie XL2730 

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks, add this the list of games I own but have never played/finished 

Laptop: 2019 16" MacBook Pro i7, 512GB, 5300M 4GB, 16GB DDR4 | Phone: iPhone 13 Pro Max 128GB | Wearables: Apple Watch SE | CPU: R5 2600 | Mobo: ASRock B450M Pro4 | RAM: 16GB 2666 | GPU: ASRock RX 5700 8GB | Case: Apple PowerMac G5 | OS: Win 10 | Storage: 480GB PNY SSD & 2TB WD Green HDD | PSU: Corsair CX600M | Display: Dell 27 Gaming Monitor S2719DGF 1440p @155Hz, Dell UZ2215H 21.5" 1080p, ViewSonic VX2450wm-LED 23.6" 1080p | Cooling: Wraith Prism | Keyboard: G610 Orion Cherry MX Brown | Mouse: G303 | Audio: Audio Technica ATH-M50X & Blue Snowball
Link to comment
Share on other sites

Link to post
Share on other sites

Got it for free back when 4A was giving out cd-keys on Facebook, back in 2012 or so.  Not a bad game for those that enjoy single player story driven corridor shooters.

Link to comment
Share on other sites

Link to post
Share on other sites

To those that read this, there's definitely a stuttering issue with the game when you first start it up. I thought it was a Direct X issue at first since you can choose between 9, 10 or 11. But that's not it. I basically went into the Nvidia Control panel and turned v-sync OFF. Then I capped my frames at 60 with MSI AB. Fixed the stuttering right up.

 

There's still a little stuttering in the game due to the game itself(probably the game engine). But the major stuttering is fixed by what I mentioned above. If you want to get more fps than 60, I would think you can cap your fps to whatever you think your GPU can achieve. I just started out with 60. I'm gonna try 90 next and see how much usage and power my GPU pushes. If it's in the high 90's percentage wise, I might lower some individual graphic settings in the configuration files to see if that helps. If not, I'll just then try capping the fps at 75 or so. 60 works just fine if you want to not push your GPU to its max for now.

 

Btw, I'm playing in 1440p on a 144 Hz monitor with a 1070 if anyone is wondering. If you're playing in 1080p with an equal or better GPU, consider starting out capping your frames at least at 90. Then try 120, and so on. Hope this helps who is new to the game like me. If anyone reading this has been playing this game for a while, I'm all ears to any more pointers to what you did to run the game smoothly.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×