Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Horizon 4 will not stop crashing

jnic
 Share

I can not go 2 mins into a game with out crashing

I have tried setting all everything to very low, cant even run benchmark mode with out it crashing on the loading screen

horizon 3 / horizon 4 demo ran perfectly fine with an occasional crash

 

Specs

2 xeon E5620's (4 core, 8 thread)

Gigabyte GTX 1050Ti, 4gb vram

10gb ddr3 ram

mechanical hard drive

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Dan Castellaneta said:

Have you reinstalled drivers?

gigabyte has really outdated drives for my card, so i just installed Nividia's latest driver for the 1050Ti

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, jnic said:

gigabyte has really outdated drives for my card, so i just installed Nividia's latest driver for the 1050Ti

Did you uninstall with DDU prior to installing the new one?

Quote or tag me( @Crunchy Dragon) if you want me to see your reply

If my post solved your problem/answered your question, please consider marking it as "solved"

Community Standards // PSU Tier List // Bugs and Issues // Join Floatplane! // Join the LTT Official Discord //

Link to comment
Share on other sites

Link to post
Share on other sites

FH4 probably doesn't like the two CPU's...

PC - i7 9700K @5 Ghz | MSI 3070Ti Gaming X Trio | NZXT Kraken x53 | ASUS ROG Strix Z390-E | 32GB TridentZ RGB | NZXT H510 Elite & EVGA 750W

-

If my post solved your problem/answered your question, please consider marking it as "solved"

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Crunchy Dragon said:

Did you uninstall with DDU prior to installing the new one?

no

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Optane^ said:

FH4 probably doesn't like the two CPU's...

i thought that, but the demo ran fine and so did 3.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, jnic said:

no

Download and run DDU(you'll have to boot into Safe Mode for this). Then reinstall the driver.

Quote or tag me( @Crunchy Dragon) if you want me to see your reply

If my post solved your problem/answered your question, please consider marking it as "solved"

Community Standards // PSU Tier List // Bugs and Issues // Join Floatplane! // Join the LTT Official Discord //

Link to comment
Share on other sites

Link to post
Share on other sites

24 minutes ago, Crunchy Dragon said:

Download and run DDU(you'll have to boot into Safe Mode for this). Then reinstall the driver.

ok do you think i should use the latest for my card or the latest Nividia one 

Link to comment
Share on other sites

Link to post
Share on other sites

15 hours ago, jnic said:

ok do you think i should use the latest for my card or the latest Nividia one 

Nvidia's.

Quote or tag me( @Crunchy Dragon) if you want me to see your reply

If my post solved your problem/answered your question, please consider marking it as "solved"

Community Standards // PSU Tier List // Bugs and Issues // Join Floatplane! // Join the LTT Official Discord //

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×