Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Sound card

Igy89
 Share

Hi guys need some help....i want to get Logitech Z906 5.1 speaker system..do i need to get better sound card or on my motherboard is good? I have evga classified 4 way sli z170! Thank you! 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, Igy89 said:

Hi guys need some help....i want to get Logitech Z906 5.1 speaker system..do i need to get better sound card or on my motherboard is good? I have evga classified 4 way sli z170! Thank you! 

 

You don't need a better sound card to drive those speakers.

AMD R7 2700 | 2x8 3000Mhz Corsair LPX | B450M Mortar  | GTX 1070 6GB | Noctua DH-N14 | Corsair MP50 480GB | BitFenix Phenom M | Corsair AX760 | Khadas Soundboard + JDS Labs Atom | Debian 10 SID

 

Thanks let me know if I said something useful. Cheers!

Link to comment
Share on other sites

Link to post
Share on other sites

Most humanoid creatures won't really hear a difference between onboard audio and a dedicated soundcard anymore for quite some time, IF there is no faulty "wiring". So just use your onboard sound. 

2 Main Systems (mine and my late wifes):

System 1 "Igluna" AsRock Fatal1ty Z77 Pro, Core I5 3570k @4300, 16 GB Ram DDR3 2133, some SSD, and a 2 TB HDD each, Gainward Phantom 760GTX.

System 2 "Inskah" AsRock Fatal1ty Z77 Pro, Core I5 3570k @4300, 16 GB Ram DDR3 2133, some SSD, and a 2 TB HDD each, Gainward Phantom 760GTX.

 

New System in the making "Anghammarad" AsRock Taichi x570, AMD Ryzen 5800X, 32 GB Ram DDR4 3600, some SSD, Gainward Phoenix GS 1060.

 

On the Road: Acer Aspire 5 Model A515-51G-54FD, Intel Core i5 7200U, 8 GB DDR4 Ram, 120 GB SSD, 1 TB HDD, Intel CPU GFX and Nvidia MX 150, Full HD IPS display

 

Media System: Asrock ASRock Z87 Extreme4/TB4, Intel Core i5 4460, 16 GB Ram DDR3 1600 ADATA XPG, 1 275 GB SSD, 4 Seagate Ironwolf 4TB HDD in raid 5, Gainward Phantom 560 GTX (the 560 will be replaced with one of the 760 due to better effeciency)

 

(Abit Fatal1ty FP9 IN SLI, C2Duo E8400, 6 GB Ram DDR2 800, far too less diskspace, Gainward Phantom 560 GTX broken need fixing)

 

Nostalgia: Amiga 1200, Tower Build, CPU/FPU/MMU 68EC020, 68030, 68882 @50 Mhz, 10 MByte ram (2 MB Chip, 8 MB Fast), Fast SCSI II, 2 CDRoms, 2 1 GB SCSI II IBM Harddrives, 512 MB Quantum Lightning HDD, self soldered Sync changer to attach VGA displays, WLAN

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×