Jump to content

Aorus B450 PRO rev 1 bios update

Go to solution Solved by FCS010101,

UPDATE for anyone who whill has this question

I istalled them in the following order:


1. AMD Chipset Driver (F30 note)
2. F32

3. EC FW Update Tool (F40 Note)
4. F40

5. F50

6. F60

7. F63a

8. F63d

Everything works fine.
Thanks everyone fot the assistance.

Hi, i want to update my bios to the newest version because i want to update my cpu from a 2600 to a 5800x3d
My current bios version is F2 and i want to update to F63d
Is it possible to update it in one go or do i need to do incremental updates?
Will the F63d version still support my 2600?
https://www.gigabyte.com/Motherboard/B450-AORUS-PRO-rev-10/support#support-dl-bios

Thanks

Link to comment
Share on other sites

Link to post
Share on other sites

Updating it in one go should be fine, and yes, the upgraded bios will still support your old cpu.

Link to comment
Share on other sites

Link to post
Share on other sites

i'm not 100% sure if you have to or not, but you should do version f32 before going to the latest, just to avoid possible issues.

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, JimTheBeet said:

Updating it in one go should be fine, and yes, the upgraded bios will still support your old cpu.

did you read the notes under the various bios revisions in the link he provided?

 

25 minutes ago, FCS010101 said:

Will the F63d version still support my 2600?

yes, it should still work

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, bmx6454 said:

did you read the notes under the various bios revisions in the link he provided?

 

yes, that is why i'm asking
it is not specified that you need a previous version for F60 and higher, only for F40, F50 and this is what got me really unsure

Link to comment
Share on other sites

Link to post
Share on other sites

11 minutes ago, bmx6454 said:

did you read the notes under the various bios revisions in the link he provided?

 

yes, it should still work

I did, but it looks like that was an issue with versions f40-f50, and not later versions. You're probably right that it's better to be on the safe side, though.

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, FCS010101 said:

yes, that is why i'm asking
it is not specified that you need a previous version for F60 and higher, only for F40, F50 and this is what got me really unsure

just do version f32 first, then you don't have to worry.

Link to comment
Share on other sites

Link to post
Share on other sites

  • 2 weeks later...

UPDATE for anyone who whill has this question

I istalled them in the following order:


1. AMD Chipset Driver (F30 note)
2. F32

3. EC FW Update Tool (F40 Note)
4. F40

5. F50

6. F60

7. F63a

8. F63d

Everything works fine.
Thanks everyone fot the assistance.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×