Jump to content

Ram slot damage

Yo I know it’s stupid but when I took my old ram out I only unclipped one side of the latches as on my old board it only undid on one side, pc is running fine with new ram in but is there any chance I have damaged the slot ? I assume it just wouldn’t boot if I broke the slot ? 
didn’t realise Msi boards unclipped both sides 

-13600kf 1.15v stock clocks

- z790 tomahawk

- 3600 dual rank 14-14-14-28

-2080ti ftw3

- Samsung oddesy g7 1440p 240hz 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Ebony Falcon said:

Yo I know it’s stupid but when I took my old ram out I only unclipped one side of the latches as on my old board it only undid on one side, pc is running fine with new ram in but is there any chance I have damaged the slot ? I assume it just wouldn’t boot if I broke the slot ? 
didn’t realise Msi boards unclipped both sides 

Just make sure all of your memory is detected.

 

If it is, then consider yourself lucky and move on. ;3

"Don't fall down the hole!" ~James, 2022

 

"If you have a monitor, look at that monitor with your eyeballs." ~ Jake, 2022

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Sarra said:

Just make sure all of your memory is detected.

 

If it is, then consider yourself lucky and move on. ;3

Yeah it’s all detected and working 

 

-13600kf 1.15v stock clocks

- z790 tomahawk

- 3600 dual rank 14-14-14-28

-2080ti ftw3

- Samsung oddesy g7 1440p 240hz 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×