Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Fractal Torrent RGB Strip Issues

I'm having an issue with the RGB strip on my Fractal Torrent RGB. I reached out to Fractal but was trying to troubleshoot in the meantime. For some reason it is flickering with different colors, especially when it is set to a single color. Ex: when it is set to red it flashes blue and red like a cop car. I checked all my connections and they seem good to go and the strip is chained together with all the Fractal RGB case fans and all the case fans are doing fine. Thoughts?

Link to comment
Share on other sites

Link to post
Share on other sites

31 minutes ago, WoodsytheOwl221 said:

I'm having an issue with the RGB strip on my Fractal Torrent RGB. I reached out to Fractal but was trying to troubleshoot in the meantime. For some reason it is flickering with different colors, especially when it is set to a single color. Ex: when it is set to red it flashes blue and red like a cop car. I checked all my connections and they seem good to go and the strip is chained together with all the Fractal RGB case fans and all the case fans are doing fine. Thoughts?

If it’s not systemic and other parts are acting normally it sounds like a hardware issue.  If it’s the only thing hooked up to a given connector it could be the connector.  Doesn’t sound like it.  I might be r wrong about that. Is this the only strip in that chain? This is like one of those things where only one fan in a chain of three isn’t working right. 90+% chance it’s the fan in that case.

Life is like a bowl of chocolates: there are all these little crinkly paper cups everywhere.

Link to comment
Share on other sites

Link to post
Share on other sites

On 12/2/2021 at 1:12 PM, WoodsytheOwl221 said:

I'm having an issue with the RGB strip on my Fractal Torrent RGB. I reached out to Fractal but was trying to troubleshoot in the meantime. For some reason it is flickering with different colors, especially when it is set to a single color. Ex: when it is set to red it flashes blue and red like a cop car. I checked all my connections and they seem good to go and the strip is chained together with all the Fractal RGB case fans and all the case fans are doing fine. Thoughts?

i would hook up just the strip and change the color to a solid red, green, blue. see if something not right.

Link to comment
Share on other sites

Link to post
Share on other sites

On 12/2/2021 at 4:43 PM, Bombastinator said:

If it’s not systemic and other parts are acting normally it sounds like a hardware issue.  If it’s the only thing hooked up to a given connector it could be the connector.  Doesn’t sound like it.  I might be r wrong about that. Is this the only strip in that chain? This is like one of those things where only one fan in a chain of three isn’t working right. 90+% chance it’s the fan in that case.

Nope, definitely not the only thing in the chain. About 5 other fans are hooked up. Spoke to Fractal and they are already sending me a new strip, so lets hope that's all it it and not a header issue.

Link to comment
Share on other sites

Link to post
Share on other sites

On 12/3/2021 at 11:09 PM, thrasher_565 said:

i would hook up just the strip and change the color to a solid red, green, blue. see if something not right.

Good call, I have a replacement coming from Fractal so at least it will be fixed if that's the issue. Although since all the fans also hooked up to that header are fine I think it's just an issue with the strip.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×