Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Do I have a problem with my old laptop?

So. I missed playing online games again and I saw that Albion had a new update. I found my old laptop, cleaned it but when I started playing, the game is stuttering even though I have more than the required spec to play the game. Do I have a problem?

16236693912796875646862816345506.jpg

Link to post
Share on other sites

Well clearly your gpu is maxing out so you are hitching there.

 

You should also check per core usage of the cpu as this is a grand strategy game so to say and those often have a single core limit.

 

At worst you have to turn the settings down if possible. Can also be that over time the game simply got heavier but since it is a top down kinda game that isn't split second reaction the devs consider your specs plenty as it simply launches.

 

Sidenote it is running pretty hot have you cleaned the heatsinks from dust by opening up the laptop?

Link to post
Share on other sites
Just now, jaslion said:

Well clearly your gpu is maxing out so you are hitching there.

Its completly normal for the GPU to be on 100%, it doesn't mean that is the problem.

 

More likely is as you also mentioned the per core usage for the CPU, if one core are maxing out that will likely cause stuttering as its not able to deliver frames to the gpu in a timely manner.

 

Link to post
Share on other sites
Just now, Tegneren said:

Its completly normal for the GPU to be on 100%, it doesn't mean that is the problem.

 

More likely is as you also mentioned the per core usage for the CPU, if one core are maxing out that will likely cause stuttering as its not able to deliver frames to the gpu in a timely manner.

 

I meant hitching as limited there. Should have used clearer words.

Link to post
Share on other sites
48 minutes ago, jaslion said:

Well clearly your gpu is maxing out so you are hitching there.

 

You should also check per core usage of the cpu as this is a grand strategy game so to say and those often have a single core limit.

 

At worst you have to turn the settings down if possible. Can also be that over time the game simply got heavier but since it is a top down kinda game that isn't split second reaction the devs consider your specs plenty as it simply launches.

 

Sidenote it is running pretty hot have you cleaned the heatsinks from dust by opening up the laptop?

Thanks! I found a flat spider egg under the fan.I don't know if I want to use it now though....

Link to post
Share on other sites
7 minutes ago, New ask said:

Thanks! I found a flat spider egg under the fan.I don't know if I want to use it now though....

Clean it out with some compressed air and a harsher paint brush.

Link to post
Share on other sites

* your thread was moved to the Troubleshooting section, please always post in the appropriate section *

If you need help with your forum account, please use the Forum Support form !

 

VPN server guide

Introduction to Mechanical Keyboard

Spoiler

My Gaming Rig - Motherboard: MSI Z370-A PRO CPU: i7-8700 RAM: 32GB DDR4 2400(4x8GB) GPU: Gigabyte GTX 1060 3GB OS SSD: 512GB SU800 SSD Storage: 2x 1TB Seagate PSU: Seasonic G650 OS: Windows 10 Pro 64bits Monitor: Acer 21in G205H + Lenovo 21in

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×