Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Keyboard lights up but does not type

Hi. I just got this old computer, it wasn't working, (i posted in a previous thread) and i got it fixed, and now i have encountered a new problem. I have a usb gaming keyboard and a ps2 mouse, i tried to connect it and it light up, but when i attempted to type, it didn't do anything. i plugged in my phone charger to see if the ports were working, all of them work. I plugged the keyboard into my laptop and it works, so the keyboard is not the problem.

Link to post
Share on other sites

I'm assuming you have the keyboard pluged into a USB port where the PS2 port for the mouse is.

Try plugging it into a regular USB port, those being normally under or around the LAN port and see if anything changes.
 

Link to post
Share on other sites

Hmmmm.....
Make sure you're not plugging it into anything but a standard USB, not one that's blue or red.

Link to post
Share on other sites

I tried to plug in this keyboard into my laptop and it worked. And i tried plugging in a old usb keyboard which i used before i bought this one. It still dosent work in this pc but it works in my laptop, so i think it is a problem on this pc

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×