Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Wireless Repeater Setup

Hello folks,

 

Recently changed out my router, I used to use a Netgear WNR1000 v3, which seemed to die every time I connect 2-3 devices over wifi. I switched to using a MikroTik hAP ac2, seems to have taken care of the issue.

However, my living room TV is a bit far away from the router and is not getting good signal. I could go ahead and fix that by running a cable, but I was thinking there could be a more elegant solution.

 

So since I have the Netgear, I decided to try connecting it as a repeater to the MikroTik. Problem is, my knowledge on the subject is pretty much none, so I've resorted to reading guides and such. I have tried doing the following on the Netgear side: 

I tried same and different subnet, as well as using the MAC for both the 2GHz and 5GHz, but no success. I think I am missing something I need to configure on the MikroTik side, but I'm failing to find out what.

 

TL;DR - Trying to connect a Netgear WNR1000 v3 as a repeater for a MikroTik hAP ac2.

Link to post
Share on other sites

I'm trying to avoid running a cable between the two

Link to post
Share on other sites
25 minutes ago, JustTsuki said:

I'm trying to avoid running a cable between the two

First of all, for an old wireless router, running in AP is something your WNR1000 supports under stock firmware. While running it as an AP requires an ethernet uplink, it's more likely to give you the best overall performance compared to a repeater. A repeater needs a good signal to repeat in the first place, so mounting a repeater where the signal is poor (from walls, floors, distance) is going to result in poor wireless coverage. Not to mention, repeaters work in half-duplex mode which means that the overall wireless throughput will be cut in half due the unit having to not only negotiate communication between itself and a wireless client, but also between itself and the primary wireless router. The latter point is going to affect overall performance significantly given that the WNR1000 is a single band device from the WiFi 4 era. So keep this in mind if you absolutely cannot run ethernet.

 

Reading around online reveals there might be an option under ADVANCED > Advanced Setup > Wireless Repeating. If this feature is available, you might need to turn off your wireless security (i.e. WEP/WPA/WPA2) altogether to get the repeater link to work properly. Having an open wireless network is not something I would recommend as it poses a significant security threat to your networked devices.

 

There's always the possibility of using 3rd party firmware to "unlock" extra features. You can check if DD-WRT or Tomato supports the WNR1000. If you go this route, beware of bricking your router and not being covered under warranty, although it is likely to be out of warranty at this point.

Link to post
Share on other sites

The problem with the signal strength seems to originate from the TV experiencing connection issues. I've tried a few laptops I've got laying around and the connection is just fine, so it's probably the TV antenna that isn't as good.

 

I tried the Wireless Repeating option on the Netgear, but I got it to work when the two routers are linked up via ethernet. I think I am missing something on the MikroTik side to make them communicate wirelessly.

 

I was able to keep the wireless security turned on when using the Wireless Repeating, even got it to inherit the security configuration from the wireless on the MikroTik, but again only when the two are cabled up.

 

Since wifi is good in the room and it's just the TV that is giving me problems, I think I'll just run a cable to the TV and call it a day. Still it was a fun learning experience and I'm thankful for the help.

Link to post
Share on other sites
21 minutes ago, JustTsuki said:

Since wifi is good in the room and it's just the TV that is giving me problems, I think I'll just run a cable to the TV and call it a day. Still it was a fun learning experience and I'm thankful for the help.

Honestly a cable is always the more elegant solution purely and simply because you never have to worry about it again.  Short of the cable being damaged, it will work forever regardless of what may change when it comes to WiFi interference.

Router: i5-7200U appliance running pfSense WiFi: Honor Router 3 (~850Mbit peak throughput)
ISPs: Zen Unlimited Fibre 2 (66Mbit) + Plusnet Unlimited Fibre Extra. (56Mbit) + Voxi LTE (~120Mbit)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×