Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Ryzen 5900x stuck at 4.2 GHz

Hello there, 

 

I just recently upgraded to a Ryzen 5900x and a x570 board. Without any change to the BIOS, the CPU ran at 4.2 GHz. However, no matter what I did after, the top clock speed was always stuck at 4.2 GHz.

I tried PSO and Ryzen master and absolutely nothing happens. 

 

My spec:

5900x

EVGA 1080 FTW

Asus TUF x570 plus with the most recent BIOS

4 x 6gb 3200Mhz TridentZ

H80i (the temp peaked around 60 at 100% load at 4.2Ghz)

 

 

Link to post
Share on other sites

Hello, I have a few questions?

A. What is your Power Supply

B. Have you installed the Ryzen Balanced Power plan, if not https://www.amd.com/en/support/kb/faq/chipset-install

C. The H80i really is not up to the task of running a 5900x a crazy high clock speeds, Ryzen's frequency scales with temperature right out of the box like a GPU does. So a cooler CPU will naturally clock higher, and that H80i is likely having some water permeation considering its age (unless it is the V2 version and new). 60 is pretty low temps on Ryzen and it should clocking higher. 

D. Try enabling Precision Boot Overdrive, then run a benchmark like cinebench 10 times and record the temperature once the AIO has reached heat saturation. PBO will auto overclock the CPU, so it may clock up higher, and definitely hotter, other than that maybe you just lost the silicon lottery.

Link to post
Share on other sites
4 minutes ago, IAMABOSS said:

Hello, I have a few questions?

A. What is your Power Supply

B. Have you installed the Ryzen Balanced Power plan, if not https://www.amd.com/en/support/kb/faq/chipset-install

C. The H80i really is not up to the task of running a 5900x a crazy high clock speeds, Ryzen's frequency scales with temperature right out of the box like a GPU does. So a cooler CPU will naturally clock higher, and that H80i is likely having some water permeation considering its age (unless it is the V2 version and new). 60 is pretty low temps on Ryzen and it should clocking higher. 

D. Try enabling Precision Boot Overdrive, then run a benchmark like cinebench 10 times and record the temperature once the AIO has reached heat saturation. PBO will auto overclock the CPU, so it may clock up higher, and definitely hotter, other than that maybe you just lost the silicon lottery.

A. its a Seasonic Gold GX850

B. It is

C. I know that H80i really isn't optimal for a 5900x, however its maxing out at around 60 so I think it should be able to go higher

D. PSO is already enabled

Link to post
Share on other sites
Just now, TwistedTale said:

A. its a Seasonic Gold GX850

B. Probably not

C. I know that H80i really isn't optimal for a 5900x, however its maxing out at around 60 so I think it should be able to go higher

D. PSO is already enabled

Ok go install Ryzen Balanced Power Plan ASAP, that is probably your problem. Ryzen on windows needs certain optimizations from the power plan otherwise the CPU will be limited in performance. Other than that I have no idea what could be causing this issue. 

Link to post
Share on other sites
4 minutes ago, IAMABOSS said:

Ok go install Ryzen Balanced Power Plan ASAP, that is probably your problem. Ryzen on windows needs certain optimizations from the power plan otherwise the CPU will be limited in performance. Other than that I have no idea what could be causing this issue. 

I just made sure that its in fact installed, I already ran a bunch of cinebench for long period before and the temp tops around 60ish when the clock speed at 4.2. Also, is it normal the hardwareinfo report 1600mhz ram when windows shows 3200mhz (I have it set to 3200 in the BIOS)image.thumb.png.87479465b27db686e938f124b32b6f34.png

Link to post
Share on other sites

I also realized that under load the CPU is only at 1.087V and seem to be capped, is there any setting in BIOS that govern this

 

Link to post
Share on other sites
11 minutes ago, TwistedTale said:

I just made sure that its in fact installed, I already ran a bunch of cinebench for long period before and the temp tops around 60ish when the clock speed at 4.2. Also, is it normal the hardwareinfo report 1600mhz ram when windows shows 3200mhz (I have it set to 3200 in the BIOS)

DDR(4) is Double Data Rate, so 1600 X2 = 3200, so yes your ram is fine. I really do not know what could be causing this, try increasing the power limits in Ryzen master. You can increase the voltage in Ryzen master under auto OC or Manual OC modes. Also increase the Numbers at the top. (PPT, TDC, EDC) There are lots of guides on how to do this on Youtube/Google.

This is what Ryzen Balanced Power plan looks like just for reference, under additional power settings. The slider on Power & Sleep should be maxed to performance. 

image.thumb.png.81ac21ff6b4c50c892977c8f7b8cddae.png

I am starting to think that this issues I something else and beyond my realm of knowledge. 

Link to post
Share on other sites
10 minutes ago, IAMABOSS said:

DDR(4) is Double Data Rate, so 1600 X2 = 3200, so yes your ram is fine. I really do not know what could be causing this, try increasing the power limits in Ryzen master. You can increase the voltage in Ryzen master under auto OC or Manual OC modes. Also increase the Numbers at the top. (PPT, TDC, EDC) There are lots of guides on how to do this on Youtube/Google.

This is what Ryzen Balanced Power plan looks like just for reference, under additional power settings. The slider on Power & Sleep should be maxed to performance. 

image.thumb.png.81ac21ff6b4c50c892977c8f7b8cddae.png

I am starting to think that this issues I something else and beyond my realm of knowledge. 

I did install the chipset but I don't see the AMD Ryzen Balanced option in my Power Options

Link to post
Share on other sites
10 minutes ago, TwistedTale said:

I did install the chipset but I don't see the AMD Ryzen Balanced option in my Power Options

Ryzen Power Plant is a thing of the Past. not needed with Windows Updates. I think it can'T even be activated for 5000 Series

4.2 is not bad (not best) on all cores. You will not get high clock speeds on mulitcore. It start araound 4,6 and then will clock down pretty fast to 4,3-4,4. Also 1.2V is normal on all Core boost. You may drop to 4.2 fast with that small cooler (edit: which is a bit low)

 

What are you clock speeds on single core benches, or while just using your PC. You should have spikes up to 4,95

 

 

 

grafik.png

Link to post
Share on other sites
6 minutes ago, toni2 said:

Ryzen Power Plant is a thing of the Past. not needed with Windows Updates. I think it can'T even be activated for 5000 Series

4.2 is not bad (not best) on all cores. You will not get high clock speeds on mulitcore. It start araound 4,6 and then will clock down pretty fast to 4,3-4,4. Also 1.2V is normal on all Core boost. You may drop to 4.2 fast with that small cooler (edit: which is a bit low)

 

What are you clock speeds on single core benches, or while just using your PC. You should have spikes up to 4,95

 

 

 

grafik.png

mine is always maxing at 4.2 no matter how hard the load, also the voltage is worrying low image.thumb.png.f73ee7ca8b51b44b51337e3489909d1f.png

Link to post
Share on other sites
1 minute ago, TwistedTale said:

mine is always maxing at 4.2 no matter how hard the load, also the voltage is worrying low image.thumb.png.f73ee7ca8b51b44b51337e3489909d1f.png

Not always. During all-core test...

Link to post
Share on other sites
1 minute ago, TwistedTale said:

mine is always maxing at 4.2 no matter how hard the load, also the voltage is worrying low image.thumb.png.f73ee7ca8b51b44b51337e3489909d1f.png

are you sure you didn't load some overclock stuff?

 

i'm pretty sure there is some fucked up setting in Bios which sets a fixed 4,2 clock. Cinebench should look like this:

grafik.png.2339fc622802a633b1ac81ecdf3b7c98.png

 

The CPU is clocked at 3.7. PB and PBO will take care of single/multicore clocking

Link to post
Share on other sites
2 minutes ago, Jeppes said:

Not always. During all-core test...

image.thumb.png.b689f8fb6840e5579fb924c9d5801920.png

 

 

Link to post
Share on other sites
2 minutes ago, toni2 said:

are you sure you didn't load some overclock stuff?

 

i'm pretty sure there is some fucked up setting in Bios which sets a fixed 4,2 clock. Cinebench should look like this:

grafik.png.2339fc622802a633b1ac81ecdf3b7c98.png

 

The CPU is clocked at 3.7. PB and PBO will take care of single/multicore clocking

That's what I m thinking too, the fact its fixed should mean that it's manually set. However, I didn't change anything of sort and I don't know which BIOS setting govern that

Link to post
Share on other sites
4 minutes ago, TwistedTale said:

That's what I m thinking too, the fact its fixed should mean that it's manually set. However, I didn't change anything of sort and I don't know which BIOS setting govern that

IT could be that or i can think of 2 software problems (AI Suite has some stupid stuff, and Ryzen master)

 

If load "auto optimal" on the Asus Bios and then just activate XMP (DOCP) , set everything on auto. Set PB and PBO on Auto. It should all work. (except if Ryzen master or AI Suite is doing some stupid shit)

 

to be clear: with auto optimal i don't mean any automatic overcloocking via the tweek stuff of the bios. Just let bios load it's default optimal stuff and ONLY change memory to docp, and if you want set PB and PBO on auto

Link to post
Share on other sites
Just now, toni2 said:

IT could be that or i can think of 2 software problems (AI Suite has some stupid stuff, and Ryzen master)

 

If load "auto optimal" on the Asus Bios and then just activate XMP (DOCP) , set everything on auto. Set PB and PBO on Auto. It should all work. (except if Ryzen master or AI Suite is doing some stupid shit)

I dont have Ai Suite or Ryzen master installed 

Link to post
Share on other sites

Thx you all a lot for helping, I found the sneaky culprit of the problem.

I resetted the BIOS and the base speed is back to the rated 3.7 GHz and was all cores at 4 GHz ish under load.

After that, I did an reset, and activated PBO, the auto optimal, XMP and all the regular stuff and it back to being stuck at 4.2. In the end it was the Auto Optimal setting in the Asus BIOS that automatically set a fixed clock speed. After doing another reset and activating everything except Auto Optimal, its working better than I could ever ask for

image.thumb.png.20308ee49d0efa3a8a1a4c6c7d78681e.png

Link to post
Share on other sites
15 minutes ago, TwistedTale said:

I dont have Ai Suite or Ryzen master installed 

Ok, my suggestion is to install Ryzen Master https://www.amd.com/en/technologies/ryzen-master

Clear your CMOS, this will reset the BIOS to factory settings https://www.asus.com/us/support/FAQ/1040820/ (It will still use the latest bios, just change the settings back to stock)

Once both of those are done, enter the BIOS and enable XMP then open Ryzen Master and enable Precision Boost Overdrive. (Test your clock speed first maybe, clearing the CMOS should fix the issue)

image.thumb.png.90f6d62ec30626294b245b3e41bf5400.png

Make sure that PBO is Green and hit apply. If you do not have Ryzen Master installed, then you do not have PBO on. 

Link to post
Share on other sites
5 minutes ago, TwistedTale said:

Thx you all a lot for helping, I found the sneaky culprit of the problem.

I resetted the BIOS and the base speed is back to the rated 3.7 GHz and was all cores at 4 GHz ish under load.

After that, I did an reset, and activated PBO, the auto optimal, XMP and all the regular stuff and it back to being stuck at 4.2. In the end it was the Auto Optimal setting in the Asus BIOS that automatically set a fixed clock speed. After doing another reset and activating everything except Auto Optimal, its working better than I could ever ask for

 

Ah nice you fixed it! I figured it was just some dumb BIOS options being turned on. Have fun crushing everyone's CPU scores!

Link to post
Share on other sites
8 minutes ago, TwistedTale said:

Thx you all a lot for helping, I found the sneaky culprit of the problem.

I resetted the BIOS and the base speed is back to the rated 3.7 GHz and was all cores at 4 GHz ish under load.

After that, I did an reset, and activated PBO, the auto optimal, XMP and all the regular stuff and it back to being stuck at 4.2. In the end it was the Auto Optimal setting in the Asus BIOS that automatically set a fixed clock speed. After doing another reset and activating everything except Auto Optimal, its working better than I could ever ask for

image.thumb.png.20308ee49d0efa3a8a1a4c6c7d78681e.png

Glad we could help

 

2 Tips:

- Your AIO is really a bit small for that cpu

- keep on checking bios update. As soon as there is a non Beta version with AMD AM4 AGESA V2 PI 1.2.0.0 you should update --> better cpu management and PBO 2 . (can then be activated in bios. No clue bout ryzen master, I don't like it, I don't use it)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×