Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

The Witcher 3 poor performce on RTX 3090

Go to solution Solved by Plermpel,

So I tried it with the 850W PSU, no effect at all (like I thought).

The problem seems to be mostly the tripple monitor setup, when I just run FullHD I get allmost 100fps and 99% GPU Usage (even the GPU doesn't boost as high, as it does in other Games), but also have that effect a little, that when I move the camera ingame, GPU usage and FPS drops. I gues I will just wait till all my other hardware arrives and play on the other PC in 4K. I don't have too high hopes to get such issues fixed for such an old game. :(

Hello,

 

I made a console thread a few days ago about the witcher 3, since I watched my dad playing that game I while now, I wanted to play it myself again.

Optimistic as I am I downloaded a mod list from one of does beatiful YouTube Videos and packed it all into my game folder.

Started up the game and it was a great disapointment, not just that it looks much worse then those videos but also 5-10fps!!!!

So I deinstalled the game downloaded it again, and fired it up vanilla and it was a disapointment again...

The game runs about 45fps 60% GPU Usage (vanilla maxed out) but as soon as I move it dropes to about 15fps and GPU usage goes down as low as 7%.

I am running NVSurround 5760x1080, I tried to turn it off and run the game on my TV in 4k and that's ok I guess, but still the GPU is at 95% load, no boost clock (1840MHz) and barely holds the 60fps.

That's about the same performance I got on my 1080Ti. No chance to run smooth with some mods.

So I wanted to ask, is anyone else experiencing such drama with witcher 3 on a 3090?

No hardware suggestions please, everything but Witcher 3 runs fine, NV Surround seems to e a problem now, but wasn't a few years ago, but also 4k performance is bad in my opinion.

All drivers and BIOS+VBIOS is the latest, tried flashing older VBIOS on my TUF 3090, no impact. Specs bellow.

 

Ryzen 3700X (soon to be 5950X if it ever arrives...)

ASRock B550 Pro-4 (Backup MoBo)

4x8Gig Patriot Viper @3200Mhz CL16

ASUS TUF 3090OC

Link to post
Share on other sites
2 minutes ago, Plermpel said:

Hello,

 

I made a console thread a few days ago about the witcher 3, since I watched my dad playing that game I while now, I wanted to play it myself again.

Optimistic as I am I downloaded a mod list from one of does beatiful YouTube Videos and packed it all into my game folder.

Started up the game and it was a great disapointment, not just that it looks much worse then those videos but also 5-10fps!!!!

So I deinstalled the game downloaded it again, and fired it up vanilla and it was a disapointment again...

The game runs about 45fps 60% GPU Usage (vanilla maxed out) but as soon as I move it dropes to about 15fps and GPU usage goes down as low as 7%.

I am running NVSurround 5760x1080, I tried to turn it off and run the game on my TV in 4k and that's ok I guess, but still the GPU is at 95% load, no boost clock (1840MHz) and barely holds the 60fps.

That's about the same performance I got on my 1080Ti. No chance to run smooth with some mods.

So I wanted to ask, is anyone else experiencing such drama with witcher 3 on a 3090?

No hardware suggestions please, everything but Witcher 3 runs fine, NV Surround seems to e a problem now, but wasn't a few years ago, but also 4k performance is bad in my opinion.

All drivers and BIOS+VBIOS is the latest, tried flashing older VBIOS on my TUF 3090, no impact. Specs bellow.

 

Ryzen 3700X (soon to be 5950X if it ever arrives...)

ASRock B550 Pro-4 (Backup MoBo)

4x8Gig Patriot Viper @3200Mhz CL16

ASUS TUF 3090OC

PSU?

Link to post
Share on other sites

Not sure about your issues but my 3080 has no problem running modded Witcher 3 at 90+ FPS at 4K Ultra. (+A lot of graphics mods) But in my case it's combined with a 5600X.

Dislaimer: If my post is older than 5 minutes, refresh the page. Most of my posts get edited straight away. 😄

 

PSU Tier List          AMD Motherboard Tier List          SSD Tier List

 

Current Specs:

CPU: AMD Ryzen 5 5600X - Motherboard: ASUS ROG Strix B550-E - GPU: PNY RTX 3080 XLR8 Epic-X - RAM: 4x8GB (32GB) G.Skill TridentZ RGB 3600MHz CL16 - PSU: Corsair RMx (2018) 850W - Storage: 500 GB Corsair MP600 (Boot) + 2 TB Sabrent Rocket Q (Storage) - Cooling: EK, HW Labs & Alphacool custom loop - Case: Lian-Li PC O11 Dynamic - Fans: 6x Noctua NF-A12x25 - AMP/DAC: FiiO K5 Pro - OS: Windows 10 Pro - Monitor: LG 27GN950-B - TV: LG C9 OLED 55" - Speakers: Samsung HW-Q80R + optional surround speakers - Mouse: Logitech G Pro + Powerplay - Keyboard: Logitech G915, Corsair K63 Wireless + Lapboard - Headphones: Beyerdynamic Amiron Home - Microphone: Antlion ModMic

 

Temperatures @steady state: Furmark + CinebenchR23 running for 1 hour. Fans @850RPM. Pump @1600RPM.

Water: 37°C

CPU: 73°C

GPU: 54°C

Link to post
Share on other sites
5 minutes ago, Plermpel said:

No hardware suggestions please, everything but Witcher 3 runs fine

...

2 minutes ago, Downkey said:

PSU?

EVGA 650GQ, but just for your happienes, I can try to hook up a Corsair TX850

Link to post
Share on other sites
3 minutes ago, Stahlmann said:

Not sure about your issues but my 3080 has no problem running modded Witcher 3 at 90+ FPS at 4K Ultra. (+A lot of graphics mods) But in my case it's combined with a 5600X.

None of my threads is fully uilized when I am ingame, so I think it can't be a CPU bottleneck?

Link to post
Share on other sites
6 minutes ago, Plermpel said:

...

EVGA 650GQ, but just for your happienes, I can try to hook up a Corsair TX850

A mediocre unit that’s only 650watts for a 3090? Hook up that TX850. I wouldn’t be suprised if that fixed the issue

Link to post
Share on other sites
48 minutes ago, Downkey said:

A mediocre unit that’s only 650watts for a 3090? Hook up that TX850. I wouldn’t be suprised if that fixed the issue

Normally the PC shuts down if the PSU is overloaded. Seems like OP has throttling issues. I don't know if the other PSU would help, but trying won't hurt.

 

54 minutes ago, Plermpel said:

None of my threads is fully uilized when I am ingame, so I think it can't be a CPU bottleneck?

My CPU is also only sitting at 30% when playing the game. It's not about that. I've had a 3700X before and the game was also running perfectly fine with that.

Dislaimer: If my post is older than 5 minutes, refresh the page. Most of my posts get edited straight away. 😄

 

PSU Tier List          AMD Motherboard Tier List          SSD Tier List

 

Current Specs:

CPU: AMD Ryzen 5 5600X - Motherboard: ASUS ROG Strix B550-E - GPU: PNY RTX 3080 XLR8 Epic-X - RAM: 4x8GB (32GB) G.Skill TridentZ RGB 3600MHz CL16 - PSU: Corsair RMx (2018) 850W - Storage: 500 GB Corsair MP600 (Boot) + 2 TB Sabrent Rocket Q (Storage) - Cooling: EK, HW Labs & Alphacool custom loop - Case: Lian-Li PC O11 Dynamic - Fans: 6x Noctua NF-A12x25 - AMP/DAC: FiiO K5 Pro - OS: Windows 10 Pro - Monitor: LG 27GN950-B - TV: LG C9 OLED 55" - Speakers: Samsung HW-Q80R + optional surround speakers - Mouse: Logitech G Pro + Powerplay - Keyboard: Logitech G915, Corsair K63 Wireless + Lapboard - Headphones: Beyerdynamic Amiron Home - Microphone: Antlion ModMic

 

Temperatures @steady state: Furmark + CinebenchR23 running for 1 hour. Fans @850RPM. Pump @1600RPM.

Water: 37°C

CPU: 73°C

GPU: 54°C

Link to post
Share on other sites
1 hour ago, Downkey said:

A mediocre unit that’s only 650watts for a 3090? Hook up that TX850. I wouldn’t be suprised if that fixed the issue

If the PSU is bad, it wont run, it would just crash or restart at high loads.

As the OP said it only happened with the Witcher.

What you have probably a driver issue, since the card is new, expect some bugs.

Ryzen 2600x @ 4.2ghz all cores | Asrock B450M Steel Legend | Radeon RX580 | 4x Samsung 8gb d-die 2133 @ 3200mhz | 500gb Samsung PM981a | 5 TB HDD | Hyper 212 classic w/ 2 delta 4000rpm push pull | Antec Neo Eco Zen 500w

Link to post
Share on other sites

So I tried it with the 850W PSU, no effect at all (like I thought).

The problem seems to be mostly the tripple monitor setup, when I just run FullHD I get allmost 100fps and 99% GPU Usage (even the GPU doesn't boost as high, as it does in other Games), but also have that effect a little, that when I move the camera ingame, GPU usage and FPS drops. I gues I will just wait till all my other hardware arrives and play on the other PC in 4K. I don't have too high hopes to get such issues fixed for such an old game. :(

Link to post
Share on other sites

If you have added Reshade and/or ENB the files would not be deleted when uninstalling the game. 

 

So check what you installed or uninstall the game then delete the game folder then install again.

 

RIG#1 CPU: Intel i9 10900k | Motherboard: ASUS ROG Maximus XII Hero | RAM: Corsair Vengeance RGB Pro 32GB DDR4 4000 | GPU: EVGA  RTX 2080 ti FTW3 ULTRA | PSU: EVGA 1300 G2 | Case: Cooler Master H500M | Cooler: SilverStone PF360 | SSD#1: Crucial P1 1TB | SSD#2: Crucial MX500 2.5" 2TB | Monitor: LG 55" 4k B9 OLED TV


RIG#2 CPU: AMD, R 7 5800X| Motherboard: X570 AORUS Master  | RAM: Corsair Vengeance RGB Pro 32GB DDR4 3200 | GPU: EVGA RTX 2080 ti FTW3 ULTRA | PSU: EVGA 1000 GQ | Case: Cooler Master H500P Mesh White | Cooler: EVGA 360mm AIO | SSD#1: Corsair MP600 1TB | SSD#2: Crucial MX500 2.5" 2TB | Monitor: LG 55" 4k B9 OLED TV

 

RIG#3 CPU: Intel i9 9900k | Motherboard: AORUS Z390 Ultra | RAM: Ripjaws V Series 32GB DDR4 3200 | GPU: EVGA GTX 1080 ti SC | PSU: EVGA 1000 GQ | Case: Cooler Master H500 | Cooler: Noctua NH-D15 | SSD: Crucial P1 1TB | Monitor: LG 49" NanoCell 85

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×