Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Help powering a GPU from an external PSU + wrong PCI slot

Trying to get a R9 270X working in a server. I currently have 2 issues that I will deal with more permanently later, the first being that the server only has x8 slots (technically it has a x16 but I don't think Its wired for x16, instead it's 2 x8 in one connector) and the second being it does not have 2x 6 pin power for the card (or any auxiliary power for that matter) 

Just want to get my setup right before proceeding, because I think I bricked a server motherboard about 2 hours ago trying the card in a x16 slot. 

So, I should be able to dremel out the end of the x8 slot to fit x16 card, correct? 

Also, I am trying to power the GPU from a secondary power supply Using its 6 pin wires (there's a jumper on the 24 pin to turn it on). Can I leave that power supply on and then start the machine? Do I need to start the machine and then the power supply?

 

Thx

My PC: 

CPU: Intel i5-6600K @ 4.7Ghz Motherboard: EVGA Z170 FTW RAM: 2x8GB Corsair LPX GPU 1: EVGA GTX 1060 FTW GPU 2: MSI R9 270X HAWK Case: NZXT H440 Blue Storage: 120GB PNY, 1TB Hitachi Monitor: Asus VC279 Keyboard: Corsair K95 RGB (MX Brown) Mouse: Logitech G602

Guest PC: 

Spoiler

CPU: AMD FX-8320 Motherboard: Some shit Gigabyte board RAM: 2x4GB G.Skill Ares 2133Mhz GPU: EVGA GTX 570 DoubleShot Case: Idk. Some cheap case Storage: 250GB HDD Monitor: Some NEC thing Keyboard: Logitech G105 Mouse: Some Microsoft mouse

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×