Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

So I want to be able to play 4k movies on my pc and Im using CyberLink but when I tried to play a 4k movie it says it requires Intel SGX which is only possible on intel CPUs so google says. Is there any way around this?

So I can play 4k movies on my AMD 2700X cpu or do I have to upgrade to a newer Intel CPU to do so?

I hope this is not the case cause I really want to upgrade to the newest AMD CPU...

 

AMD 2700X

AMD 5700XT

X470 Aorus Gaming 5 WiFi

Corsair Vengeance LPX 32GB @ 3200

Western Digital SN750 1TB M.2

Thermaltake Toughpower Gold 750 Watt 

Link to post
Share on other sites

Yes, Intel SGX works only with Intel systems. 

 

Try an alternative player.

 

 

- If it ain't broken, don't fix it! -

- Your post codes and beep codes in the drop down below.

Spoiler

 

 

Link to post
Share on other sites

**UPDATE** I tried a few different apps which said they work with AMD but none of them would open my disc drive, only opened files. But I did reach out to AMD Support and asked, here's their response. So I'm pretty happy with AMD and can't wait for the driver support and my PC upgrade in in a month or two.

amdUHD_LI.thumb.jpg.02a709d924e49413f6847cff74048b43.jpg

Link to post
Share on other sites

As mentioned above, try a different player. CyberLink software is 💩. VLC is usually my go-to, but I have heard of it having issues with 4k Blu-Rays. You can try the K-Lite Codec Pack and Media Player Classic, which you can download together in the K-Lite Codec Mega Pack. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×