Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Stuttering in Battlefield 1 with a good pc

Vux
 Share

I get really bad stuttering with a pc which should be able to run BF1 with zero issues. You can see the settings and everything else in this video.

My specs are:

  • CPU: AMD Ryzen 5 1600x
  • RAM: Kingston Hyperx Fury 2x4 GB 2666 Mhz + Ballistix Sport LT 2x4 GB 2666 Mhz
  • Motherboard: Gigabyte GA-AB350M-DS3H
  • GPU: Asus ROG Strix RX570
  • HDD: Toshiba DT01ACA100 1 TB
  • SSD: Samsung 860 Evo 250 GB
  • PSU: Corsair CX550M
  • Windows 10 Pro 64 bit


Everything is on stock. And the game is on the SSD, which has 80 GB left, so that isn't the issue.

I have tried:

  • EmptyStandbyList
  • Checking each of the ram sticks
  • All kinds of different settings
  • V sync
  • Ryzen Balanced / High performance power plan
  • Disabling Origin in-game
  • Lower resolutions
  • Switching to DX12
  • GameTime.MaxVariableFPS 72 and RenderDevice.RenderAheadLimit 2
  • Allocating different number of cores to the game
  • High priority in Task Manager
  • DDU
  • Clean install of Windows
  • Bumping the voltage up a bit to make sure the CPU is getting enough power


Every other game runs fine, though i get some stutters here and there in GTA V and Bioshock infinite. I hope someone can help, because i really like this game, but the stuttering is driving me crazy. Thanks in advance!

Link to comment
Share on other sites

Link to post
Share on other sites

is that your recording? I don't see the stuttering that you mean ?

You mean the stuttering of the players or your frames?

My Setup: 
CPU: i7 4790 @3800 MHz, MB: MSI H87-G41, Grafik: Gigabyte GTX 1080TI, RAM: 2x 8GB DDR3 (1600), Storage: Samsung SSD 850 Evo

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Mike87 said:

is that your recording? I don't see the stuttering that you mean ?

You mean the stuttering of the players or your frames?

I mean the frames. It's hard to see on the video, that's why i have the performance graph on. The yellow and green lines spike up when there is a stutter.

Link to comment
Share on other sites

Link to post
Share on other sites

7 minutes ago, Vux said:

I mean the frames. It's hard to see on the video, that's why i have the performance graph on. The yellow and green lines spike up when there is a stutter.

hmm... what exactly is the graph below? I thought it was the frametime, but it is at the top. 

 

I might have 2 tips you could try:

-Turning off the Win10 Gaming recording. Start-Settings-Games - deactivate the recording

-Turning off the "Control flow Guard, CFG" in Windows 10. Start-Settings-update and security-windows security-open windows security-apps and browsercontrol- at the bottom settings for exploit- deactivate it.

**Sorry if the instructions is not 100% correct, my windows is in german ;)

 

Try it out

 

My Setup: 
CPU: i7 4790 @3800 MHz, MB: MSI H87-G41, Grafik: Gigabyte GTX 1080TI, RAM: 2x 8GB DDR3 (1600), Storage: Samsung SSD 850 Evo

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Vux said:

I get really bad stuttering with a pc which should be able to run BF1 with zero issues. You can see the settings and everything else in this video.

My specs are:

  • CPU: AMD Ryzen 5 1600x
  • RAM: Kingston Hyperx Fury 2x4 GB 2666 Mhz + Ballistix Sport LT 2x4 GB 2666 Mhz
  • Motherboard: Gigabyte GA-AB350M-DS3H
  • GPU: Asus ROG Strix RX570
  • HDD: Toshiba DT01ACA100 1 TB
  • SSD: Samsung 860 Evo 250 GB
  • PSU: Corsair CX550M
  • Windows 10 Pro 64 bit


Everything is on stock. And the game is on the SSD, which has 80 GB left, so that isn't the issue.

I have tried:

  • EmptyStandbyList
  • Checking each of the ram sticks
  • All kinds of different settings
  • V sync
  • Ryzen Balanced / High performance power plan
  • Disabling Origin in-game
  • Lower resolutions
  • Switching to DX12
  • GameTime.MaxVariableFPS 72 and RenderDevice.RenderAheadLimit 2
  • Allocating different number of cores to the game
  • High priority in Task Manager
  • DDU
  • Clean install of Windows
  • Bumping the voltage up a bit to make sure the CPU is getting enough power


Every other game runs fine, though i get some stutters here and there in GTA V and Bioshock infinite. I hope someone can help, because i really like this game, but the stuttering is driving me crazy. Thanks in advance!

have you tried switching off HPET? in bios or in windows

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Vux said:

I get really bad stuttering with a pc which should be able to run BF1 with zero issues. You can see the settings and everything else in this video.

This video shows no "bad stuttering" at all. Your fps is pretty much locked at 70-72. Stuttering would show the fps drop below that. What you are seeing can be described as micro-stuttering.

 

This... "GameTime.MaxVariableFPS 72 and RenderDevice.RenderAheadLimit 2" is why your fps is locked at 70-72. I would set this back to how it was at default. Cap your fps at 72 with MSI AB if that's the fps you're trying to cap it at. Your in game settings show your monitor is 72 Hz? It that the max Hz of your monitor?

 

You could try using these settings to maximize performance without losing visual fidelity:

 

Anything to do with motion blur, chromatic abberation, dof, etc, turn them all OFF. Keep your field of view where you have it already though.

 

Direct X 12 - OFF (11 is what you want for better fps, using 12 has fps stuttering issues on certain maps)

Texture Quality - Ultra (dropping to low or medium from Ultra gives around 2-4% fps boost)

Texture Filtering - Ultra (dropping to low from Ultra gives around 2-3% fps boost, setting to medium may help with micro-stuttering)

Lighting Quality - Low (dropping to low from Ultra gives around 15% fps boost, set to medium or high for extra eye candy but expect loss in fps)

Effect Quality - Ultra (dropping to low from Ultra gives very little fps boost)

Post Process Quality - Low (dropping to low from Ultra gives around 15% fps boost)

Mesh Quality - High (dropping to low from Ultra gives around 5% fps boost, dropping below high introduces pop-ins)

Terrain Quality - Medium (very little fps impact, a minimum of medium introduces parallax, which makes rocks and dirt pop out and look better)

Undergrowth Quality - Low (this is personal preference but low gives an fps boost)

Antialiasing Post - TAA (leave this here no matter what, it makes things, especially trees, look much better, 7-8% fps boost on OFF though)

Ambient Occlusion - OFF (turning this off gives 10% fps boost and the game still looks amazing)

 

There are various guides on BF1 and they all seem to be from different times of the year so they will vary dramatically. Playing around with the settings yourself is the best way to determine boosts in fps. This guide is supposedly one of the best on the internet but I have found other good ones before as well. This guide right here though has animations you can click on for each setting to see exactly what each setting looks like.

 

Perfect example... Terrain Quality Low to Ultra Gif

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, Mike87 said:

hmm... what exactly is the graph below? I thought it was the frametime, but it is at the top. 

 

I might have 2 tips you could try:

-Turning off the Win10 Gaming recording. Start-Settings-Games - deactivate the recording

-Turning off the "Control flow Guard, CFG" in Windows 10. Start-Settings-update and security-windows security-open windows security-apps and browsercontrol- at the bottom settings for exploit- deactivate it.

**Sorry if the instructions is not 100% correct, my windows is in german ;)

 

Try it out

 

The graph below is also the frametime, but it shows the gpu and cpu frametime separately so you can see what is bittlenecking the pc. But my cpu is more than capable of running the game. I'll try those things when i get home. 

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, A Random Dude said:

This video shows no "bad stuttering" at all. Your fps is pretty much locked at 70-72. Stuttering would show the fps drop below that. What you are seeing can be described as micro-stuttering.

 

This... "GameTime.MaxVariableFPS 72 and RenderDevice.RenderAheadLimit 2" is why your fps is locked at 70-72. I would set this back to how it was at default. Cap your fps at 72 with MSI AB if that's the fps you're trying to cap it at. Your in game settings show your monitor is 72 Hz? It that the max Hz of your monitor?

 

You could try using these settings to maximize performance without losing visual fidelity:

 

Anything to do with motion blur, chromatic abberation, dof, etc, turn them all OFF. Keep your field of view where you have it already though.

 

Direct X 12 - OFF (11 is what you want for better fps, using 12 has fps stuttering issues on certain maps)

Texture Quality - Ultra (dropping to low or medium from Ultra gives around 2-4% fps boost)

Texture Filtering - Ultra (dropping to low from Ultra gives around 2-3% fps boost, setting to medium may help with micro-stuttering)

Lighting Quality - Low (dropping to low from Ultra gives around 15% fps boost, set to medium or high for extra eye candy but expect loss in fps)

Effect Quality - Ultra (dropping to low from Ultra gives very little fps boost)

Post Process Quality - Low (dropping to low from Ultra gives around 15% fps boost)

Mesh Quality - High (dropping to low from Ultra gives around 5% fps boost, dropping below high introduces pop-ins)

Terrain Quality - Medium (very little fps impact, a minimum of medium introduces parallax, which makes rocks and dirt pop out and look better)

Undergrowth Quality - Low (this is personal preference but low gives an fps boost)

Antialiasing Post - TAA (leave this here no matter what, it makes things, especially trees, look much better, 7-8% fps boost on OFF though)

Ambient Occlusion - OFF (turning this off gives 10% fps boost and the game still looks amazing)

 

There are various guides on BF1 and they all seem to be from different times of the year so they will vary dramatically. Playing around with the settings yourself is the best way to determine boosts in fps. This guide is supposedly one of the best on the internet but I have found other good ones before as well. This guide right here though has animations you can click on for each setting to see exactly what each setting looks like.

 

Perfect example... Terrain Quality Low to Ultra Gif

Does it matter? Micro stuttering or stuttering, its noticeable and annoying. And of course the fps is at 70, when the fps drops for a split second, it doesnt have time to detect it. Thats what the frametime graph is for. Also i have already tried different settings, and it didnt help. My gpu should be able to run the game at ultra with no issues. And it does, sometimes i get even 90 fps. So there is a different thing causing the stuttering.

Link to comment
Share on other sites

Link to post
Share on other sites

9 hours ago, Vux said:

Does it matter? Micro stuttering or stuttering, its noticeable and annoying.

If it's noticeable and annoying then of course it matters. 

9 hours ago, Vux said:

when the fps drops for a split second, it doesnt have time to detect it.

This is exactly what micro stuttering is. Which can be caused by this... "GameTime.MaxVariableFPS 72 and RenderDevice.RenderAheadLimit 2". Set this to default so that your fps isn't locked at 72. Then just lock your fps at 72 with MSI Afterburner from the Rivatuner settings framerate limiter. This might rid the micro stuttering.

9 hours ago, Vux said:

My gpu should be able to run the game at ultra with no issues. And it does, sometimes i get even 90 fps.

Certain maps online have a lot to do with fps issues in BF1. Does this same micro stuttering happen in the campaign?

9 hours ago, Vux said:

So there is a different thing causing the stuttering.

Stuttering can be caused by multiple things.

 

You could have RAM issues with that Ryzen CPU. I see that you are using just DDR4-2666 RAM and two different kinds of RAM at that. There could be a confliction with your BIOS there, especially if you have messed around with the voltage. They say Ryzen CPU's love at least DDR4-3000 RAM.

 

If what I am suggesting you do here with the 72 fps lock doesn't fix the issue, you at least rule it out and you can add it to that list.

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, A Random Dude said:

If it's noticeable and annoying then of course it matters. 

This is exactly what micro stuttering is. Which can be caused by this... "GameTime.MaxVariableFPS 72 and RenderDevice.RenderAheadLimit 2". Set this to default so that your fps isn't locked at 72. Then just lock your fps at 72 with MSI Afterburner from the Rivatuner settings framerate limiter. This might rid the micro stuttering.

Certain maps online have a lot to do with fps issues in BF1. Does this same micro stuttering happen in the campaign?

Stuttering can be caused by multiple things.

 

You could have RAM issues with that Ryzen CPU. I see that you are using just DDR4-2666 RAM and two different kinds of RAM at that. There could be a confliction with your BIOS there, especially if you have messed around with the voltage. They say Ryzen CPU's love at least DDR4-3000 RAM.

 

If what I am suggesting you do here with the 72 fps lock doesn't fix the issue, you at least rule it out and you can add it to that list.

But i have already tried what you said, and also limited in radeon settings, and turning the limiter altogether. Same exact issue every time. Whatever i do, it doesn't change a single thing.

Link to comment
Share on other sites

Link to post
Share on other sites

did you try my 2 tips? didn't help? :/ 

 

My Setup: 
CPU: i7 4790 @3800 MHz, MB: MSI H87-G41, Grafik: Gigabyte GTX 1080TI, RAM: 2x 8GB DDR3 (1600), Storage: Samsung SSD 850 Evo

Link to comment
Share on other sites

Link to post
Share on other sites

23 minutes ago, Mike87 said:

did you try my 2 tips? didn't help? :/ 

 

Yeah i tried, didn't help...

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, Vux said:

But i have already tried what you said, and also limited in radeon settings, and turning the limiter altogether. Same exact issue every time. Whatever i do, it doesn't change a single thing.

And the micro stuttering is in the campaign right?

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, A Random Dude said:

And the micro stuttering is in the campaign right?

Both campaign and multiplayer.

Link to comment
Share on other sites

Link to post
Share on other sites

7 hours ago, Vux said:

Both campaign and multiplayer.

Try this. Lock your fps at 60. Play BF1 for around 10 minutes and see if the micro stuttering is gone. Try to record 1 minute of the 10 minute game play around the middle of the 10 minutes. This isn't a solution, it's a troubleshooting step. Do this and report this 1 minute game play video to me. Make sure you are using MSI AB.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×