Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Anyone Have Issues With CableMod Recently?

FaultyWarrior
 Share

Wondering what's up with CableMod lately.  Ordered some stuff from them over the summer (Late July/early August) - no problems.  Cables were made within a week and arrived a few days later.

 

The time around, I placed an order 3 weeks ago.  They had some weird thing with the order that didn't pick up my color choice.  They emailed me about it the day after I placed the order, I replied back, and they acknowledged it and updated my order to reflect the correct color choice.  Several days later, I got an email saying my order was complete, and gave me a DHL tracking number.

 

It's been more than a week since then, and DHL still indicates that the "shipment info was received" - i.e. it's not been shipped, its just had a tracking number issued.

 

I've tried emailing them and contacting them via their web form several times, all with no reply.  I hate to go and whack them via PayPal, but they're holding up a build, and they're not even trying when contact goes unanswered for days on-end.  Also mind you, the stuff I ordered wasn't even custom - it was just their standard cable set for a Corsair RM-series!

 

Anyone else had issues with them as of late?

"VictoryGin"

Case: Define R6-S, Black | PSU: Corsair RM1000x, Custom CableMod Cables | Mobo: Asus ROG Zenith Extreme X399 | CPU: Threadripper 1950X | Cooling: Enermax Liqtech TR4 360mm AIO with Noctua NF-F12's | RAM: 64GB (8x8GB) G.SKILL Flare X DDR4-2400 | GPUs: AMD Radeon Vega Frontier Edition; NVIDIA Quadro P400 | Storage: 3x Intel 760p 128GB NVMe RAID-0 | I/O Cards: Blackmagic Intensity Pro, Mellanox ConnectX-3 Pro EN 40GbE NIC, StarTech FireWire, StarTech Serial/Parallel  | Monitors: 3x 30” First Semi F301GD @ 2560x1600, 60Hz; 50" Avera 49EQX20 @ 3840x2160, 60 Hz | Keyboard: Black/Gray Unicomp Classic | Mouse: Logitech MX Master 2S | OS: Windows 10 Enterprise LTSB 2016

Link to comment
Share on other sites

Link to post
Share on other sites

@CableMod might know about this.

 

I've not personally bought from them.

Quote or tag me( @Crunchy Dragon) if you want me to see your reply

If my post solved your problem/answered your question, please consider marking it as "solved"

Community Standards // PSU Tier List // Bugs and Issues // Join Floatplane! // Join the LTT Official Discord //

Link to comment
Share on other sites

Link to post
Share on other sites

Hopefully it's not something serious. I've had nothing but high praise for them in the past. I once had a cable start to fray within the first month of use, and they sent me a replacement no questions asked. They are one of my favorite enthusiast PC accessory companies, so I really hope this is just a fluke. 

Gaming build:

CPU: i7-7700k (5.0ghz, 1.312v)

GPU(s): Asus Strix 1080ti OC (~2063mhz)

Memory: 32GB (4x8) DDR4 G.Skill TridentZ RGB 3000mhz

Motherboard: Asus Prime z270-AR

PSU: Seasonic Prime Titanium 850W

Cooler: Custom water loop (420mm rad + 360mm rad)

Case: Be quiet! Dark base pro 900 (silver)
Primary storage: Samsung 960 evo m.2 SSD (500gb)

Secondary storage: Samsung 850 evo SSD (250gb)

 

Server build:

OS: Ubuntu server 16.04 LTS (though will probably upgrade to 17.04 for better ryzen support)

CPU: Ryzen R7 1700x

Memory: Ballistix Sport LT 16GB

Motherboard: Asrock B350 m4 pro

PSU: Corsair CX550M

Cooler: Cooler master hyper 212 evo

Storage: 2TB WD Red x1, 128gb OCZ SSD for OS

Case: HAF 932 adv

 

Link to comment
Share on other sites

Link to post
Share on other sites

My one and only experience with them was positive, which was a while back. Ideally they aren't getting screwed by something economically.

I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Skill Trident Z RGB - WD SN750 - Jedi Order Titan Xp - Hyper 212 Black (with RGB Riing flair) - EVGA G3 650W - dual booting Windows 10 and Linux - Black and green theme, Razer brainwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Dual Xeon X5560 - 24GB ECC DDR3 - GTX 750 TI - old Seagate 1.5TB HDD - dark mode Ubuntu (and Win7, cuz why not)

 

How many watts do I need? Seasonic Focus thread, PSU misconceptions, protections explainedgroup reg is bad

Link to comment
Share on other sites

Link to post
Share on other sites

I have used them once no issues - My experience with DHL however - ISSUES!  Slowest shipping company in the world.

 

I have had 2 builds held up by DHL.  Ordered all the 'ish from Newegg...Newegg places it all one Fed Ex sans the SSD every gosh darned time.  No they put the SSD on DHL.  So usually 3-5 days after I order the parts I stair at a pile of goodness waiting for the SSD to arrive...usually took a week or more.

 

Bought an SSD on Black Friday...they shipped it DHL...everything I got Black Friday from Newegg was on my doorstep by Tuesday the next week.  Got the SSD Monday this week.

Workstation Laptop: Dell Precision 7540, Xeon E-2276M, 32gb DDR4, Quadro T2000 GPU, 4k display

Ryzen Rig 3: ASRock B450m Pro4, Ryzen 5 3600, ARESGAME River 5 CPU cooler in push/pull, EVGA RTX 2060 KO, 16gb (2x8) 3600mhz TeamGroup T-Force RAM, ARESGAME AGV750w PSU, 1tb WD Black SN750 NVMe Win 10 boot drive, 3tb Hitachi 7200 RPM HDD, Fractal Design Focus G Mini custom painted.  Lenovo 27" 1080p 60hz placeholder monitor, generic mouse, generic keyboard.  Still a work in progress

NVIDIA GeForce RTX 2060 video card benchmark result - AMD Ryzen 5 3600,ASRock B450M Pro4 (3dmark.com)

Ryzen Rig 2: ASrock B450 Pro4, Ryzen 7 1700 @ 4.2ghz all core 1.4vCore, AMD R9 Fury X w/ Swiftech KOMODO waterblock, Custom Loop 2x240mm + 1x120mm radiators in push/pull 16gb (2x8) 3600mhz V-Color Skywalker (or 4x8gb DDR4 2666mhz for large tasks), Corsair HX850 PSU, 250gb Samsun 960 EVO NVMe Win 10 boot drive, 500gb Samsung 840 EVO SSD, 512GB TeamGroup MP30 M.2 SATA III SSD, SuperTalent 512gb SATA III SSD, CoolerMaster HAF XM Case.  Zalman K600S keyboard, Zalman ZM-GM1 mouse, Viotek GN24C 24" 1080p 144hz curved and Hannspree HF207 as 2nd monitor

https://www.3dmark.com/3dm/37004594?

Ryzen Rig 1: ASUS B350-PRIME ATX, Ryzen 7 1700, Sapphire R9 Fury Tri-X Nitro 4gb HBM, 16gb (2x8) 3200mhz V-Color Skywalker, ANTEC Earthwatts 750w PSU, MasterLiquid Lite 120 AIO cooler in Push/Pull config as rear exhaust, 250gb Samsung 850 Evo SSD, Patriot Burst 240gb SSD, Cougar MX330-X Case.  Zalman K600S keyboard, Zalman ZM-GM1 mouse, Acer XF270HU 2560x1440 144hz IPS monitor

https://www.3dmark.com/3dm/37628874?

Link to comment
Share on other sites

Link to post
Share on other sites

7 minutes ago, reniat said:

Hopefully it's not something serious. I've had nothing but high praise for them in the past. I once had a cable start to fray within the first month of use, and they sent me a replacement no questions asked. They are one of my favorite enthusiast PC accessory companies, so I really hope this is just a fluke. 

Same.  I've heard nothing but positives about them, and really like their stuff.

4 minutes ago, fasauceome said:

My one and only experience with them was positive, which was a while back. Ideally they aren't getting screwed by something economically.

Yup.  My first order was flawless.  Order to delivery was just under 2 weeks, cables were great.  No issues.

 

This time?  No clue what's going on.  I suppose it's possible they've been drowned in orders leading up to the holidays (which granted, I did place my order the weekend before Thanksgiving), but even still; I'd expect them to at least reply to an email or a message and let me know that they're behind on production.

"VictoryGin"

Case: Define R6-S, Black | PSU: Corsair RM1000x, Custom CableMod Cables | Mobo: Asus ROG Zenith Extreme X399 | CPU: Threadripper 1950X | Cooling: Enermax Liqtech TR4 360mm AIO with Noctua NF-F12's | RAM: 64GB (8x8GB) G.SKILL Flare X DDR4-2400 | GPUs: AMD Radeon Vega Frontier Edition; NVIDIA Quadro P400 | Storage: 3x Intel 760p 128GB NVMe RAID-0 | I/O Cards: Blackmagic Intensity Pro, Mellanox ConnectX-3 Pro EN 40GbE NIC, StarTech FireWire, StarTech Serial/Parallel  | Monitors: 3x 30” First Semi F301GD @ 2560x1600, 60Hz; 50" Avera 49EQX20 @ 3840x2160, 60 Hz | Keyboard: Black/Gray Unicomp Classic | Mouse: Logitech MX Master 2S | OS: Windows 10 Enterprise LTSB 2016

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Tristerin said:

I have used them once no issues - My experience with DHL however - ISSUES!  Slowest shipping company in the world.

 

I have had 2 builds held up by DHL.  Ordered all the 'ish from Newegg...Newegg places it all one Fed Ex sans the SSD every gosh darned time.  No they put the SSD on DHL.  So usually 3-5 days after I order the parts I stair at a pile of goodness waiting for the SSD to arrive...usually took a week or more.

 

Bought an SSD on Black Friday...they shipped it DHL...everything I got Black Friday from Newegg was on my doorstep by Tuesday the next week.  Got the SSD Monday this week.

Yes - THIS.  I ragequit like hell when I saw that my NAS got shipped via FedEx, yet NewEgg shipped the SSDs (FOR THE DAMN NAS!) via SmartPost or whatever...I've had the NAS for well over a week, and the stupid SSDs are just going out for delivery today!  Even worse-so, I ordered an SSD for my parents to replace a dying one for them over the holidays (yay for Chrismas-day IT work?!) - the got their drive within 3 days, and I used the free shipping option....

"VictoryGin"

Case: Define R6-S, Black | PSU: Corsair RM1000x, Custom CableMod Cables | Mobo: Asus ROG Zenith Extreme X399 | CPU: Threadripper 1950X | Cooling: Enermax Liqtech TR4 360mm AIO with Noctua NF-F12's | RAM: 64GB (8x8GB) G.SKILL Flare X DDR4-2400 | GPUs: AMD Radeon Vega Frontier Edition; NVIDIA Quadro P400 | Storage: 3x Intel 760p 128GB NVMe RAID-0 | I/O Cards: Blackmagic Intensity Pro, Mellanox ConnectX-3 Pro EN 40GbE NIC, StarTech FireWire, StarTech Serial/Parallel  | Monitors: 3x 30” First Semi F301GD @ 2560x1600, 60Hz; 50" Avera 49EQX20 @ 3840x2160, 60 Hz | Keyboard: Black/Gray Unicomp Classic | Mouse: Logitech MX Master 2S | OS: Windows 10 Enterprise LTSB 2016

Link to comment
Share on other sites

Link to post
Share on other sites

For the past week or two shipping (overall) seems to be slower than normal. My  "priority shipment" (Not the real name) was meant to take 3 days. It took 2 weeks.

I don't know if it's the same problem for you, but if it helps, I'm in the Houston(ish) area.

Fan Comparisons          F@H          PCPartPicker         Analysis of Market Trends (Coming soon? Never? Who knows!)

Designing a mITX case. Working on aluminum prototypes.

Open for intern / part-time. Good at maths, CAD and airflow stuff. Dabbled with Python.

Please fill out this form! It helps a ton! https://linustechtips.com/main/topic/841400-the-poll-to-end-all-polls-poll/

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Imbellis said:

For the past week or two shipping (overall) seems to be slower than normal. My  "priority shipment" (Not the real name) was meant to take 3 days. It took 2 weeks.

I don't know if it's the same problem for you, but if it helps, I'm in the Houston(ish) area.

Could very well be.  I'm in the Dallas area, so not horribly far off.

 

I had some CNC tooling I ordered from a company in Austin that normally shows up the next day take 4 days this time; so it does seem that carriers are running behind.

"VictoryGin"

Case: Define R6-S, Black | PSU: Corsair RM1000x, Custom CableMod Cables | Mobo: Asus ROG Zenith Extreme X399 | CPU: Threadripper 1950X | Cooling: Enermax Liqtech TR4 360mm AIO with Noctua NF-F12's | RAM: 64GB (8x8GB) G.SKILL Flare X DDR4-2400 | GPUs: AMD Radeon Vega Frontier Edition; NVIDIA Quadro P400 | Storage: 3x Intel 760p 128GB NVMe RAID-0 | I/O Cards: Blackmagic Intensity Pro, Mellanox ConnectX-3 Pro EN 40GbE NIC, StarTech FireWire, StarTech Serial/Parallel  | Monitors: 3x 30” First Semi F301GD @ 2560x1600, 60Hz; 50" Avera 49EQX20 @ 3840x2160, 60 Hz | Keyboard: Black/Gray Unicomp Classic | Mouse: Logitech MX Master 2S | OS: Windows 10 Enterprise LTSB 2016

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, FaultyWarrior said:

Could very well be.  I'm in the Dallas area, so not horribly far off.

 

I had some CNC tooling I ordered from a company in Austin that normally shows up the next day take 4 days this time; so it does seem that carriers are running behind. 

USPS was closed yesterday, and after talking to some workers, they say they've got a backlog right now.

Fan Comparisons          F@H          PCPartPicker         Analysis of Market Trends (Coming soon? Never? Who knows!)

Designing a mITX case. Working on aluminum prototypes.

Open for intern / part-time. Good at maths, CAD and airflow stuff. Dabbled with Python.

Please fill out this form! It helps a ton! https://linustechtips.com/main/topic/841400-the-poll-to-end-all-polls-poll/

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Imbellis said:

USPS was closed yesterday, and after talking to some workers, they say they've got a backlog right now.

Ah.  That would explain things.  I was trying to figure out why it took over a full day for that tooling package to get from the regional distribution center in my town to the local post office, which is literally 2 miles down the street.  Being closed this time of year would definitely do that.

"VictoryGin"

Case: Define R6-S, Black | PSU: Corsair RM1000x, Custom CableMod Cables | Mobo: Asus ROG Zenith Extreme X399 | CPU: Threadripper 1950X | Cooling: Enermax Liqtech TR4 360mm AIO with Noctua NF-F12's | RAM: 64GB (8x8GB) G.SKILL Flare X DDR4-2400 | GPUs: AMD Radeon Vega Frontier Edition; NVIDIA Quadro P400 | Storage: 3x Intel 760p 128GB NVMe RAID-0 | I/O Cards: Blackmagic Intensity Pro, Mellanox ConnectX-3 Pro EN 40GbE NIC, StarTech FireWire, StarTech Serial/Parallel  | Monitors: 3x 30” First Semi F301GD @ 2560x1600, 60Hz; 50" Avera 49EQX20 @ 3840x2160, 60 Hz | Keyboard: Black/Gray Unicomp Classic | Mouse: Logitech MX Master 2S | OS: Windows 10 Enterprise LTSB 2016

Link to comment
Share on other sites

Link to post
Share on other sites

@FaultyWarrior around this time of the year the couriers are usually pretty hammered with Black Friday, Cyber Monday, and upcoming Christmas shipments so there can be backlog and slower delivery times. Not really something we can help unfortunately, just depends on how many shipments they're processing each day on how quickly they're able to get to the next one. We have also had a lot of orders coming in though too so processing times on our end are a little longer than normal as well though but we're continually working to hammer orders out as quick as possible with a strong attention to quality being maintained of course. :)

Link to comment
Share on other sites

Link to post
Share on other sites

On 12/7/2018 at 4:18 PM, CableMod said:

@FaultyWarrior around this time of the year the couriers are usually pretty hammered with Black Friday, Cyber Monday, and upcoming Christmas shipments so there can be backlog and slower delivery times. Not really something we can help unfortunately, just depends on how many shipments they're processing each day on how quickly they're able to get to the next one. We have also had a lot of orders coming in though too so processing times on our end are a little longer than normal as well though but we're continually working to hammer orders out as quick as possible with a strong attention to quality being maintained of course. :)

OK.  I heard back from CableMod, and they confirmed that my order did indeed ship.  So this lies at DHL's feet.

 

If I don't see the tracking move by Tuesday, I'll call them and chew them out...there's no excuse for them to need more than TWO WEEKS just to acknowledge that they've taken possession of a package; especially when their site claims "normal delivery is usually within 2-3 days".

 

EDIT:

Woke up this morning to a text from DHL...seems something kicked their butts into gear...package processed and will be delivered Tuesday.

"VictoryGin"

Case: Define R6-S, Black | PSU: Corsair RM1000x, Custom CableMod Cables | Mobo: Asus ROG Zenith Extreme X399 | CPU: Threadripper 1950X | Cooling: Enermax Liqtech TR4 360mm AIO with Noctua NF-F12's | RAM: 64GB (8x8GB) G.SKILL Flare X DDR4-2400 | GPUs: AMD Radeon Vega Frontier Edition; NVIDIA Quadro P400 | Storage: 3x Intel 760p 128GB NVMe RAID-0 | I/O Cards: Blackmagic Intensity Pro, Mellanox ConnectX-3 Pro EN 40GbE NIC, StarTech FireWire, StarTech Serial/Parallel  | Monitors: 3x 30” First Semi F301GD @ 2560x1600, 60Hz; 50" Avera 49EQX20 @ 3840x2160, 60 Hz | Keyboard: Black/Gray Unicomp Classic | Mouse: Logitech MX Master 2S | OS: Windows 10 Enterprise LTSB 2016

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×