Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Samsung TV can't handle windows 10 HDR (or vica versa)

Recommended Posts

Posted · Original PosterOP



So, I know this probably isn't the first time this topic has been posted, and I know there's probably no solution, but I've been trying for the last 4 hours to get my PC to output HDR picture to my PC. I've just ran my last experiment and I officially have no idea what to do (I'm guessing at this point there's nothing to be done).


I have a Samsung ue50ru7102 smart TV. I quickly found that you need to enable HDR support in the TV for the HDMI port, it's under a setting called "Input signal plus". However. When I first tried this, the picture on the TV was screwed up, stretched beyond the borders of the screen, and it was mostly green and a bit of purple (but the desktop was recognizable). Then I tried to restart the PC I think and I ended up having no signal on the TV from the PC if the Input signal plus is turned on. What's funny is that even my monitor, which is connected to the PC through a Display Port, looses signal if the option in the TV is turned on. I tried the suggested route that Samsung has on it's support site, to make a custom resolution and use the polarities given there, but when I tried this I didn't get a signal either (even with the Input signal plus turned off). So that didn't help. Lastly I tried to run a game that I think supports HDR, which was RDR2 (maybe I should try a different game, since I've read HDR support isn't epecially good with RDR2). What I wanted to see is if the fullscreen option circumvents some option on the PC that leads to the signal loss. And sure enough, I fired up RDR2, didn't even load a game, just in the menu, I turned on the Input signal plus for the HDMI port and it worked. Sorta... The picture was washed out and I didn't have sound. Now, I'm pretty sure the cable I bought is HDR capable, however I can't find on the box if it is, and I can't find if it's HDMI 2 or not. It just says High speed HDMI cable, and that it's UHD ready. Trouble is that the cable that was labeled HDMI 2 was only 3m and I need a 5m long one. But I'm pretty sure it's not the cable... like, at least 87% sure. Anyway, back to RDR2, the TV finally said it's running in HDR mode. I bucked the resolution to 1080p and restarted the game, now I had sound as well. However, I didn't have the HDR calibration option in the options menu.


So meanwhile I spent hours searching the net, didn't find any solution, only that some people had success with a display port to hdmi adapter. It seems to me that there's some deep rooted problem in Windows 10 that crashes all display out signals or display signal processing when this TV is connected. I don't have any other HDR ready displays, so I can't test further. But when the windows side of things is circumvented via a fullscreen game that takes over the display output, it kinda works I guess.


I'm using an RTX 2070 super.

"Same rules since the first man picked up the first stick and beat the second man's ass with it."

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now