Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Cipulot99

MX Master 3 Horizontal Scroll in VSCode

Recommended Posts

Posted · Original PosterOP

Hello there,

 

I've bought a couple of weeks ago a MX Master 3 to replace my old MX Master. I do programming most of the time and I use Visual Studio and VS Code most of the time.

 

I have a problem using the horizontal scroll wheel to navigate my code, even tho the option is enabled in both programs.

In the Logitech Options configuration I've assigned horizontal scroll to the wheel but it doesn't seems to work. I'm not the only one with this problem in the VS community and no "clear" solution was given by the vscode team on github.

 

It seems that there is a problem with a feature like "horizontal tab" or something like that.....I don't remember the exact name of that.

I know for a fact that some apps need a special implementation to get horizontal scroll to work, like the one with app specific profile (excel and word in the photo).

image.png.592ccfb717eeb53c7446932572dfcb6c.png

 

Does anybody having the same issue solved it or know a workaround? I noticed a thing called "developer mode" in the Logitech app, maybe I can develop a custom addin for specific app like the one mentioned above.

Link to post
Share on other sites

@Cipulot99 looks like others have had this issue as well, someone posted a work around (from 2018 so may no longer work):

Quote

windows 10 Pro, build 1809, VSCode 1.31.1
Logitech MX anywhere 2S works only after:

  1. opening vscode
  2. minimizing it explicitly using the mouse by clicking the hyphen (super-key + down-arrow does not work)
  3. restore the vscode window by clicking the icon in the taskbar

this procedure should be repeated every time you open vscode

I personally haven't tried using my MX Master Mouse 2S in VSCode, but I know that for some applications (Excel), I know that I have to roll the horizontal wheel each direction a few times before the application "catches up." I did a search for the issue and found the above linked issue, but there were several more, so others may have found newer/better work arounds if you do some digging. Good luck!


 

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, burh4n said:

@Cipulot99 looks like others have had this issue as well

Yeah, I see tons of issues about it but every time the vscode bot keeps closing the posts before someone can even respond......lol

Link to post
Share on other sites
4 minutes ago, Cipulot99 said:

Yeah, I see tons of issues about it but every time the vscode bot keeps closing the posts before someone can even respond......lol

🤷‍♂️

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×