Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
RileyTheFox

High CPU usage with kswapd0 (Ubuntu)

Recommended Posts

Posted · Original PosterOP

Hey. Over the past few days my VPS has been pinned to 100% CPU usage by the process 'kswapd0'. Using the top command, this is the information I get:

image.png.56a7f3634fb651bd1a1491d0004bf38d.png

 

The user sidney is just a friend's user account, and the kswapd0 issue only occurs from there. I tried deleting the user account and remaking it (in case there was anything that got corrupted) and after deletion, the problem was solved. But soon after recreation the problem arose again.

 

Multiple sources online tell me to run "echo 1 > /proc/sys/vm/drop_caches" but this also achieves nothing. The system is consistently pinned to 100%. I dabbled in killing the kswapd0 process, and that solved the problem, however that means swap is no longer running (and it could be unstable too?)

 

This has only started happening since around a week ago. I've tried a kernel upgrade to see if that would solve anything but nothing worked. Even the VPS company's support couldn't help me after so long.

 

Does anyone have any solution to this? Thanks.


CPU: Intel Core i7 8700  

GPU: Gigabyte GeForce GTX 1070

MOBO: ASUS Z370-F STRIX  

RAM: 16GB Corsair Vengeance DDR4 2133MHz

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×