Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Posted · Original PosterOP

Edit: i fixed it there was an extra motherboard stand in the case must have been shorting it 

 

 

Parts list 

Cpu: amd ryzen 5 3600

mb: gigabyte aorus elite 

Ram: g.skill ripjaws ddr4 3600mhz cl18

gpu: gigabyte rtx 2070 super oc 3x

Psu: apex gaming 650w 80+ gold

Case: (new) deepcool matrexx 55 mesh

(Old) coolermaster something 

 

So i swapped my personal pc into a new case and now it's not working and i have no clue why I've tried one stick of ram and clearing cmos. I have also tried a ryzen 3 3200g that also didn't work. Tried to reseat the gpu and ram.  kinda stuck 

 

Link to post
Share on other sites
Posted · Original PosterOP

The led on the motherboard sits on dram for a few seconds then goes to vga and cycles 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×