Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TheGrouch

Can't enter BIOS, please halp :(

Recommended Posts

Posted · Original PosterOP

Please halp, I've just built my first system by myself and all has gone OK up until now. I've plugged it in to turn on for the first time and my monitor shows the Asus logo as I'm using an Asus prime x570-p with a ryzen 3600, ans it says to press delete or F2 to enter the bios however nothing happens when i do. I've tried tapping it continuously as soon as I turn the pc on, I've tried slow, fast, nothing at all, different keyboard, different USB ports, but no luck 😢 If anyone knows what the issue is or how to fix it this would be a huge help! Thankyou in advance 

Link to post
Share on other sites
2 minutes ago, TheGrouch said:

Please halp, I've just built my first system by myself and all has gone OK up until now. I've plugged it in to turn on for the first time and my monitor shows the Asus logo as I'm using an Asus prime x570-p with a ryzen 3600, ans it says to press delete or F2 to enter the bios however nothing happens when i do. I've tried tapping it continuously as soon as I turn the pc on, I've tried slow, fast, nothing at all, different keyboard, different USB ports, but no luck 😢 If anyone knows what the issue is or how to fix it this would be a huge help! Thankyou in advance 

have you tried spamming the DELETE key upon startup too?


I apologize for the way I am. If my post seemed rude, that was not my intention. Just my ineptness in forming a nice coherent message.

"Why do we suffer a lifetime for a moment of happiness?" - Anonymous

"FuryBSD, name of your sex tape" - Alex Clark

"How long do I have to keep going on? Someone end it already"

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, minibois said:

have you tried spamming the DELETE key upon startup too?

Yeah, I've tried everything I can think of and i can't find anything online apart from restarting to the bios from Windows, but i cant do that because I don't have Windows installed yet

Link to post
Share on other sites
11 minutes ago, TheGrouch said:

Yeah, I've tried everything I can think of and i can't find anything online apart from restarting to the bios from Windows, but i cant do that because I don't have Windows installed yet

Try pressing F11, F12, F2 and DEL upon startup.

You mentioned trying out different keyboards. Were any of the boards you tried more 'basic' boards? Sometimes the  gaming boards don't really work nicely.


I apologize for the way I am. If my post seemed rude, that was not my intention. Just my ineptness in forming a nice coherent message.

"Why do we suffer a lifetime for a moment of happiness?" - Anonymous

"FuryBSD, name of your sex tape" - Alex Clark

"How long do I have to keep going on? Someone end it already"

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, minibois said:

Try pressing F11, F12, F2 and DEL upon startup.

You mentioned trying out different keyboards. Were any of the boards you tried more 'basic' boards? Sometimes the  gaming boards don't really work nicely.

Thanks, I've not tried f11 or f12 I'll give that a go. And the 2 keyboards I tried were a corsair strafe rgb and a very basic Microsoft keyboard, neither seem to work but I know do work normally 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×