Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
DarkEnergy

Monitor issues

I am replying with a temporary solution I have found in case someone runs into a similar issue. For reference, my monitor is an Asus VS239H with a display of 1920x1080 60hz.

 

TLDR: Download "Custom Resolution Utility" by ToastyX, edit the "Generic Non-PnP Monitor" profile (assuming this is the active profile) by adding your monitor resolution and display Hz. Restart computer and within windows try to enable the resolution you added in windows settings.

 

 

I think that part of the root problem is that the monitor is not telling the computer what it is when in HDMI mode. For instance in device manager it shows up as "Generic Non-PnP Monitor." This is not a windows or a computer issue. Even Ubuntu will not recognize the monitor. That said, the monitor works fine on a VGA connection. My solution was a program called "Custom Resolution Utility" by ToastyX. Within that utility, it shows active and non-active profiles. The active profile was "Generic Non-PnP Monitor." It also lists profiles that appear to be what SHOULD be active such as "Asus VS239." Clearly that profile exists but there is no option to activate it. Instead I edited the Generic Non-PnP Monitor profile. Within that profile I added a resolution in the "standard resolutions" section (which originally contained no listed resolutions). I added 1920x1080 @60 Hz. After that the program showed the profile status as "restart required." I restarted the computer. After this, I went into Windows 10 display settings and the option for 1920x1080 was there. The monitor is now functional.***

***Functional in that it only works in windows. Since no computers will not recognize it by default, I can no longer get a splash screen or windows loading screen when booting the computer. However once windows is loaded in, it will work. 

Annotation 2020-04-11 130409.png

Recommended Posts

Posted · Original PosterOP

I have no idea if this is a thing. Someone gave me a second monitor so I unplugged mine to test it out. The second monitor looked quite bad so I hooked up my original again except now I'm having issues. My original monitor is 1920x1080. It's about 8 years old and HDMI. When I first hooked it up everything looked pixelated and blurry. I tried restarting my computer but that didn't fix the issue. Resetting the monitor settings didn't do anything. The monitor shows 480p and Windows is only detecting 480p as the maximum resolution supported. I tried hooking the monitor up to my laptop, which didn't even detect a monitor (it used to work fine). It's not the HDMI cable, I tested with another. What could possible have died?

 

IMG_20200405_181508.jpg

IMG_20200405_182818.jpg


 

CPU - FX 8350 @ 4.5GHZ GPU - Radeon 5700  Mobo - M5A99FX Pro R2.0 RAM - Crucial Ballistix 16GB @ 1600 PSU - Corsair CX600M CPU Cooler - Hyper 212 EVO Storage - Samsung EVO 250GB, WD Blue 1TB

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

I am replying with a temporary solution I have found in case someone runs into a similar issue. For reference, my monitor is an Asus VS239H with a display of 1920x1080 60hz.

 

TLDR: Download "Custom Resolution Utility" by ToastyX, edit the "Generic Non-PnP Monitor" profile (assuming this is the active profile) by adding your monitor resolution and display Hz. Restart computer and within windows try to enable the resolution you added in windows settings.

 

 

I think that part of the root problem is that the monitor is not telling the computer what it is when in HDMI mode. For instance in device manager it shows up as "Generic Non-PnP Monitor." This is not a windows or a computer issue. Even Ubuntu will not recognize the monitor. That said, the monitor works fine on a VGA connection. My solution was a program called "Custom Resolution Utility" by ToastyX. Within that utility, it shows active and non-active profiles. The active profile was "Generic Non-PnP Monitor." It also lists profiles that appear to be what SHOULD be active such as "Asus VS239." Clearly that profile exists but there is no option to activate it. Instead I edited the Generic Non-PnP Monitor profile. Within that profile I added a resolution in the "standard resolutions" section (which originally contained no listed resolutions). I added 1920x1080 @60 Hz. After that the program showed the profile status as "restart required." I restarted the computer. After this, I went into Windows 10 display settings and the option for 1920x1080 was there. The monitor is now functional.***

***Functional in that it only works in windows. Since no computers will not recognize it by default, I can no longer get a splash screen or windows loading screen when booting the computer. However once windows is loaded in, it will work. 

Annotation 2020-04-11 130409.png


 

CPU - FX 8350 @ 4.5GHZ GPU - Radeon 5700  Mobo - M5A99FX Pro R2.0 RAM - Crucial Ballistix 16GB @ 1600 PSU - Corsair CX600M CPU Cooler - Hyper 212 EVO Storage - Samsung EVO 250GB, WD Blue 1TB

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×