Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
What do I have to put here

One side of my monitor is really unclear.

Recommended Posts

One of 2 things, damage or tn panel
If it's a tn panel, then it's supposed to do that
 


CPU: Intel core i7-8086K Case: CORSAIR Crystal 570X RGB CPU Cooler: Corsair Hydro Series H150i PRO RGB Storage: Samsung 960 EVO Series - 1TB PCIe NVMe - M.2 Internal PSU: EVGA 1000 GQ, 80+ GOLD 1000W, Semi Modular GPU: GeForce RTX 2080 GAMING X TRIO RAM: Corsair Dominator Platinum 32GB (2 x 16GB) DDR4 3200mhz Motherboard: Asus ROG STRIX Z370-E Gaming

Link to post
Share on other sites
1 minute ago, What do I have to put here said:

It's an Ips display and it's the first time that happened. So you think it's damaged?

Not uncommon to be damaged with the run down you gave.
3 most likely would be heat, weakening backlight, or improperly attached panels


CPU: Intel core i7-8086K Case: CORSAIR Crystal 570X RGB CPU Cooler: Corsair Hydro Series H150i PRO RGB Storage: Samsung 960 EVO Series - 1TB PCIe NVMe - M.2 Internal PSU: EVGA 1000 GQ, 80+ GOLD 1000W, Semi Modular GPU: GeForce RTX 2080 GAMING X TRIO RAM: Corsair Dominator Platinum 32GB (2 x 16GB) DDR4 3200mhz Motherboard: Asus ROG STRIX Z370-E Gaming

Link to post
Share on other sites
1 minute ago, What do I have to put here said:

Is there no way to fix it?

If it's a lose part, you can try smacking it firmly, but try taking it to a repair center to see what a professional might put it as.

Also check if this isn't a common issue with your monitor


CPU: Intel core i7-8086K Case: CORSAIR Crystal 570X RGB CPU Cooler: Corsair Hydro Series H150i PRO RGB Storage: Samsung 960 EVO Series - 1TB PCIe NVMe - M.2 Internal PSU: EVGA 1000 GQ, 80+ GOLD 1000W, Semi Modular GPU: GeForce RTX 2080 GAMING X TRIO RAM: Corsair Dominator Platinum 32GB (2 x 16GB) DDR4 3200mhz Motherboard: Asus ROG STRIX Z370-E Gaming

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Jumballi said:

If it's a lose part, you can try smacking it firmly, but try taking it to a repair center to see what a professional might put it as.

Also check if this isn't a common issue with your monitor

Ok thanks.

Link to post
Share on other sites

Start by checking the cable... Also does it do that all the time or only in some programs


F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX2080S, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites

Checking it's well plugged, and yes try another too 


F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX2080S, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites

Sounds like dead monitor then.


F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX2080S, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites
24 minutes ago, What do I have to put here said:

I tried re plugging my cable and tried an other one as well nothing worked. 

Can you provide a picture of the screen (so the clear/7’clear, and what model is it?

 

did you notice anything previous odd with how the monitor displayed things?

 

checked that all cables are plugged in correctly ? Are you using hdmi or DP?


 

MSI B450 Pro Gaming Pro Carbon AC | AMD Ryzen 2700x  | NZXT  Kraken X52  MSI GeForce RTX2070 Armour | Corsair Vengeance LPX 16GB 3200MhZ | Samsung 970 evo M.2nvme 500GB Boot  / Samsung 860 evo 500GB SSD | Corsair RM550X (2018) | Fractal Design Meshify C white | Logitech G pro WirelessGigabyte Aurus AD27QD 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×