Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Alphaxir

Both RAM sticks and slots work, but only half of my ram is available.

Recommended Posts

Posted · Original PosterOP

So i have 2 x 4gb RAM sticks installed on a new pc, however when i open the BIOS and task manager, it only shows 4gb. 

 

I isolated the sticks and tried both of them in each slot, and each time it loaded up with 4gb, so the sticks and the slots are both fine.

 

How can i fix this?

 

Specs:

Windows 10

x64

AMD Ryzen 3 2300X Quad Core, 3500Mhz

Nvidia Geforce GTX 1050

2 x 4gb ADATA RAM sticks

 

Thanks in advance!

 

Link to post
Share on other sites

Do you happen to know the make and model of your motherboard? does it have 2 or 4 ram slots? could be a dual channel issue where you have placed in slots 1+2 rather than 1+3 or 2+4.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Scott Macbeth said:

Do you happen to know the make and model of your motherboard? does it have 2 or 4 ram slots? could be a dual channel issue where you have placed in slots 1+2 rather than 1+3 or 2+4.

My motherboard is the MS-7C51, and there is 2 slots, which both have ram sticks in :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×