Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Niekao

Laptop not using dedicated GPU

Recommended Posts

Posted · Original PosterOP

So when I play games on my laptop, I noticed that it doesn’t use my dedicated GPU. Does anyone know a fix for this? I already have set the settings in 3D graphics in the nvidia control panel to use the powerfull one, but that didnt work. 

A58C2D4F-6A61-45C7-B132-636F9F7650AD.jpeg

Link to post
Share on other sites

Not sure why but some tips that might help. 

Reinstall newest drivers from nVidia website

Try setting the game to use nVidia gpu manually not system wide but for civ 6 exactly.

 

Make sure your gpu works at all, get some kind of stress test program like aida64 and test the gpu. 

 

Worst case scenario try reinstalling windows. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×