Jump to content

R9 390X GPU Usage fluctuation

Hello, sorry to be a bother again seeing as I just posted a question not to long ago on this forum, was just hoping someone could help a person out.
 

 Picture shows a TLDR of what is happening while in game.

So, I was running MSI Afterburner and noticed while I was playing Star Citizen, and a couple other games, I noticed that the GPU usage was going from 100% down to 0% then back up constantly.

This isn't due to heat as the highest temp recorded is 76C.

The Core clock also doesn't go to the full clock speed when game, it sits around 600 MHZ and goes up and down (specifically in Star Citizen), making the frame rate spike at times.

If anyone has any ideas as to what this is and how to fix it, it would be greatly appreciated. Thank you!

Rig Specs in case you need them for some reason..

Chasis: Coolermaster Storm Stryker
Motherboard: MSI Z87-G45
GPU: MSI R9 390X
Processor: Intel Core i7-4790K
RAM: G.SKILL Ripjaws X Series 8GB (2 x 4GB)
CPU Cooler: Cooler Master H100i
PSU: EVGA 1000W G2 
Display: 1080P ASUS VE278 Monitor (x3)

post-258221-0-59522600-1450684455.png

Link to comment
Share on other sites

Link to post
Share on other sites

Star Citizen is not optimized

 

even rigs with 980Ti will not get over 90% GPU usage

 

try with Crysis 3 and you see the graphs

 

Unigine Heaven will also tell the correct story

Budget? Uses? Currency? Location? Operating System? Peripherals? Monitor? Use PCPartPicker wherever possible. 

Quote whom you're replying to, and set option to follow your topics. Or Else we can't see your reply.

 

Link to comment
Share on other sites

Link to post
Share on other sites

I usually get that with unoptimized game/cpu limited game.

| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to comment
Share on other sites

Link to post
Share on other sites

Star Citizen is not optimized

 

even rigs with 980Ti will not get over 90% GPU usage

 

try with Crysis 3 and you see the graphs

 

Unigine Heaven will also tell the correct story

Nice to see you again, haha. I will definitely check that out right now and come back to you with the results.

Also, really wish I knew why the clock speed won't max out when in GTA 5 for example. I just switched over from an Nvidia card so I guess the GPUs work a bit differently, but while in a game, the clock speed would max out on the GTX 770.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Nice to see you again, haha. I will definitely check that out right now and come back to you with the results.

Also, really wish I knew why the clock speed won't max out when in GTA 5 for example. I just switched over from an Nvidia card so I guess the GPUs work a bit differently, but while in a game, the clock speed would max out on the GTX 770.

 

did you do a proper full uninstall and install the AMD driver?

 

use Display Driver Uninstall

 

because i suspect it a old nVidia drivers lingering in your PC

Budget? Uses? Currency? Location? Operating System? Peripherals? Monitor? Use PCPartPicker wherever possible. 

Quote whom you're replying to, and set option to follow your topics. Or Else we can't see your reply.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Nice to see you again, haha. I will definitely check that out right now and come back to you with the results.

Also, really wish I knew why the clock speed won't max out when in GTA 5 for example. I just switched over from an Nvidia card so I guess the GPUs work a bit differently, but while in a game, the clock speed would max out on the GTX 770.

 

Its something to do with some AMD feature. Not sure if its powerplay or ulps. The card will downclock in correspondent to the gpu usage. You might want to turn those either one of those features off. 

i5 2400 | ASUS RTX 4090 TUF OC | Seasonic 1200W Prime Gold | WD Green 120gb | WD Blue 1tb | some ram | a random case

 

Link to comment
Share on other sites

Link to post
Share on other sites

did you do a proper full uninstall and install the AMD driver?

use Display Driver Uninstall

because i suspect it a old nVidia drivers lingering in your PC

I already used DDU before installing my new graphics card a few days ago. Everything Nvidia is off of my pc.

Link to comment
Share on other sites

Link to post
Share on other sites

Its something to do with some AMD feature. Not sure if its powerplay or ulps. The card will downclock in correspondent to the gpu usage. You might want to turn those either one of those features off.

Any idea how I would go about turning that off? Would it be in the crimson driver?

Link to comment
Share on other sites

Link to post
Share on other sites

I already used DDU before installing my new graphics card a few days ago. Everything Nvidia is off of my pc.

ok try with Unigine heaven and test

 

watch the load,speed and temps

Budget? Uses? Currency? Location? Operating System? Peripherals? Monitor? Use PCPartPicker wherever possible. 

Quote whom you're replying to, and set option to follow your topics. Or Else we can't see your reply.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Any idea how I would go about turning that off? Would it be in the crimson driver?

You can do it in the registry editor by finding "enable ulps" and set it to 0 instead of 1. 

Current PC: Origin Millennium- i7 5820K @4.0GHz | GTX 980Ti SLI | X99 Deluxe 

 

Link to comment
Share on other sites

Link to post
Share on other sites

You can do it in the registry editor by finding "enable ulps" and set it to 0 instead of 1. 

MSI Afterburner has the toggle

Budget? Uses? Currency? Location? Operating System? Peripherals? Monitor? Use PCPartPicker wherever possible. 

Quote whom you're replying to, and set option to follow your topics. Or Else we can't see your reply.

 

Link to comment
Share on other sites

Link to post
Share on other sites

MSI Afterburner has the toggle

That makes it a lot easier. Thank you ha-ha. Also, will report back with uniengine. Currently in bed right now. Will get them to you tomorrow asap. Thank you for all the help really means a lot.
Link to comment
Share on other sites

Link to post
Share on other sites

MSI Afterburner has the toggle

 

That makes it a lot easier. Thank you ha-ha. Also, will report back with uniengine. Currently in bed right now. Will get them to you tomorrow asap. Thank you for all the help really means a lot.

Registry editor is almost just as easy and a more permanent fix because it doesn't get reset with software updates.

Current PC: Origin Millennium- i7 5820K @4.0GHz | GTX 980Ti SLI | X99 Deluxe 

 

Link to comment
Share on other sites

Link to post
Share on other sites

GPU Usage:

http://i.imgur.com/0K40S6q.png

Max temp was 73C

Core clock bounced around a bit.

 

Did you overclock?

| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to comment
Share on other sites

Link to post
Share on other sites

Did you overclock?

Not at all. Have not touched the clock speed on anything yet.
Link to comment
Share on other sites

Link to post
Share on other sites

  • 1 month later...

Hey guys,

Having the same issue with my new R9. Also the fans do a similar spike. not as frequently as the gpu usage.

Any ideas?

Also, While playing WoW there is a drop in FPS when ever I go into a new zone or enter a town with people.

Whats with that?

Link to comment
Share on other sites

Link to post
Share on other sites

Hey guys,

Having the same issue with my new R9. Also the fans do a similar spike. not as frequently as the gpu usage.

Any ideas?

Also, While playing WoW there is a drop in FPS when ever I go into a new zone or enter a town with people.

Whats with that?

 

Many new 300 series cards have fan off feature. 

 

Drops in fps when you load a new area or are in an area full of players are normal. That happens in nearly ALL mmos. 

i5 2400 | ASUS RTX 4090 TUF OC | Seasonic 1200W Prime Gold | WD Green 120gb | WD Blue 1tb | some ram | a random case

 

Link to comment
Share on other sites

Link to post
Share on other sites

Hey guys,

Having the same issue with my new R9. Also the fans do a similar spike. not as frequently as the gpu usage.

Any ideas?

Also, While playing WoW there is a drop in FPS when ever I go into a new zone or enter a town with people.

Whats with that?

Most MMOs care about your CPU than your graphics card.

CPU i7 6700 Cooling Cryorig H7 Motherboard MSI H110i Pro AC RAM Kingston HyperX Fury 16GB DDR4 2133 GPU Pulse RX 5700 XT Case Fractal Design Define Mini C Storage Trascend SSD370S 256GB + WD Black 320GB + Sandisk Ultra II 480GB + WD Blue 1TB PSU EVGA GS 550 Display Nixeus Vue24B FreeSync 144 Hz Monitor (VESA mounted) Keyboard Aorus K3 Mechanical Keyboard Mouse Logitech G402 OS Windows 10 Home 64 bit

Link to comment
Share on other sites

Link to post
Share on other sites

Hey guys. Thank you for the replies. The fan off feature does kick in when the gpu isnt in use. But this is what is really worrying me.

post-308331-14536787793695_thumb.jpgpost-308331-14536787992804_thumb.jpg

I have logged the usage over a couple of hours of WOW and will post those up later.

Am wondering if the card is getting enough power. Will try hooking it up with separate 6 and 8 pin cables later tonight.

Edit : So i found this post on youtube and tried it. Seems to have helped with the gpu spikes. How ever the fans are still not letting me personalise the settings.

d27061d84c0a008be6d8865b8e0f8f5e.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×